<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>Arduino Nicla Vision integrates STM32H7 MCU with Wi-Fi, BLE and camera support</title> 

<meta name="generator" content="WordPress 5.9.3" /> <!-- leave this for stats -->

<link rel="stylesheet" href="https://linuxgizmos.com/wp-content/themes/lg-theme/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com RSS Feed" href="https://linuxgizmos.com/feed/" />

<link rel="pingback" href="https://linuxgizmos.com/xmlrpc.php" />

<!-- G+ author attribution -->
<link rel="author" href="https://plus.google.com/104414840801731506333" />

<style type="text/css" media="screen">
	#headerimg { margin: 0; margin-top: 0px; height: 80px; width: 1022px; }
	#headerimg { background: url('https://linuxgizmos.com/wp-content/themes/lg-theme/images/header.jpg') no-repeat top;}
</style>

<script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&amp;version=v2.6";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v18.7 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Geniatech’s 96Boards CE Extended form-factor “Ahaura” and “Akitio” SBCs run Linux on Renesas’ 1.2GHz, dual -A55 RZ/G2L and NPU-equipped RZ/V2L variant, respectively, and offer up to 8GB RAM and 128GB eMMC, 2x GbE, 3x USB, HDMI, and 4G LTE." />
	<link rel="canonical" href="https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Arduino Nicla Vision integrates STM32H7 MCU with Wi-Fi, BLE and camera support" />
	<meta property="og:description" content="Geniatech’s 96Boards CE Extended form-factor “Ahaura” and “Akitio” SBCs run Linux on Renesas’ 1.2GHz, dual -A55 RZ/G2L and NPU-equipped RZ/V2L variant, respectively, and offer up to 8GB RAM and 128GB eMMC, 2x GbE, 3x USB, HDMI, and 4G LTE." />
	<meta property="og:url" content="https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/" />
	<meta property="og:site_name" content="LinuxGizmos.com" />
	<meta property="article:publisher" content="http://facebook.com/LinuxGizmos" />
	<meta property="article:published_time" content="2022-05-09T06:56:53+00:00" />
	<meta property="article:modified_time" content="2022-05-09T06:58:35+00:00" />
	<meta property="og:image" content="https://linuxgizmos.com/files/nicla-vision-front-117x125.jpg" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@LinuxGizmos" />
	<meta name="twitter:site" content="@LinuxGizmos" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Giorgio Mendoza" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://linuxgizmos.com/#website","url":"https://linuxgizmos.com/","name":"LinuxGizmos.com","description":"Embedded Linux news &amp; devices.","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://linuxgizmos.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/#primaryimage","url":"https://linuxgizmos.com/files/nicla-vision-front.jpg","contentUrl":"https://linuxgizmos.com/files/nicla-vision-front.jpg","width":660,"height":706},{"@type":"WebPage","@id":"https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/#webpage","url":"https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/","name":"Arduino Nicla Vision integrates STM32H7 MCU with Wi-Fi, BLE and camera support","isPartOf":{"@id":"https://linuxgizmos.com/#website"},"primaryImageOfPage":{"@id":"https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/#primaryimage"},"datePublished":"2022-05-09T06:56:53+00:00","dateModified":"2022-05-09T06:58:35+00:00","author":{"@id":"https://linuxgizmos.com/#/schema/person/6f69c46dee661d509647b53c76f5b965"},"description":"Geniatech’s 96Boards CE Extended form-factor “Ahaura” and “Akitio” SBCs run Linux on Renesas’ 1.2GHz, dual -A55 RZ/G2L and NPU-equipped RZ/V2L variant, respectively, and offer up to 8GB RAM and 128GB eMMC, 2x GbE, 3x USB, HDMI, and 4G LTE.","breadcrumb":{"@id":"https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/"]}]},{"@type":"BreadcrumbList","@id":"https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://linuxgizmos.com/"},{"@type":"ListItem","position":2,"name":"Arduino Nicla Vision integrates STM32H7 MCU with Wi-Fi, BLE and camera support"}]},{"@type":"Person","@id":"https://linuxgizmos.com/#/schema/person/6f69c46dee661d509647b53c76f5b965","name":"Giorgio Mendoza"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com &raquo; Arduino Nicla Vision integrates STM32H7 MCU with Wi-Fi, BLE and camera support Comments Feed" href="https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/linuxgizmos.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<!-- linuxgizmos.com is managing ads with Advanced Ads 1.33.2 – https://wpadvancedads.com/ --><script id="linux-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='xyz_cfm_short_code_style-css'  href='https://linuxgizmos.com/wp-content/plugins/contact-form-manager/css/xyz_cfm_shortcode_style.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-style-css'  href='https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://linuxgizmos.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://linuxgizmos.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://linuxgizmos.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=8.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='ssb-front-css-css'  href='https://linuxgizmos.com/wp-content/plugins/simple-social-buttons/assets/css/front.css?ver=4.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://linuxgizmos.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.9' type='text/css' media='all' />
<script type='text/javascript' src='https://linuxgizmos.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://linuxgizmos.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://linuxgizmos.com/wp-content/plugins/simple-social-buttons/assets/js/frontend-blocks.js?ver=4.0.1' id='ssb-blocks-front-js-js'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js?ver=8.2.4#property=624d8155ec22dd0019f320a1&#038;product=gdpr-compliance-tool-v2' id='simple-share-buttons-adder-mu-js'></script>
<script type='text/javascript' id='ssb-front-js-js-extra'>
/* <![CDATA[ */
var SSB = {"ajax_url":"https:\/\/linuxgizmos.com\/wp-admin\/admin-ajax.php","fb_share_nonce":"b53f7e16a9"};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxgizmos.com/wp-content/plugins/simple-social-buttons/assets/js/front.js?ver=4.0.1' id='ssb-front-js-js'></script>
<link rel="https://api.w.org/" href="https://linuxgizmos.com/wp-json/" /><link rel="alternate" type="application/json" href="https://linuxgizmos.com/wp-json/wp/v2/posts/81649" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linuxgizmos.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linuxgizmos.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9.3" />
<link rel='shortlink' href='https://wp.me/p3cYEr-leV' />
<link rel="alternate" type="application/json+oembed" href="https://linuxgizmos.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxgizmos.com%2Farduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://linuxgizmos.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxgizmos.com%2Farduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support%2F&#038;format=xml" />
 <style media="screen">

		.simplesocialbuttons.simplesocialbuttons_inline .ssb-fb-like {
	  margin: ;
	}
		 /*inline margin*/
	
	
	
	
	
		.simplesocialbuttons.simplesocialbuttons_inline.simplesocial-round-icon button{
	  margin: ;
	}

	
			 /*margin-digbar*/

	
	
	
	
	
	
	
</style>

<!-- Open Graph Meta Tags generated by Simple Social Buttons 4.0.1 -->
<meta property="og:title" content="Arduino Nicla Vision integrates STM32H7 MCU with Wi-Fi, BLE and camera support - LinuxGizmos.com" />
<meta property="og:description" content="The Nicla Vision is built around the STM32H7 (dual core M7/M4). This board comes in a tiny form factor and offers an on-board 2MP camera, Bluetooth 4.2 , Wi-Fi support and a 6-axis IMU. The Nicla Vision can be used as a standalone or in conjunction with Portenta and MKR components.


The microcontrollers used by the Nicla Vision are the Arm" />
<meta property="og:url" content="https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/" />
<meta property="og:site_name" content="LinuxGizmos.com" />
<meta property="og:image" content="https://linuxgizmos.com/files/nicla-vision-front-117x125.jpg" />
<meta property="og:image" content="https://linuxgizmos.com/files/nicla-vision-front.jpg" />
<meta property="og:image" content="https://linuxgizmos.com/files/nicla-vision-back.jpg" />
<meta property="og:image" content="https://linuxgizmos.com/files/nicla-vision-block-diagram.jpg" />
<meta property="og:image" content="https://linuxgizmos.com/files/nicla-vision-pinout.jpg" />
<meta property="og:image" content="https://linuxgizmos.com/files/nicla-vision-battery-support.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The Nicla Vision is built around the STM32H7 (dual core M7/M4). This board comes in a tiny form factor and offers an on-board 2MP camera, Bluetooth 4.2 , Wi-Fi support and a 6-axis IMU. The Nicla Vision can be used as a standalone or in conjunction with Portenta and MKR components.


The microcontrollers used by the Nicla Vision are the Arm" />
<meta name="twitter:title" content="Arduino Nicla Vision integrates STM32H7 MCU with Wi-Fi, BLE and camera support - LinuxGizmos.com" />
<meta property="twitter:image" content="https://linuxgizmos.com/files/nicla-vision-front-117x125.jpg" />
<meta property="twitter:image" content="https://linuxgizmos.com/files/nicla-vision-front.jpg" />
<meta property="twitter:image" content="https://linuxgizmos.com/files/nicla-vision-back.jpg" />
<meta property="twitter:image" content="https://linuxgizmos.com/files/nicla-vision-block-diagram.jpg" />
<meta property="twitter:image" content="https://linuxgizmos.com/files/nicla-vision-pinout.jpg" />
<meta property="twitter:image" content="https://linuxgizmos.com/files/nicla-vision-battery-support.jpg" />
<style type='text/css'>img#wpstats{display:none}</style>
	<style type="text/css" id="wp-custom-css">figcaption {
    text-align: center; margin: auto;
}</style>
<!-- google adsense verification tag -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4310582701436176",
    enable_page_level_ads: true
  });
</script>
<!-- end google adsense verification tag -->
	
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5377446-2', 'linuxgizmos.com');
  ga('send', 'pageview');
</script>
	
	
<!-- clone of ssba css as of v7.4.10 -->
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=4.9.4' type='text/css' media='all' />

<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css'  href='https://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.9.4' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: 0px solid #59625c;
									
									
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								#ssba-classic-2 .ssbp-text {
									display: none!important;
								}
								
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px; }
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}
								
@font-face {
				font-family: 'ssbp';
				src:url('https://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('https://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('https://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('https://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('https://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<!-- end clone of ssba css -->	
	
</head>
<body>
<div id="page">

<div id="header">
<!-- BEGIN ADVERTSERVE CODE -Zone 6-InLine-->
<script src="https://linuxgizmos.advertserve.com/js/libcode1_noajax.js" type="text/javascript"></script>
<!-- END ADVERTSERVE CODE -->
	<!-- BEGIN ADVERTSERVE CODE 6 test-->
<script type="text/javascript">
var _avp = _avp || [];
(function() {
  var s = document.createElement('script');
  s.type = 'text/javascript'; s.async = true; s.src = 'https://linuxgizmos.advertserve.com/js/libcode3.js';
  var x = document.getElementsByTagName('script')[0];
  x.parentNode.insertBefore(s, x);
})();
</script>


<a href="https://linuxgizmos.com/">
    <div id="headerimg">

     <!--
     <h1> <a href="https://linuxgizmos.com/">LinuxGizmos.com</a></h1> 
     <div class="description"><i>Embedded Linux news &amp; devices.</i></div> 
     -->
    </div>

</a>

</div>

<hr />
<!-- section links start -->
<table align=center width="1022" height=25 border=0 cellpadding=0 cellspacing=0 bgcolor="#3b3b3b"><tr>
<td width="" align=center><a href="/"><font size="2em" color="white">All News</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/boards"><font size="2em" color="white">Boards</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/chips"><font size="2em" color="white">Chips</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/devices"><font size="2em" color="white">Devices</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/software"><font size="2em" color="white">Software</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="http://linuxdevices.org"><font size="2em" color="white"><font color="white">LinuxDevices.com Archive</b></font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/about"><font size="2em" color="white">About</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/contact"><font size="2em" color="white">Contact</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="#subscribe"><font size="2em" color="white">Subscribe</font></a></td>
</tr></table>
<!-- section links end -->

<table align=center width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

<!-- header banner wrapper starts -- NOTE: total width = 1022 px -->
<center><table width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white"><tr>

<td width=14></td>

<td align=left>
<!-- 728x90 ad goes below here -->
<table align=left width=728 height=90 border=1 bordercolor="#ebebeb" cellpadding=0 cellspacing=0 bgcolor="white"><tr><td>
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="https://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=20&pid=1&resolution='+screen.width+'x'+screen.height+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<!-- 728x90 ad goes above here -->
</td>

<td width=10></td>

<td width=250 border=0 align=center>
<!-- sharing and subscription block goes below here -->
<table align=left cellpadding=5 cellspacing=0 border=0>
<tr><td align=center valign=middle><font size=2em color="#4a8ca7"><b>Follow LinuxGizmos:</b></font></td></tr>
<tr><td align=center valign=middle>
<a href="https://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter-square-25px.png" alt="Twitter"></a> 
<a href="https://www.facebook.com/LinuxGizmos/posts/" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/facebook-square-25px.png" alt="Facebook"></a>  
<a href="https://www.pinterest.com/LinuxGizmos/" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/pinterest-square-25px.png" alt="Pinterest"></a> 
<a href="/feed/" target="new"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss-square-25px.png" target="new"></a>
</td></tr>
<tr><td align=center valign=middle><a href="/#subscribe"><font size=2em color="#4a8ca7"><b>*</b> &nbsp; get email updates &nbsp; <b>*</b></font></a></td></tr>
</table>
<!-- sharing and subscription block goes above here -->
</td>
</tr></table></center>
<!-- header banner wrapper ends -->

<table align=center width="100%" height=3 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

	<div id="sidebar">
	<div class="sidebar-right">
		<ul>
			<li id="search-3" class="widget widget_search"><h2 class="widgettitle">Search LinuxGizmos:</h2>
<form method="get" id="searchform" action="https://linuxgizmos.com/">
<div><input type="text" value="" name="s" id="s" />
<input type="submit" id="searchsubmit" value="Search" />
</div>
</form></li>
<li id="text-33" class="widget widget_text"><h2 class="widgettitle">Search LinuxGizmos.com + LinuxDevices Archive:</h2>
			<div class="textwidget"><form action="https://linuxgizmos.com/search" id="cse-search-box">
  <div>
    <input type="hidden" name="cx" value="partner-pub-3975801459690075:2161158331" />
    <input type="hidden" name="cof" value="FORID:10" />
    <input type="hidden" name="ie" value="UTF-8" />
    <input type="text" name="q" size="23" />
    <input type="submit" name="sa" value="Search" />
  </div>
</form>
<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script></div>
		</li>
<li id="text-35" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
			<div class="textwidget"><br><!-- BEGIN ZONE 2 ADVERTSERVE CODE --> <!-- set total to zone 2 (non-dg) campaigns minus 1 -->
<script type="text/javascript">
document.write('<scr'+'ipt src="https://linuxgizmos.advertserve.com/servlet/view/banner/unique/javascript/strip?zid=18&pid=1&total=13&layout=vertical&margin=0&padding=15&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent(document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="https://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
		</li>
<li id="top-posts-4" class="widget widget_top-posts"><h2 class="widgettitle">Top 10 trending posts&#8230;</h2>
<ul><li><a href="https://linuxgizmos.com/mypalletizer-4-axis-robot-arm-available-in-m5-raspberry-pi-models/" class="bump-view" data-bump-view="tp">myPalletizer 4 axis robot arm available in M5 Stack &amp; Raspberry Pi 4 models</a></li><li><a href="https://linuxgizmos.com/din-rail-pc-with-four-2-5gbe-lan-dual-display-and-pcie-x4-slot/" class="bump-view" data-bump-view="tp">DIN Rail PC with four 2.5 GbE LAN, dual display and PCIe x4 slot</a></li><li><a href="https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/" class="bump-view" data-bump-view="tp" aria-current="page">Arduino Nicla Vision integrates STM32H7 MCU with Wi-Fi, BLE and camera support</a></li><li><a href="https://linuxgizmos.com/radxa-offers-affordable-rock-pi-4-c-equipped-with-rockchip-rk3399-t-processor/" class="bump-view" data-bump-view="tp">Radxa offers affordable Rock Pi 4 C+ equipped with Rockchip RK3399-T processor</a></li><li><a href="https://linuxgizmos.com/rock-5-sbc-features-octa-core-rk3588-16gb-ram-and-triple-displays/" class="bump-view" data-bump-view="tp">Rock 5 SBC features octa-core RK3588, 16GB RAM, and triple displays</a></li><li><a href="https://linuxgizmos.com/axzez-equips-8port-poe-board-to-their-interceptor-raspberry-pi-cm4-carrier-board/" class="bump-view" data-bump-view="tp">Axzez equips 8 port PoE+ board to their Interceptor Raspberry Pi CM4 carrier board</a></li><li><a href="https://linuxgizmos.com/raspberry-pi-cm4-carrier-has-five-sata-slots-and-four-gbe-ports/" class="bump-view" data-bump-view="tp">Raspberry Pi CM4 carrier has five SATA slots and four GbE ports</a></li><li><a href="https://linuxgizmos.com/cluster-focused-sbc-features-octa-core-rk3588/" class="bump-view" data-bump-view="tp">Cluster-focused SBC features octa-core RK3588</a></li><li><a href="https://linuxgizmos.com/anbernic-rg503-a-rockchip-based-handheld-game-console-with-a-4-95-oled-screen/" class="bump-view" data-bump-view="tp">Anbernic RG503 a Rockchip based handheld game console with a Samsung 4.95” OLED screen</a></li><li><a href="https://linuxgizmos.com/qualcomm-joins-the-wi-fi-7-competition-with-networking-pro-series/" class="bump-view" data-bump-view="tp">Qualcomm joins the Wi-Fi 7 competition with Networking Pro Series</a></li></ul></li>
<li id="text-36" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
			<div class="textwidget"><br><!-- BEGIN ZONE 3 ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="https://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=21&pid=1&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="https://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
		</li>
<li id="text-18" class="widget widget_text">			<div class="textwidget"><a name="subscribe"></a></div>
		</li>
<li id="text-3" class="widget widget_text"><h2 class="widgettitle">Follow LinuxGizmos or subscribe to our posts:</h2>
			<div class="textwidget"></div>
		</li>
<li id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><table>
<tr><td align=center valign=middle>
&nbsp;&nbsp;
<a href="https://www.twitter.com/LinuxGizmos" target="new" rel="noopener"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter-square-25px.png" alt="Twitter"></a>
<a href="https://www.facebook.com/LinuxGizmos/posts/" target="new" rel="noopener"><img height=25 width=25 vspace=0 hspace=5 src="/files/facebook-square-25px.png" alt="Facebook"></a>
<a href="https://www.pinterest.com/LinuxGizmos/" target="new" rel="noopener"><img height=25 width=25 vspace=0 hspace=5 src="/files/pinterest-square-25px.png" alt="Pinterest"></a>
<a href="/feed/" target="new" rel="noopener"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss-square-25px.png" target="new"></a>
</td></tr></table></div></li>

		</ul>
	</div>	<!--sidebar-left-->


	</div>


	<div id="content" class="narrowcolumn">
				
  		
		<div class="post" id="post-81649">
			<h2><a href="https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/" rel="bookmark" title="Permanent Link: Arduino Nicla Vision integrates STM32H7 MCU with Wi-Fi, BLE and camera support">Arduino Nicla Vision integrates STM32H7 MCU with Wi-Fi, BLE and camera support</a></h2>

		<small>May 8, 2022 &mdash; by Giorgio Mendoza </small>

	<!-- tag for gapp post pageviews plugin -->
    <small>  </small> 

	<!-- tag for Post Views for JetPack Plugin -->
 <small>84 views</small>
			
			<div class="entrytext">
				<div class="simplesocialbuttons simplesocial-round-icon simplesocialbuttons_inline simplesocialbuttons-align-left post-81649 post  simplesocialbuttons-inline-no-animation">
<button class="simplesocial-twt-share" data-href="https://twitter.com/share?text=Arduino+Nicla+Vision+integrates+STM32H7+MCU+with+Wi-Fi%2C+BLE+and+camera+support&url=https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/&via=@linuxgizmos" rel="nofollow" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">Twitter</span> </button>
<button class="simplesocial-fb-share" target="_blank" data-href="https://www.facebook.com/sharer/sharer.php?u=https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">Facebook </span> </button>
<button target="popup" class="simplesocial-linkedin-share" data-href="https://www.linkedin.com/cws/share?url=https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">LinkedIn</span></button>
<button class="simplesocial-reddit-share"  data-href="https://reddit.com/submit?url=https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/&title=Arduino+Nicla+Vision+integrates+STM32H7+MCU+with+Wi-Fi%2C+BLE+and+camera+support" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;" ><span class="simplesocialtxt">Reddit</span> </button>
<button rel="nofollow" class="simplesocial-pinterest-share" onclick="var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);return false;" ><span class="simplesocialtxt">Pinterest</span></button>
<button onclick="javascript:window.location.href = this.dataset.href;return false;" class="simplesocial-email-share" data-href="mailto:?subject=Arduino+Nicla+Vision+integrates+STM32H7+MCU+with+Wi-Fi%2C+BLE+and+camera+support&body=https://linuxgizmos.com/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/"><span class="simplesocialtxt">Email</span></button>
</div>
<p><span style="font-weight: 400;"><img class="alignleft size-thumbnail wp-image-81651" src="https://linuxgizmos.com/files/nicla-vision-front-117x125.jpg" alt="" width="117" height="125" srcset="https://linuxgizmos.com/files/nicla-vision-front-117x125.jpg 117w, https://linuxgizmos.com/files/nicla-vision-front-421x450.jpg 421w, https://linuxgizmos.com/files/nicla-vision-front.jpg 660w" sizes="(max-width: 117px) 100vw, 117px" />The <a href="https://store.arduino.cc/products/nicla-vision">Nicla Vision</a> is built around the STM32H7 (dual core M7/M4). This board comes in a tiny form factor and offers an on-board 2MP camera, Bluetooth 4.2 , Wi-Fi support and a 6-axis IMU. The Nicla Vision can be used as a standalone or in conjunction with Portenta and MKR components.</span><br />
<span id="more-81649"></span></p>
<p><span style="font-weight: 400;">The microcontrollers used by the Nicla Vision are the Arm Cortex M7 (up to 480MHz) and the Arm Cortex M4 (240MHz). The wireless interface consists of a Murata 1DX Wi-Fi/BT LE module. The 2MP onboard camera supports tinyML which is a platform to run machine learning modules on low power MCUs.  </span></p><div class="linux-content" style="margin-left: auto; margin-right: auto; text-align: center; " id="linux-74234069"><p style="font-size:6px; text-align: center;">— ADVERTISEMENT —</p>
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="https://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=40&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"><\/scr'+'ipt>');
</script><br>
<!-- END ADVERTSERVE CODE --></div>
<p><center><br />
<a href="https://linuxgizmos.com/files/nicla-vision-front.jpg"><img loading="lazy" class="alignnone wp-image-81651" src="https://linuxgizmos.com/files/nicla-vision-front.jpg" alt="" width="252" height="270" srcset="https://linuxgizmos.com/files/nicla-vision-front.jpg 660w, https://linuxgizmos.com/files/nicla-vision-front-421x450.jpg 421w, https://linuxgizmos.com/files/nicla-vision-front-117x125.jpg 117w" sizes="(max-width: 252px) 100vw, 252px" /></a><a href="https://linuxgizmos.com/files/nicla-vision-back.jpg"><img loading="lazy" class="alignnone wp-image-81650" src="https://linuxgizmos.com/files/nicla-vision-back.jpg" alt="" width="245" height="269" srcset="https://linuxgizmos.com/files/nicla-vision-back.jpg 647w, https://linuxgizmos.com/files/nicla-vision-back-411x450.jpg 411w, https://linuxgizmos.com/files/nicla-vision-back-114x125.jpg 114w" sizes="(max-width: 245px) 100vw, 245px" /></a><br />
<strong>Nicla Vision front (left) and back (right)</strong><br />
(click images to enlarge)</center>&nbsp;</p>
<p><span style="font-weight: 400;">The 6-axis IMU (LSM6DSOX) consists of a 3D accelerometer and a 3D gyroscope. Other features include a fuel gauge for battery monitoring, a time of flight sensor (VL53L1CBV0FY) , a microphone, a USB transceiver and even a crypto chip with RSA/ECC algorithm support. </span></p>
<p><center><br />
<a href="https://linuxgizmos.com/files/nicla-vision-block-diagram.jpg"><img loading="lazy" class="alignnone wp-image-81653" src="https://linuxgizmos.com/files/nicla-vision-block-diagram.jpg" alt="" width="319" height="243" srcset="https://linuxgizmos.com/files/nicla-vision-block-diagram.jpg 955w, https://linuxgizmos.com/files/nicla-vision-block-diagram-450x343.jpg 450w, https://linuxgizmos.com/files/nicla-vision-block-diagram-125x95.jpg 125w" sizes="(max-width: 319px) 100vw, 319px" /></a><a href="https://linuxgizmos.com/files/nicla-vision-pinout.jpg"><img loading="lazy" class="alignnone wp-image-81652" src="https://linuxgizmos.com/files/nicla-vision-pinout.jpg" alt="" width="274" height="237" srcset="https://linuxgizmos.com/files/nicla-vision-pinout.jpg 888w, https://linuxgizmos.com/files/nicla-vision-pinout-450x389.jpg 450w, https://linuxgizmos.com/files/nicla-vision-pinout-125x108.jpg 125w" sizes="(max-width: 274px) 100vw, 274px" /></a><br />
<strong>Nicla Vision block diagram (left) and pinout (right)</strong><br />
(click images to enlarge)</center>&nbsp;</p>
<p><span style="font-weight: 400;">Additionally, the device is enabled to interface with MicroPython,  Arduino IDE, and OpenMV. Arduino has tutorials available on their <a href="https://docs.arduino.cc/hardware/nicla-vision">Docs section</a> that showcase some of the capabilities of the Nicla Vision including <a href="https://docs.arduino.cc/tutorials/nicla-vision/microphone_sensor">audio sampling</a> and<a href="https://docs.arduino.cc/tutorials/nicla-vision/image-classification"> image processing</a> applications. </span></p>
<p><center><a href="https://linuxgizmos.com/files/nicla-vision-battery-support.jpg"><img loading="lazy" class="alignnone wp-image-81654" src="https://linuxgizmos.com/files/nicla-vision-battery-support.jpg" alt="" width="284" height="201" srcset="https://linuxgizmos.com/files/nicla-vision-battery-support.jpg 352w, https://linuxgizmos.com/files/nicla-vision-battery-support-125x88.jpg 125w" sizes="(max-width: 284px) 100vw, 284px" /></a><br />
<b><strong>Nicla Vision 3.7V Li-Po battery support</strong></b><br />
(click images to enlarge)</center>&nbsp;</p>
<p><span style="font-weight: 400;">According to the company, the Nicla Vision is powerful enough for applications such as facial recognition, object detection, gesture recognition, etc. The Nicla Vision ships for €95 (~$99). The company also claimed their vision embedded board was designed to meet industrial standards and temperatures (-20° C to +70° C) and price decreases with quantity orders. </span></p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/p1d3oOqP-CE?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span></p>
<p>&nbsp;</p>
<p><span style="font-weight: 400;">Key features of the Nicla Vision include:</span></p>
<ul>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">MCU:</span>
<ul>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">STM32H747AII6 Dual Arm Cortex M7 (up to 480MHz) and Cortex M4 (up to 240 MHz) </span></li>
</ul>
</li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Memory/storage:</span>
<ul>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">2MB Flash</span></li>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">1MB RAM </span></li>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">16MB QSPI Flash</span></li>
</ul>
</li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Camera:</span>
<ul>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">2MP GC2145 CMOS camera</span></li>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">On-chip 10-bit ADC</span></li>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">1.75 μm pixel size</span></li>
</ul>
</li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Connectivity:</span>
<ul>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;"> Wi-Fi/Bluetooth Low Energy 4.2 (Murata 1DX)</span></li>
</ul>
</li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">I/O Interface:</span>
<ul>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">10x GPIOs (pins shared w/ I2C &amp; SPI)</span></li>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">1x I2C</span></li>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">1x UART</span></li>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">1x SPI</span></li>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">2x ADC</span></li>
</ul>
</li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Security:</span>
<ul>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">NXP SE050C2 Crypto chip</span></li>
</ul>
</li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">USB:</span>
<ul>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">Micro USB port</span></li>
</ul>
</li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Power:</span>
<ul>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">5V (Via 5V USB)</span></li>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">3.7V Li-Po battery w/ integrated battery charger and fuel gauge</span></li>
</ul>
</li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Operating temperature: </span>
<ul>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;">-20° C to +70° C</span></li>
</ul>
</li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Dimensions:</span>
<ul>
<li style="font-weight: 400;" aria-level="2"><span style="font-weight: 400;"> 22.86 x 22.86  mm</span></li>
</ul>
</li>
</ul>
<p>&nbsp;</p>
<p><span style="font-weight: 400;"> </span><b>Further information</b></p>
<p><span style="font-weight: 400;">Nicla Vision boards are available on <a href="https://store.arduino.cc/products/nicla-vision">Arduino&#8217;s website</a> for</span><span style="font-weight: 400;"> €95 (~$99). </span></p>
<p>&nbsp;</p>
<div class="crp_related     crp-text-only"><h4>LinuxGizmos related posts:</h4><ul><li><a href="https://linuxgizmos.com/khronos-and-emva-collaborate-on-embedded-camera-standards/"     class="crp_link post-74633"><span class="crp_title">Khronos and EMVA collaborate on embedded camera standards</span></a></li><li><a href="https://linuxgizmos.com/jetson-xavier-system-bundles-lipsedge-3d-vision-camera/"     class="crp_link post-73156"><span class="crp_title">Jetson Xavier system bundles LIPSedge 3D vision camera</span></a></li><li><a href="https://linuxgizmos.com/hd-camera-board-targets-ai-education/"     class="crp_link post-71067"><span class="crp_title">HD camera board targets AI education</span></a></li><li><a href="https://linuxgizmos.com/embedded-vision-systems-adopt-ai-and-iot-tech/"     class="crp_link post-70320"><span class="crp_title">Embedded Vision Systems Adopt AI and IoT Tech</span></a></li><li><a href="https://linuxgizmos.com/13mp-mipi-csi2-cam-plugs-into-variscite-i-mx8m-board/"     class="crp_link post-65057"><span class="crp_title">13MP MIPI-CSI2 cam plugs into Variscite i.MX8M board</span></a></li><li><a href="https://linuxgizmos.com/e-con-systems-and-qualcomm-launch-ready-to-deploy-edge-ai-vision-kit/"     class="crp_link post-81248"><span class="crp_title">e-con Systems and Qualcomm launch ready-to-deploy edge AI&hellip;</span></a></li><li><a href="https://linuxgizmos.com/edge-ai-camera-runs-linux-on-quad-a53-soc-with-google-edge-tpu/"     class="crp_link post-75939"><span class="crp_title">Edge AI camera runs Linux on quad -A53 SoC with Google Edge&hellip;</span></a></li><li><a href="https://linuxgizmos.com/low-cost-lidar-camera-ships-with-open-source-software/"     class="crp_link post-73346"><span class="crp_title">Low-cost LiDAR camera ships with open source software</span></a></li><li><a href="https://linuxgizmos.com/module-and-dev-kit-run-linux-on-qcs610-camera-soc/"     class="crp_link post-72379"><span class="crp_title">Module and dev kit run Linux on QCS610 camera SoC</span></a></li><li><a href="https://linuxgizmos.com/13mp-raspberry-pi-4-cam-sells-for-99/"     class="crp_link post-73125"><span class="crp_title">13MP Raspberry Pi 4 cam sells for $99</span></a></li></ul><div class="crp_clear"></div></div>							</div>
		</div>

<table align=center border=0 bordercolor="#ebebeb" cellpadding=0 cellspacing=0>
<tr><td bgcolor="#f4f4f4" align=center valign=middle>
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="https://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=22&pid=0&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
<br><br> 
<!-- tag for printer friendly display or pdf printout -->
<div class="printfriendly pf-button  pf-alignleft"><a href="#" rel="nofollow" onClick="window.print(); pfTrackEvent('Arduino Nicla Vision integrates STM32H7 MCU with Wi-Fi, BLE and camera support'); return false;" title="Printer Friendly, PDF & Email"><img class="pf-button-img" src="https://cdn.printfriendly.com/buttons/printfriendly-button-nobg.png" alt="Print Friendly, PDF & Email" style="width: 112px;height: 24px;"  /></a></div><!-- end of tag -->
<table width="100%" bordercolor="#ebebeb" border=1 cellpadding=10 cellspacing="0" align=center>
<tr><td align=center><b><font color="#4a8ca7" size=3>PLEASE COMMENT BELOW</font></b></td></tr></table>

	
<!-- You can start editing here. -->


			<!-- If comments are open, but there are no comments. -->

	

		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Please comment here...					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/arduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&#038;postid=81649&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=blank&#038;greeting=Please+comment+here...&#038;jetpack_comments_nonce=52fe5cd285&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=10.9&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=f9dda1dbb6faff1e95ecb6c1e8ab7a26223af1ba#parent=https%3A%2F%2Flinuxgizmos.com%2Farduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
		
	</div>

<div id="footer">
<table width="100%" border=0 bgcolor="#ebebeb" cellpadding=10 cellspacing=0><tr><td></td></tr></table>
<table align="center" width=100% height=90 border=0 bgcolor="#ebebeb" cellpadding=0 cellspacing=0><tr><td align="center" valign="middle">
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="https://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=23&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<center><a href="/contact"><font size="1.2em" color="#4a8ca7">(advertise here)</font></a></center>
<table width="100%" align=center border=0 bgcolor="#ebebeb" cellpadding=10 cellspacing=0><tr><td>	
<font size="1.2em"><i>The content on this site is copyright &copy; 2007-2022 LinuxGizmos.com unless otherwise noted.  Comments are the property of their submitters. LinuxGizmos is part of the <a href="http://circuitcellar.com/about-us/" target="new"><font color="#4a8ca7">KCK Media Corp. network</font></a>. Linux is a registered trademark of Linus Torvalds.</i></font></td></tr></table>
<!-- <br /><a href="feed:https://linuxgizmos.com/feed/">Entries (RSS)</a> --> <!-- and <a href="feed:https://linuxgizmos.com/comments/feed/">Comments (RSS)</a>. --> 	<!-- 82 queries. 0.435 seconds. -->
<!-- optional advertserve page peel tag can go below here -->
	<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="https://linuxgizmos.advertserve.com/servlet/view/pagepeel/javascript/media?mid=974&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
 <!--END ADVERTSERVE CODE -->
	
<!-- optional advertserve page peel tag can go above here -->
</div>
     <script type="text/javascript" id="pf_script">
            
					function pfTrackEvent(title) {
						
                        if(typeof(_gaq) === 'function') {
                            _gaq.push(['_trackEvent','PRINTFRIENDLY', 'print', title]);
                        }else if(typeof(ga) === 'function') {
                            ga('send', 'event','PRINTFRIENDLY', 'print', title); 
                        }else if(typeof(gtag) === 'function') { 
                            gtag('event', 'printfriendly_button_click', {'event_category': 'printfriendly', 'event_label': title})
                        }else if(typeof(dataLayer) === 'object') { 
                            dataLayer.push({
                                'event': 'printfriendly_button_click',
                                'pageTitle': title
                            })
                        }
					
					}
				          var pfHeaderImgUrl = 'https://linuxgizmos.com/files/linuxgizmos-logo.jpg';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '1';
          var pfImagesSize = 'medium';
          var pfImageDisplayStyle = 'block';
          var pfEncodeImages = '0';
          var pfShowHiddenContent  = '0';
          var pfDisableEmail = '1';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
        var pfPlatform = 'WordPress';

        (function($){
            $(document).ready(function(){
                if($('.pf-button-content').length === 0){
                    $('style#pf-excerpt-styles').remove();
                }
            });
        })(jQuery);
        </script>
      <script async src='https://cdn.printfriendly.com/printfriendly.js'></script>
            <script type='text/javascript' src='https://linuxgizmos.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://linuxgizmos.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.13.1' id='jquery-ui-datepicker-js'></script>
<script type='text/javascript' id='jquery-ui-datepicker-js-after'>
jQuery(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"M. d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='https://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=1646974972' id='simple-share-buttons-adder-ssba-js'></script>
<script type='text/javascript' id='simple-share-buttons-adder-ssba-js-after'>
Main.boot( [] );
</script>
<script type='text/javascript'>function initTwitCount(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://static1.twitcount.com/js/twitcount.js';fjs.parentNode.insertBefore(js,fjs)}}
        var ssb_twit_count_init=!1;addEventListener('mouseover',function(event){if(!ssb_twit_count_init){initTwitCount(document,'script','twitcount_plugins')
        ssb_twit_count_init=!0}})</script><script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script>
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=81649&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&jetpack_comments_nonce=52fe5cd285&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.9&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=f9dda1dbb6faff1e95ecb6c1e8ab7a26223af1ba#parent=https%3A%2F%2Flinuxgizmos.com%2Farduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=81649&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&jetpack_comments_nonce=52fe5cd285&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.9&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=f9dda1dbb6faff1e95ecb6c1e8ab7a26223af1ba#parent=https%3A%2F%2Flinuxgizmos.com%2Farduino-nicla-vision-integrates-stm32h7-mcu-with-wi-fi-ble-and-camera-support%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202219.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9',blog:'47422091',post:'81649',tz:'-7',srv:'linuxgizmos.com'} ]);
	_stq.push([ 'clickTrackerInit', '47422091', '81649' ]);
</script>
 
</body>
</html>