<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>Tiny IoT gateway built on Raspberry Pi Compute Module wears HATs</title>
<meta name="generator" content="WordPress 4.8.3" /> 
<link rel="stylesheet" href="http://linuxgizmos.com/wp-content/themes/BlackTower-lgw/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com RSS Feed" href="http://linuxgizmos.com/feed/" />
<link rel="pingback" href="http://linuxgizmos.com/xmlrpc.php" />

<link rel="author" href="https://plus.google.com/104414840801731506333" />
<style type="text/css" media="screen">
	#headerimg { margin: 0; margin-top: 0px; height: 80px; width: 1022px; }
	#headerimg { background: url('http://linuxgizmos.com/wp-content/themes/BlackTower-lgw/images/header.jpg') no-repeat top;}
</style>
<script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script>

<meta name="description" content="CompuLab’s IOT-GATE-RPi mini-PC/gateway builds on the RPi CM3 with 2x GbE, RPi HAT expansion, and optional WiFi, BT, 3G, LTE, and -40 to 80°C support." />
<link rel="canonical" href="http://linuxgizmos.com/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats/" />
<link rel="publisher" href="https://plus.google.com/b/104414840801731506333/+LinuxGizmos" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Tiny IoT gateway built on Raspberry Pi Compute Module wears HATs" />
<meta property="og:description" content="CompuLab’s IOT-GATE-RPi mini-PC/gateway builds on the RPi CM3 with 2x GbE, RPi HAT expansion, and optional WiFi, BT, 3G, LTE, and -40 to 80°C support." />
<meta property="og:url" content="http://linuxgizmos.com/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats/" />
<meta property="og:site_name" content="LinuxGizmos.com" />
<meta property="article:publisher" content="http://facebook.com/LinuxGizmos" />
<meta property="article:section" content="Devices" />
<meta property="article:published_time" content="2017-11-28T09:11:14-08:00" />
<meta property="article:modified_time" content="2017-11-28T11:25:07-08:00" />
<meta property="og:updated_time" content="2017-11-28T11:25:07-08:00" />
<meta property="og:image" content="http://linuxgizmos.com/files/compulab_iotgaterpi-thm.jpg" />
<meta property="og:image" content="http://linuxgizmos.com/files/compulab_iotgaterpi-sm.jpg" />
<meta property="og:image" content="http://linuxgizmos.com/files/compulab_iotgaterpi_back-sm.jpg" />
<meta property="og:image" content="http://linuxgizmos.com/files/compulab_iotgaterpi_front_back-sm.jpg" />
<meta property="og:image" content="http://linuxgizmos.com/files/rpi_cm3-thm.jpg" />
<meta property="og:image" content="http://linuxgizmos.com/files/compulab_iotgaterpi_exploded-sm.jpg" />
<meta property="og:image" content="http://linuxgizmos.com/files/compulab_iotgaterpi_carrier-sm.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="CompuLab’s IOT-GATE-RPi mini-PC/gateway builds on the RPi CM3 with 2x GbE, RPi HAT expansion, and optional WiFi, BT, 3G, LTE, and -40 to 80°C support." />
<meta name="twitter:title" content="Tiny IoT gateway built on Raspberry Pi Compute Module wears HATs" />
<meta name="twitter:site" content="@LinuxGizmos" />
<meta name="twitter:image" content="http://linuxgizmos.com/files/compulab_iotgaterpi-thm.jpg" />
<meta name="twitter:creator" content="@LinuxGizmos" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/linuxgizmos.com\/","name":"LinuxGizmos.com","alternateName":"LinuxGizmos","potentialAction":{"@type":"SearchAction","target":"http:\/\/linuxgizmos.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/linuxgizmos.com\/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats\/","sameAs":["http:\/\/facebook.com\/LinuxGizmos","https:\/\/plus.google.com\/b\/104414840801731506333\/+LinuxGizmos","https:\/\/twitter.com\/LinuxGizmos"],"@id":"#organization","name":"DeviceGuru Blog Network","logo":""}</script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com &raquo; Tiny IoT gateway built on Raspberry Pi Compute Module wears HATs Comments Feed" href="http://linuxgizmos.com/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/linuxgizmos.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='xyz_cfm_short_code_style-css' href='http://linuxgizmos.com/wp-content/plugins/contact-form-manager/css/xyz_cfm_shortcode_style.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-style-css' href='http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='http://linuxgizmos.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.5.1' type='text/css' media='all' />
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script id='st_insights_js' type='text/javascript' src='http://w.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare'></script>
<link rel='https://api.w.org/' href='http://linuxgizmos.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://linuxgizmos.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://linuxgizmos.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.8.3" />
<link rel='shortlink' href='https://wp.me/p3cYEr-fFy' />
<link rel="alternate" type="application/json+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Ftiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Ftiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats%2F&#038;format=xml" />
<style type="text/css" media="screen">
      div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited {
        text-decoration: none;
        border: none;
      }
    </style>
<style type="text/css" media="screen">
          div.printfriendly {
            margin: 12px 12px 12px 30px;
            position: relative;
            z-index: 1000;
          }
          div.printfriendly a, div.printfriendly a:link, div.printfriendly a:visited {
            font-size: 14px;
            color: #6D9F00;
            vertical-align: bottom;
          }
          .printfriendly a {
            box-shadow:none;
          }
          .printfriendly a:hover {
            cursor: pointer;
          }
          .printfriendly a img  {
            border: none;
            padding:0;
            margin-right: 6px;
            box-shadow: none;
            -webkit-box-shadow: none;
            -moz-box-shadow: none;
          }
          .printfriendly a span{
            vertical-align: bottom;
          }
          .pf-alignleft {
            float: left;
          }
          .pf-alignright {
            float: right;
          }
          div.pf-aligncenter {
            display: block;
            margin-left: auto;
            margin-right: auto;
            text-align: center;
          }
        </style>
<style type="text/css" media="print">
          .printfriendly {
            display: none;
          }
        </style>
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<style type="text/css" id="wp-custom-css">
				/*
Welcome to Custom CSS!

To learn how this works, see http://wp.me/PEmnE-Bt
*/
.commentlist li {
	font-size: 1em;
}			</style>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5377446-2', 'linuxgizmos.com');
  ga('send', 'pageview');
</script>

<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css' href='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.8.3' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: 0px solid #59625c;		
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}		
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px;
								}
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}						
</style>

</head>
<body>
<div id="page">
<div id="header">


<script type="text/javascript">
_avp.push({ alias: '/', type: 'pagepeel', mid: 380, pid: 0 });
</script>

<a href="http://linuxgizmos.com/">
<div id="headerimg">

</div>
</a>
</div>
<hr />

<table align=center width="1022" height=25 border=0 cellpadding=0 cellspacing=0 bgcolor="#3b3b3b"><tr>
<td width="" align=center><a href="/"><font size="2em" color="white">All News</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/boards"><font size="2em" color="white">Boards</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/chips"><font size="2em" color="white">Chips</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/devices"><font size="2em" color="white">Devices</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/software"><font size="2em" color="white">Software</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="http://linuxdevices.linuxgizmos.com"><font size="2em" color="white"><font color="white">LinuxDevices.com Archive</b></font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/about"><font size="2em" color="white">About</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/contact"><font size="2em" color="white">Contact</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="#subscribe"><font size="2em" color="white">Subscribe</font></a></td>
</tr></table>

<table align=center width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

<center><table width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white"><tr>
<td width=14></td>
<td align=left>

<table align=left width=728 height=90 border=1 bordercolor="#ebebeb" cellpadding=0 cellspacing=0 bgcolor="white"><tr><td>

<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=20&pid=1&resolution='+screen.width+'x'+screen.height+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>

</td></tr></table>

</td>
<td width=10></td>
<td width=250 border=0 align=center>

<table align=left cellpadding=5 cellspacing=0 border=0>
<tr><td align=center valign=middle><font size=2em color="#4a8ca7"><b>Follow LinuxGizmos:</b></font></td></tr>
<tr><td align=center valign=middle>
<a href="http://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter-square-25px.png" alt="Twitter"></a>
<a href="https://plus.google.com/+LinuxGizmos/posts" rel="publisher" style="text-decoration:none;" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/googleplus-square-25px.png" alt="Google+"></a>
<a href="https://www.facebook.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="http://linuxgizmos.com/files/facebook-square-25px.png" alt="Facebook"></a>
<a href="/feed/" target="new"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss-square-25px.png" target="new"></a>
</td></tr>
<tr><td align=center valign=middle><a href="/#subscribe"><font size=2em color="#4a8ca7"><b>*</b> &nbsp; get email updates &nbsp; <b>*</b></font></a></td></tr>
</table>

</td>
</tr></table></center>

<table align=center width="100%" height=3 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>
<div id="sidebar">
<div class="sidebar-right">
<ul>
<li id="search-3" class="widget widget_search"><h2 class="widgettitle">Search LinuxGizmos:</h2>
<form method="get" id="searchform" action="http://linuxgizmos.com/">
<div><input type="text" value="" name="s" id="s" />
<input type="submit" id="searchsubmit" value="Search" />
</div>
</form></li>
<li id="text-33" class="widget widget_text"><h2 class="widgettitle">Search LinuxGizmos.com + LinuxDevices Archive:</h2>
<div class="textwidget"><form action="http://linuxgizmos.com/search" id="cse-search-box">
<div>
<input type="hidden" name="cx" value="partner-pub-3975801459690075:2161158331" />
<input type="hidden" name="cof" value="FORID:10" />
<input type="hidden" name="ie" value="UTF-8" />
<input type="text" name="q" size="23" />
<input type="submit" name="sa" value="Search" />
</div>
</form>
<script type="text/javascript" src="http://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script></div>
</li>
<li id="text-35" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
<div class="textwidget"><br> 
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/unique/javascript/strip?zid=18&pid=0&total=10&layout=vertical&margin=0&padding=15&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent(document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>

<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
</li>
<li id="top-posts-3" class="widget widget_top-posts"><h2 class="widgettitle">Top 10 trending posts&#8230; </h2>
<ul> <li>
<a href="http://linuxgizmos.com/rugged-mini-pc-supports-linux-on-apollo-lake/" class="bump-view" data-bump-view="tp">
Rugged mini-PC supports Linux on Apollo Lake </a>
</li>
<li>
<a href="http://linuxgizmos.com/first-renesas-based-raspberry-pi-clone-runs-linux/" class="bump-view" data-bump-view="tp">
First Renesas based Raspberry Pi clone runs Linux </a>
</li>
<li>
<a href="http://linuxgizmos.com/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats/" class="bump-view" data-bump-view="tp">
Tiny IoT gateway built on Raspberry Pi Compute Module wears HATs </a>
</li>
<li>
<a href="http://linuxgizmos.com/rugged-octa-core-hacker-board-has-2gb-ram/" class="bump-view" data-bump-view="tp">
Rugged, octa-core hacker board has 2GB RAM </a>
</li>
<li>
<a href="http://linuxgizmos.com/ringing-in-2017-with-90-hacker-friendly-single-board-computers/" class="bump-view" data-bump-view="tp">
Ringing in 2017 with 90 hacker-friendly single board computers </a>
</li>
<li>
<a href="http://linuxgizmos.com/2017-hacker-board-survey-raspberry-pi-still-rules-but-x86-sbcs-make-gains/" class="bump-view" data-bump-view="tp">
2017 hacker board survey results: Raspberry Pi still rules, but x86 SBCs make gains </a>
</li>
<li>
<a href="http://linuxgizmos.com/open-source-linux-on-zynq-sbc-debuts-new-fpga-add-on-standard/" class="bump-view" data-bump-view="tp">
Open source Linux-on-Zynq SBC debuts new FPGA add-on standard </a>
</li>
<li>
<a href="http://linuxgizmos.com/compact-carrier-matches-the-footprint-of-the-jetson-tx2-that-powers-it/" class="bump-view" data-bump-view="tp">
Compact carrier turns Nvidia Jetson TX2 into an SBC </a>
</li>
<li>
<a href="http://linuxgizmos.com/catalog-of-98-open-spec-hacker-friendly-sbcs/" class="bump-view" data-bump-view="tp">
Catalog of 98 open-spec, hacker friendly SBCs </a>
</li>
<li>
<a href="http://linuxgizmos.com/linuxandroid-hacker-sbc-with-hexa-core-rockchip-soc-debuts-at-75/" class="bump-view" data-bump-view="tp">
Linux/Android hacker SBC with hexa-core Rockchip SoC debuts at $75 </a>
</li>
</ul></li>
<li id="text-36" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
<div class="textwidget"><br>
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=21&pid=1&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>

<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
</li>
<li id="text-18" class="widget widget_text"> <div class="textwidget"><a name="subscribe"></a></div>
</li>
<li id="text-3" class="widget widget_text"><h2 class="widgettitle">Follow LinuxGizmos or subscribe to our posts:</h2>
<div class="textwidget"></div>
</li>
<li id="text-37" class="widget widget_text"> <div class="textwidget"><table align=center><tr><td align=center valign=middle><h2>Follow:</h2></td><td align=center valign=middle><a href="http://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/twitter.png" alt="Twitter" target="new"></a> <a href="https://plus.google.com/+LinuxGizmos/posts" rel="publisher" style="text-decoration:none;" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/gplus.png" alt="Google+"></a> <a href="https://www.facebook.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/facebook.png" alt="Facebook"></a> <a href="/feed/"><img height=25 width=25 vspace=5 hspace=5 alt="RSS feed" src="http://linuxgizmos.com/files/rss.png" target="new"></a></td></tr></table></div>
</li>
<li id="blog_subscription-2" class="widget jetpack_subscription_widget"> <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
<div id="subscribe-text"><p>Enter your email address to receive notifications of new posts:</p>
</div> <p id="subscribe-email">
<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-2">
Email Address </label>
<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-2" placeholder="Email Address" />
</p>
<p id="subscribe-submit">
<input type="hidden" name="action" value="subscribe" />
<input type="hidden" name="source" value="http://linuxgizmos.com/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats/" />
<input type="hidden" name="sub-type" value="widget" />
<input type="hidden" name="redirect_fragment" value="blog_subscription-2" />
<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
</p>
</form>
<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-2]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-2'),
					input = d.getElementById('subscribe-field-blog_subscription-2'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
</li>
</ul>
</div> 
</div>
<div id="content" class="narrowcolumn">
<div class="post" id="post-60236">
<h2><a href="http://linuxgizmos.com/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats/" rel="bookmark" title="Permanent Link: Tiny IoT gateway built on Raspberry Pi Compute Module wears HATs">Tiny IoT gateway built on Raspberry Pi Compute Module wears HATs</a></h2>
<small>Nov 28, 2017 &mdash; by Eric Brown </small>

<small> &mdash; 210 views </small>
<div class="entrytext">
<div class="ssba ssba-wrap"><div style="text-align:center"><i>Please share:</i> <a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=http://linuxgizmos.com/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats/&amp;text=Tiny%20IoT%20gateway%20built%20on%20Raspberry%20Pi%20Compute%20Module%20wears%20HATs%20" target=&quot;_blank&quot;><img src="http://linuxgizmos.com/files/twitter-square-25px.png" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /></a><a data-site="" class="ssba_google_share" href="https://plus.google.com/share?url=http://linuxgizmos.com/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats/" target=&quot;_blank&quot;><img src="http://linuxgizmos.com/files/googleplus-square-25px.png" title="Share on Google+" class="ssba ssba-img" alt="Google+" /></a><a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=http://linuxgizmos.com/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats/" target="_blank"><img src="http://linuxgizmos.com/files/facebook-square-25px.png" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http://linuxgizmos.com/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats/" target=&quot;_blank&quot;><img src="http://linuxgizmos.com/files/linkedin-square-25px.png" alt="Share on LinkedIn" title="LinkedIn" class="ssba ssba-img" /></a><a data-site="reddit" class="ssba_reddit_share" href="http://reddit.com/submit?url=http://linuxgizmos.com/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats/&amp;title=Tiny IoT gateway built on Raspberry Pi Compute Module wears HATs" target=&quot;_blank&quot;><img src="http://linuxgizmos.com/files/reddit-square-25px.png" title="Reddit" class="ssba ssba-img" alt="Share on Reddit" /></a><a data-site='pinterest' class='ssba_pinterest_share' href='javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;//assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());'><img title="Pinterest" class="ssba ssba-img" src="http://linuxgizmos.com/files/pinterest-square-25px.png" alt="Pin on Pinterest" /></a><a data-site="email" class="ssba_email_share" href="/cdn-cgi/l/email-protection#f8c78b8d9a929d9b8cc5ac919681ddcac8b197acddcac89f998c9d8f9981ddcac89a8d91948cddcac89796ddcac8aa998b889a9d8a8a81ddcac8a891ddcac8bb9795888d8c9dddcac8b5979c8d949dddcac88f9d998a8bddcac8b0b9ac8bdedbc8cbc0c39a979c81c5ddcac8908c8c88c2d7d79491968d809f918295978bd69b9795d78c919681d591978cd59f998c9d8f9981d59a8d91948cd59796d58a998b889a9d8a8a81d58891d59b9795888d8c9dd595979c8d949dd58f9d998a8bd590998c8bd7"><img src="http://linuxgizmos.com/files/email-square-25px.png" title="Email" class="ssba ssba-img" alt="Email to someone" /></a></div></div><div class="pf-content"><p><img align=left vspace=5 hspace=10 src="/files/compulab_iotgaterpi-thm.jpg"><br />
CompuLab’s IOT-GATE-RPi mini-PC/gateway builds on the RPi CM3 with 2x GbE, RPi HAT expansion, and optional WiFi, BT, 3G, LTE, and -40 to 80°C support.<br />
<span id="more-60236"></span><br />
CompuLab has added another Linux-friendly member to its IOT-GATE family of ultra-compact mini-PCs, following the <a href="http://linuxgizmos.com/iot-gateway-runs-mainline-linux-on-i-mx7/" target="new">IOT-GATE-iMX7</a>, which is built around its NXP i.MX7 based CL-SOM-iMX7 computer-on-module. For the new IOT-GATE-RPi, CompuLab opted for a third-party COM: the popular <a href="http://linuxgizmos.com/64-bit-rpi-compute-module-3-ships-for-30/" target="new">Raspberry Pi Compute Module 3</a>, a COM version of the Raspberry Pi 3.<br />
<center><br />
<a href="/files/compulab_iotgaterpi.jpg" target="new"><img src="/files/compulab_iotgaterpi-sm.jpg" vspace=10 hspace=5 border=0></a> <a href="/files/compulab_iotgaterpi_back.jpg" target="new"><img src="/files/compulab_iotgaterpi_back-sm.jpg" vspace=10 hspace=5 border=0></a><br />
<b>IOT-GATE-RPi front and back &#8212; left side of rear view shows RJ11 connectors on an optional HAT board featuring RS485 and CAN</b><br />
(click images to enlarge)<br />
</center><br />
Starting at $110 in volume, the 112 x 84 x 25mm IOT-GATE-RPi IoT gateway is only slightly larger than the IOT-GATE-iMX7. It follows several other compact computers based on the RPi CM3, such as Dek Italia’s <a href="http://linuxgizmos.com/din-rail-iot-gateway-builds-on-raspberry-pi-cm3/" target="new">Telegea Smart Hub</a> DIN-rail computer and Distec’s <a href="http://linuxgizmos.com/raspberry-pi-cm3_touch-panel-and-network-media-player/" target="new">POS-Line IoT</a> panel PC.</p>
<p>The fanless, 450-gram IOT-GATE-RPi is available in 0 to 60°C, -20 to 60°C, and -40 to 80°C temperature ranges. Its rugged metal housing is claimed to offer unspecified levels of shock, vibration, and dust resistance. </p>
<p>The IOT-GATE-RPi provides a wide 10-36V input range, DC-plug locking, and optional DIN-rail, wall, and VESA mounting support. There’s also an RTC with back-up battery, as well as hardware protection against unauthorized boot from external storage.<br />
<center><br />
<a href="/files/compulab_iotgaterpi_front_back.jpg" vspace=10 hspace=5 border=0><img src="/files/compulab_iotgaterpi_front_back-sm.jpg"></a><br />
<b>IOT-GATE-RPi front/rear panel closeups</b><br />
(click image to enlarge)<br />
</center></p>
<table align=right vspace=5 hspace=5 border=0 cellpadding=0 cellspacing=0>
<tr>
<td align=center><img src="/files/rpi_cm3-thm.jpg"><br /><b>Raspberry Pi<br />Compute Module 3</b></td>
</tr>
</table>
<p>The <a href="http://linuxgizmos.com/64-bit-rpi-compute-module-3-ships-for-30/" target="new">Raspberry Pi Compute Module 3</a> contributes its quad-core, Cortex-A53 Broadcom BCM2837 SoC with VideoCore IV GPU &#8212; the same as on the <a href="http://linuxgizmos.com/quad-core-64-bit-pi-3-is-official-with-wifi-bt-and-35-price/" target="new">Raspberry Pi 3</a> &#8212; plus 1GB LPDDR2 RAM. The standard microSD slot can be replaced with up to 64GB of soldered eMMC storage. This would suggest that CompuLab is using the $25 Lite version of the CM3, which lacks the usual 4GB of onboard eMMC.</p>
<p>The IOT-GATE-RPi features dual 10/100 Ethernet ports, 4x USB 2.0 host ports, an audio out jack, and an HDMI 1.3 port with audio support and up to HD resolution. The system is further equipped with an ultra-mini RS232 port.<br />
<center><br />
<a href="/files/compulab_iotgaterpi_exploded.jpg" target="new"><img src="/files/compulab_iotgaterpi_exploded-sm.jpg" vspace=10 hspace=5 border=0></a> <a href="/files/compulab_iotgaterpi_carrier.jpg" target="new"><img src="/files/compulab_iotgaterpi_carrier-sm.jpg" vspace=10 hspace=5 border=0></a><br />
<b>IOT-GATE-RPi exploded view (left), and bottom side view of system&#8217;s RPi carrier board showing its 40-pin HAT expansion connector and an optional mini-PCIe modem module</b><br />
(click images to enlarge)<br />
</center><br />
A 40-pin Raspberry Pi expansion connector that supports RPi HAT add-ons is available on the lower side of the RPi CM3 carrier board (pictured above). You can populate this connector with the optional EB-RPI-FCSD HAT board that offers RS485 and CAN ports, both of which have RJ11 connectors. This HAT board would also appear to include the optional 6x 5V tolerant DIO feature, which is said to be FCSD-HAT based. </p>
<p>The carrier board also provides a mini-PCIe expansion connector for non-PCIe options such as a WiFi/Bluetooth 4.1 (Broadcom BCM43438) module, as well as 3G and 4G/LTE radios based on Simcom SIM5360 and SIM7100 modules, respectively. A micro-SIM card slot is also available. </p>
<p>The system&#8217;s modular I/O side-panel design enables &#8220;easy incorporation of HAT add-ons into the device&#8221; says Compulab. Additionally, Options such as a HAT, mini-PCIe card, and micro-SIM can be accessed via the system&#8217;s removable bottom cover.</p>
<p>In addition to the above-mentioned options, there’s an evaluation kit with a 45-day free trial and a year of tech support. This includes a variety of cables, adapters, and mounting brackets, as well as a WiFi antenna.</p>
<p>The IOT-GATE-RPi offers full compatibility with Raspberry Pi software, and runs standard Raspberry Pi OS images, says CompuLab. Supported OSes include Debian, Ubuntu Core, and Windows 10 IoT Core. The system also supports IoT frameworks like Microsoft Azure IoT and AWS Greengrass.</p>
<p>&nbsp;<br />
<b>Further information</b></p>
<p>The IOT-GATE-RPi will be available in December starting from $110 for volume orders. More information may be found at CompuLab’s IOT-GATE-RPi <a href="http://www.compulab.com/2017/11/26/compulab-introduces-a-raspberry-pi-based-iot-computer-with-3glte-modem-dual-ethernet-and-wide-temperature-range/" target="new">announcement</a> and <a href="http://www.compulab.com/products/iot-gateways/iot-gate-rpi-industrial-raspberry-pi-iot-gateway/#specs" target="new">product page</a>.<br />
&nbsp;</p>
</div><div class="crp_related "><h4>Related posts:</h4><ul><li><a href="http://linuxgizmos.com/64-bit-rpi-compute-module-3-ships-for-30/"><span class="crp_title">64-bit Raspberry Pi Compute Module 3 ships for $25 to $30</span></a></li><li><a href="http://linuxgizmos.com/tiny-foldable-imx7-module-squishes-into-30x27x8mm/"><span class="crp_title">Tiny foldable i.MX7 module squishes into 30 x 27 x 8mm</span></a></li><li><a href="http://linuxgizmos.com/automation-controller-runs-linux-on-raspberry-pi-com/"><span class="crp_title">Automation controller runs Linux on Raspberry Pi COM</span></a></li><li><a href="http://linuxgizmos.com/latest-hummingboard-sbc-drops-price-supports-click-add-ons/"><span class="crp_title">Latest HummingBoard SBC drops price, supports Click add-ons</span></a></li><li><a href="http://linuxgizmos.com/rugged-sodimm-style-com-and-sbc-run-linux-on-i-mx7/"><span class="crp_title">Rugged SODIMM-style COM and SBC run Linux on i.MX7</span></a></li><li><a href="http://linuxgizmos.com/iot-gateway-runs-mainline-linux-on-i-mx7/"><span class="crp_title">IoT gateway runs mainline Linux on i.MX7</span></a></li><li><a href="http://linuxgizmos.com/coin-sized-com-could-be-worlds-smallest-raspberry-pi-clone/"><span class="crp_title">Coin-sized COM could be world&#039;s smallest&hellip;</span></a></li><li><a href="http://linuxgizmos.com/industrial-sbc-builds-on-rpi-compute-module/"><span class="crp_title">Industrial SBC builds on Raspberry Pi Compute Module</span></a></li><li><a href="http://linuxgizmos.com/din-rail-iot-gateway-builds-on-raspberry-pi-cm3/"><span class="crp_title">DIN-rail IoT gateway builds on Raspberry Pi CM3</span></a></li><li><a href="http://linuxgizmos.com/raspberry-pi-cm3-arrives-on-pc104-sort-of/"><span class="crp_title">Raspberry Pi arrives on PC/104&#8230; sort of</span></a></li></ul><div class="crp_clear"></div></div> </div>
</div>
<table align=center border=0 bordercolor="#ebebeb" cellpadding=0 cellspacing=0>
<tr><td bgcolor="#f4f4f4" align=center valign=middle>

<script src="/cdn-cgi/scripts/0e574bed/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=22&pid=0&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>

</td></tr></table>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
<br><br>

<div class="printfriendly pf-alignleft"><a href="#" rel="nofollow" onclick="window.print();if(typeof(_gaq) != 'undefined') { _gaq.push(['_trackEvent','PRINTFRIENDLY', 'print', 'NULL']);
          }else if(typeof(ga) != 'undefined') {  ga('send', 'event','PRINTFRIENDLY', 'print', 'NULL'); } return false;" class="noslimstat" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="https://cdn.printfriendly.com/buttons/printfriendly-button-nobg.png" alt="Print Friendly, PDF & Email" /></a></div>
<table width="100%" bordercolor="#ebebeb" border=1 cellpadding=10 cellspacing="0" align=center>
<tr><td align=center><b><font color="#4a8ca7" size=3>PLEASE COMMENT BELOW</font></b></td></tr></table>


<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Please comment here... <small><a rel="nofollow" id="cancel-comment-reply-link" href="/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe src="http://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&#038;postid=60236&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=blank&#038;greeting=Please+comment+here...&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.5.1&#038;sig=d66c47ddf7571eb65d2403941705687ede465c32#parent=http%3A%2F%2Flinuxgizmos.com%2Ftiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
<!--[if !IE]><!-->
<script>
					document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});
				</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
<div id="footer">

<table width="100%" border=0 cellpadding=10 cellspacing=0><tr><td></td></tr></table>
<table align="center" width=728 height=90 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td border=1 bordercolor="#4a8ca7" bgcolor="#f4f4f4" align=center valign=middle>

<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=23&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>

</td></tr>
<tr><td></table>
<table width="100%" border=0 cellpadding=5 cellspacing=0><tr><td>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
</td></tr></table>

<div>
<font size=1><i>The content on this site is copyright &copy; 2007-2017 Rick Lehrbaum unless otherwise noted. Comments are the property of their submitters. Content originally published on LinuxDevices is Copyright &copy; 1999-2017 QuinStreet Inc. and is reproduced here under license from its owner. LinuxGizmos is part of the <a href="http://deviceguru.com/about/" target="new"><u>DeviceGuru Blog Network</u></a>. Linux is a registered trademark of Linus Torvalds.</i></font>
</div>
<br>
<div align=center>
<font size=2><a href="/contact"><font color="#4a8ca7"><u>Contact us</u></font></a> | <a href="http://www.deviceguru.com/privacy/"><font color="#4a8ca7"><u>Privacy policy</u></font></a> | <a href="/terms-of-use" target="new"><font color="#4a8ca7"><u>Terms of use</u></font></a> | <a href="/about"><font color="#4a8ca7"><u>About us</u></font></a> | <a href="/feed"><font color="#4a8ca7"><u>RSS feed</u></font></a> </font>
</div>



</div>
</div>
<script type="text/javascript">

          var pfHeaderImgUrl = 'http://linuxgizmos.com/files/linuxgizmos-logo.jpg';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '1';
          var pfImagesSize = 'medium';
          var pfImageDisplayStyle = 'block';
          var pfDisableEmail = '1';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
      (function() {
            var e = document.createElement('script'); e.type="text/javascript";
            e.src = 'https://cdn.printfriendly.com/printfriendly.js';
            document.getElementsByTagName('head')[0].appendChild(e);
        })();
      </script>
<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css' href='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.8.3' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: 0px solid #59625c;
									
									
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px;
								}
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}
								
</style>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"M. d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201748'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=4.8.3'></script>
<script type='text/javascript'>
Main.boot( [] );
</script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/wp-embed.min.js?ver=4.8.3'></script>
<script async="async" type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.1'></script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=60236&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.5.1&sig=d66c47ddf7571eb65d2403941705687ede465c32#parent=http%3A%2F%2Flinuxgizmos.com%2Ftiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=60236&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.5.1&sig=d66c47ddf7571eb65d2403941705687ede465c32#parent=http%3A%2F%2Flinuxgizmos.com%2Ftiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "http:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-201748.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.5.1',blog:'47422091',post:'60236',tz:'-8',srv:'linuxgizmos.com'} ]);
	_stq.push([ 'clickTrackerInit', '47422091', '60236' ]);
</script>



</body>
</html>