
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>RISC-V gains momentum as it moves from MCUs to Linux-friendly SoCs</title>
<meta name="generator" content="WordPress 4.9.4" /> 
<link rel="stylesheet" href="http://linuxgizmos.com/wp-content/themes/BlackTower-lgw/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com RSS Feed" href="http://linuxgizmos.com/feed/" />
<link rel="pingback" href="http://linuxgizmos.com/xmlrpc.php" />

<link rel="author" href="https://plus.google.com/104414840801731506333" />
<style type="text/css" media="screen">
	#headerimg { margin: 0; margin-top: 0px; height: 80px; width: 1022px; }
	#headerimg { background: url('http://linuxgizmos.com/wp-content/themes/BlackTower-lgw/images/header.jpg') no-repeat top;}
</style>
<script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script>

<meta name="description" content="The open source RISC-V ISA has evolved quickly into silicon, thanks to help from companies like SiFive and Microsemi. SiFive’s HiFive Unleashed board should arrive less than two years after SiFive announced its first Linux-driven Freedom SoCs." />
<link rel="canonical" href="http://linuxgizmos.com/risc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs/" />
<link rel="publisher" href="https://plus.google.com/b/104414840801731506333/+LinuxGizmos" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="RISC-V gains momentum as it moves from MCUs to Linux-friendly SoCs" />
<meta property="og:description" content="The open source RISC-V ISA has evolved quickly into silicon, thanks to help from companies like SiFive and Microsemi. SiFive’s HiFive Unleashed board should arrive less than two years after SiFive announced its first Linux-driven Freedom SoCs." />
<meta property="og:url" content="http://linuxgizmos.com/risc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs/" />
<meta property="og:site_name" content="LinuxGizmos.com" />
<meta property="article:publisher" content="http://facebook.com/LinuxGizmos" />
<meta property="article:section" content="Chips" />
<meta property="article:published_time" content="2018-02-08T12:19:47-08:00" />
<meta property="article:modified_time" content="2018-02-08T12:43:20-08:00" />
<meta property="og:updated_time" content="2018-02-08T12:43:20-08:00" />
<meta property="og:image" content="http://linuxgizmos.com/files/riscv-logo.jpg" />
<meta property="og:image" content="http://linuxgizmos.com/files/sifive_hifiveunleashed_2018-sm.jpg" />
<meta property="og:image" content="http://linuxgizmos.com/files/sifive_u540_block_2018-sm.jpg" />
<meta property="og:image" content="http://linuxgizmos.com/files/ucb_krste_asanovic.jpg" />
<meta property="og:image" content="http://linuxgizmos.com/files/arduino_cinque-thm.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="The open source RISC-V ISA has evolved quickly into silicon, thanks to help from companies like SiFive and Microsemi. SiFive’s HiFive Unleashed board should arrive less than two years after SiFive announced its first Linux-driven Freedom SoCs." />
<meta name="twitter:title" content="RISC-V gains momentum as it moves from MCUs to Linux-friendly SoCs" />
<meta name="twitter:site" content="@LinuxGizmos" />
<meta name="twitter:image" content="http://linuxgizmos.com/files/riscv-logo.jpg" />
<meta name="twitter:creator" content="@LinuxGizmos" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/linuxgizmos.com\/","name":"LinuxGizmos.com","alternateName":"LinuxGizmos","potentialAction":{"@type":"SearchAction","target":"http:\/\/linuxgizmos.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/linuxgizmos.com\/risc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs\/","sameAs":["http:\/\/facebook.com\/LinuxGizmos","https:\/\/plus.google.com\/b\/104414840801731506333\/+LinuxGizmos","https:\/\/twitter.com\/LinuxGizmos"],"@id":"#organization","name":"DeviceGuru Blog Network","logo":""}</script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com &raquo; RISC-V gains momentum as it moves from MCUs to Linux-friendly SoCs Comments Feed" href="http://linuxgizmos.com/risc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/linuxgizmos.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='xyz_cfm_short_code_style-css' href='http://linuxgizmos.com/wp-content/plugins/contact-form-manager/css/xyz_cfm_shortcode_style.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-style-css' href='http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='http://linuxgizmos.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.8' type='text/css' media='all' />
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script id='st_insights_js' type='text/javascript' src='http://w.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare'></script>
<link rel='https://api.w.org/' href='http://linuxgizmos.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://linuxgizmos.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://linuxgizmos.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.4" />
<link rel='shortlink' href='https://wp.me/p3cYEr-fW8' />
<link rel="alternate" type="application/json+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Frisc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Frisc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs%2F&#038;format=xml" />
<style type="text/css" media="screen">
      div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited {
        text-decoration: none;
        border: none;
      }
    </style>
<style type="text/css" media="screen">
          div.printfriendly {
            margin: 12px 12px 12px 30px;
            position: relative;
            z-index: 1000;
          }
          div.printfriendly a, div.printfriendly a:link, div.printfriendly a:visited {
            font-size: 14px;
            color: #6D9F00;
            vertical-align: bottom;
          }
          .printfriendly a {
            box-shadow:none;
          }
          .printfriendly a:hover {
            cursor: pointer;
          }
          .printfriendly a img  {
            border: none;
            padding:0;
            margin-right: 6px;
            box-shadow: none;
            -webkit-box-shadow: none;
            -moz-box-shadow: none;
          }
          .printfriendly a span{
            vertical-align: bottom;
          }
          .pf-alignleft {
            float: left;
          }
          .pf-alignright {
            float: right;
          }
          div.pf-aligncenter {
            display: block;
            margin-left: auto;
            margin-right: auto;
            text-align: center;
          }
        </style>
<style type="text/css" media="print">
          .printfriendly {
            display: none;
          }
        </style>
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<style type="text/css" id="wp-custom-css">
				/*
Welcome to Custom CSS!

To learn how this works, see http://wp.me/PEmnE-Bt
*/
.commentlist li {
	font-size: 1em;
}			</style>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5377446-2', 'linuxgizmos.com');
  ga('send', 'pageview');
</script>

<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css' href='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.8.3' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: 0px solid #59625c;		
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}		
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px;
								}
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}						
</style>

</head>
<body>
<div id="page">
<div id="header">


<script type="text/javascript">
_avp.push({ alias: '/', type: 'pagepeel', mid: 380, pid: 0 });
</script>

<a href="http://linuxgizmos.com/">
<div id="headerimg">

</div>
</a>
</div>
<hr />

<table align=center width="1022" height=25 border=0 cellpadding=0 cellspacing=0 bgcolor="#3b3b3b"><tr>
<td width="" align=center><a href="/"><font size="2em" color="white">All News</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/boards"><font size="2em" color="white">Boards</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/chips"><font size="2em" color="white">Chips</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/devices"><font size="2em" color="white">Devices</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/software"><font size="2em" color="white">Software</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="http://linuxdevices.io"><font size="2em" color="white"><font color="white">LinuxDevices.com Archive</b></font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/about"><font size="2em" color="white">About</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/contact"><font size="2em" color="white">Contact</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="#subscribe"><font size="2em" color="white">Subscribe</font></a></td>
</tr></table>

<table align=center width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

<center><table width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white"><tr>
<td width=14></td>
<td align=left>

<table align=left width=728 height=90 border=1 bordercolor="#ebebeb" cellpadding=0 cellspacing=0 bgcolor="white"><tr><td>

<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=20&pid=1&resolution='+screen.width+'x'+screen.height+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>

</td></tr></table>

</td>
<td width=10></td>
<td width=250 border=0 align=center>

<table align=left cellpadding=5 cellspacing=0 border=0>
<tr><td align=center valign=middle><font size=2em color="#4a8ca7"><b>Follow LinuxGizmos:</b></font></td></tr>
<tr><td align=center valign=middle>
<a href="http://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter-square-25px.png" alt="Twitter"></a>
<a href="https://plus.google.com/+LinuxGizmos/posts" rel="publisher" style="text-decoration:none;" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/googleplus-square-25px.png" alt="Google+"></a>
<a href="https://www.facebook.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="http://linuxgizmos.com/files/facebook-square-25px.png" alt="Facebook"></a>
<a href="/feed/" target="new"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss-square-25px.png" target="new"></a>
</td></tr>
<tr><td align=center valign=middle><a href="/#subscribe"><font size=2em color="#4a8ca7"><b>*</b> &nbsp; get email updates &nbsp; <b>*</b></font></a></td></tr>
</table>

</td>
</tr></table></center>

<table align=center width="100%" height=3 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>
<div id="sidebar">
<div class="sidebar-right">
<ul>
<li id="search-3" class="widget widget_search"><h2 class="widgettitle">Search LinuxGizmos:</h2>
<form method="get" id="searchform" action="http://linuxgizmos.com/">
<div><input type="text" value="" name="s" id="s" />
<input type="submit" id="searchsubmit" value="Search" />
</div>
</form></li>
<li id="text-33" class="widget widget_text"><h2 class="widgettitle">Search LinuxGizmos.com + LinuxDevices Archive:</h2>
<div class="textwidget"><form action="http://linuxgizmos.com/search" id="cse-search-box">
<div>
<input type="hidden" name="cx" value="partner-pub-3975801459690075:2161158331" />
<input type="hidden" name="cof" value="FORID:10" />
<input type="hidden" name="ie" value="UTF-8" />
<input type="text" name="q" size="23" />
<input type="submit" name="sa" value="Search" />
</div>
</form>
<script type="text/javascript" src="http://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script></div>
</li>
<li id="text-35" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
<div class="textwidget"><br> 
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/unique/javascript/strip?zid=18&pid=0&total=11&layout=vertical&margin=0&padding=15&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent(document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>

<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
</li>
<li id="top-posts-3" class="widget widget_top-posts"><h2 class="widgettitle">Top 10 trending posts&#8230; </h2>
<ul> <li>
<a href="http://linuxgizmos.com/risc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs/" class="bump-view" data-bump-view="tp">
RISC-V gains momentum as it moves from MCUs to Linux-friendly SoCs </a>
</li>
<li>
<a href="http://linuxgizmos.com/atom-c3000-based-net-appliance-offers-eight-lan-ports/" class="bump-view" data-bump-view="tp">
Atom C3000 based net appliance offers eight LAN ports </a>
</li>
<li>
<a href="http://linuxgizmos.com/open-spec-linux-android-sbcs-tap-high-end-allwinner-and-rockchip-socs/" class="bump-view" data-bump-view="tp">
Open spec Linux/Android SBCs tap high-end Allwinner and Rockchip SoCs </a>
</li>
<li>
<a href="http://linuxgizmos.com/mozillas-iot-things-gateway-software-gets-major-rev/" class="bump-view" data-bump-view="tp">
Mozilla&#039;s IoT software for the Raspberry Pi gets major rev </a>
</li>
<li>
<a href="http://linuxgizmos.com/automation-controller-debuts-linux-based-plcnext-software/" class="bump-view" data-bump-view="tp">
Automation controller debuts Linux-based PLCnext software </a>
</li>
<li>
<a href="http://linuxgizmos.com/rk3399-based-odroid-n1-sbc-doubles-up-on-sata-iii/" class="bump-view" data-bump-view="tp">
RK3399 based Odroid-N1 SBC doubles up on SATA III </a>
</li>
<li>
<a href="http://linuxgizmos.com/sifive-launches-first-risc-v-sbc-that-runs-linux/" class="bump-view" data-bump-view="tp">
SiFive launches first RISC-V SBC that runs Linux </a>
</li>
<li>
<a href="http://linuxgizmos.com/rugged-i-mx6-ul-box-pc-ships-with-open-linux-source/" class="bump-view" data-bump-view="tp">
Rugged i.MX6 UL box PC ships with open Linux source </a>
</li>
<li>
<a href="http://linuxgizmos.com/ringing-in-2017-with-90-hacker-friendly-single-board-computers/" class="bump-view" data-bump-view="tp">
Ringing in 2017 with 90 hacker-friendly single board computers </a>
</li>
<li>
<a href="http://linuxgizmos.com/skylake-based-nano-itx-sbc-offers-4x-gbe-and-8x-stackable-pcie-lanes/" class="bump-view" data-bump-view="tp">
Skylake-based Nano-ITX SBC offers 4x GbE and stackable PCIe </a>
</li>
</ul></li>
<li id="text-36" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
<div class="textwidget"><br>
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=21&pid=1&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>

<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
</li>
<li id="text-18" class="widget widget_text"> <div class="textwidget"><a name="subscribe"></a></div>
</li>
<li id="text-3" class="widget widget_text"><h2 class="widgettitle">Follow LinuxGizmos or subscribe to our posts:</h2>
<div class="textwidget"></div>
</li>
<li id="text-37" class="widget widget_text"> <div class="textwidget"><table align=center><tr><td align=center valign=middle><h2>Follow:</h2></td><td align=center valign=middle><a href="http://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/twitter.png" alt="Twitter" target="new"></a> <a href="https://plus.google.com/+LinuxGizmos/posts" rel="publisher" style="text-decoration:none;" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/gplus.png" alt="Google+"></a> <a href="https://www.facebook.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/facebook.png" alt="Facebook"></a> <a href="/feed/"><img height=25 width=25 vspace=5 hspace=5 alt="RSS feed" src="http://linuxgizmos.com/files/rss.png" target="new"></a></td></tr></table></div>
</li>
<li id="blog_subscription-2" class="widget jetpack_subscription_widget"><h2 class="widgettitle">Subscribe:</h2>
<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
<div id="subscribe-text"><p>Enter your email address to receive notifications of new posts:</p>
</div> <p id="subscribe-email">
<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-2">
Email Address </label>
<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-2" placeholder="Email Address" />
</p>
<p id="subscribe-submit">
<input type="hidden" name="action" value="subscribe" />
<input type="hidden" name="source" value="http://linuxgizmos.com/risc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs/" />
<input type="hidden" name="sub-type" value="widget" />
<input type="hidden" name="redirect_fragment" value="blog_subscription-2" />
<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
</p>
</form>
<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-2]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-2'),
					input = d.getElementById('subscribe-field-blog_subscription-2'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
</li>
</ul>
</div> 
</div>
<div id="content" class="narrowcolumn">
<div class="post" id="post-61264">
<h2><a href="http://linuxgizmos.com/risc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs/" rel="bookmark" title="Permanent Link: RISC-V gains momentum as it moves from MCUs to Linux-friendly SoCs">RISC-V gains momentum as it moves from MCUs to Linux-friendly SoCs</a></h2>
<small>Feb 8, 2018 &mdash; by Eric Brown </small>

<small> &mdash; 671 views </small>
<div class="entrytext">
<div class="ssba ssba-wrap"><div style="text-align:center"><i>Please share:</i> <a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=http://linuxgizmos.com/risc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs/&amp;text=RISC-V%20gains%20momentum%20as%20it%20moves%20from%20MCUs%20to%20Linux-friendly%20SoCs%20" target=&quot;_blank&quot;><img src="http://linuxgizmos.com/files/twitter-square-25px.png" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /></a><a data-site="" class="ssba_google_share" href="https://plus.google.com/share?url=http://linuxgizmos.com/risc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs/" target=&quot;_blank&quot;><img src="http://linuxgizmos.com/files/googleplus-square-25px.png" title="Share on Google+" class="ssba ssba-img" alt="Google+" /></a><a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=http://linuxgizmos.com/risc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs/" target="_blank"><img src="http://linuxgizmos.com/files/facebook-square-25px.png" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http://linuxgizmos.com/risc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs/" target=&quot;_blank&quot;><img src="http://linuxgizmos.com/files/linkedin-square-25px.png" alt="Share on LinkedIn" title="LinkedIn" class="ssba ssba-img" /></a><a data-site="reddit" class="ssba_reddit_share" href="http://reddit.com/submit?url=http://linuxgizmos.com/risc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs/&amp;title=RISC-V gains momentum as it moves from MCUs to Linux-friendly SoCs" target=&quot;_blank&quot;><img src="http://linuxgizmos.com/files/reddit-square-25px.png" title="Reddit" class="ssba ssba-img" alt="Share on Reddit" /></a><a data-site='pinterest' class='ssba_pinterest_share' href='javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;//assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());'><img title="Pinterest" class="ssba ssba-img" src="http://linuxgizmos.com/files/pinterest-square-25px.png" alt="Pin on Pinterest" /></a><a data-site="email" class="ssba_email_share" href="/cdn-cgi/l/email-protection#ba85c9cfd8d0dfd9ce87e8f3e9f997ec9f888adddbd3d4c99f888ad7d5d7dfd4cecfd79f888adbc99f888ad3ce9f888ad7d5ccdfc99f888adcc8d5d79f888af7f9efc99f888aced59f888af6d3d4cfc297dcc8d3dfd4ded6c39f888ae9d5f9c99c998a898281d8d5dec3879f888ad2cececa809595d6d3d4cfc2ddd3c0d7d5c994d9d5d795c8d3c9d997cc97dddbd3d4c997d7d5d7dfd4cecfd797dbc997d3ce97d7d5ccdfc997dcc8d5d797d7d9cfc997ced597d6d3d4cfc297dcc8d3dfd4ded6c397c9d5d9c995"><img src="http://linuxgizmos.com/files/email-square-25px.png" title="Email" class="ssba ssba-img" alt="Email to someone" /></a></div></div><div class="pf-content"><p><img align=left vspace=5 hspace=10 src="/files/riscv-logo.jpg">The open source RISC-V ISA has evolved quickly into silicon, thanks to help from companies like SiFive and Microsemi. SiFive’s HiFive Unleashed board should arrive less than two years after SiFive announced its first Linux-driven Freedom SoCs.<br />
<span id="more-61264"></span><br />
It’s been two years since the open source RISC-V architecture emerged from computer labs at UC Berkeley and elsewhere and began appearing in soft-core implementations designed for FPGAs, and over a year since the first commercial silicon arrived. So far, the focus has primarily been on MCU-like processors, but last October, SiFive announced the first Linux-driven RISC-V SoC with its quad-core, 64-bit bit <a href="http://linuxgizmos.com/sifive-unleashes-the-first-linux-ready-64-bit-risc-v-soc/" target="new">Freedom U540</a> (AKA U54-MC Coreplex). A few days ago at FOSDEM, SiFive opened pre-sales for an open source <a href="http://linuxgizmos.com/sifive-launches-first-risc-v-sbc-that-runs-linux/" target="new">HiFive Unleashed</a> SBC that showcases the U540.<br />
<center><br />
<a href="/files/sifive_hifiveunleashed_2018.jpg" target="new"><img src="/files/sifive_hifiveunleashed_2018-sm.jpg" vspace=10 hspace=5 border=0></a> <a href="/files/sifive_u540_block_2018.jpg" target="new"><img src="/files/sifive_u540_block_2018-sm.jpg" vspace=10 hspace=5 border=0></a><br />
<b>HiFive Unleashed (left) and Freedom U540 block diagram</b><br />
(click images to enlarge)<br />
</center><br />
The 28nm fabricated U540 SoC that drives the SBC is not only the first multi-core and Linux-ready RISC-V processor, but the first to provide cache coherence. In addition to the four 1.5GHz U54 RV64GC CPU cores, the SoC includes an E51 RV64IMAC management core. What you won’t find is a GPU or VPU. However, third parties are encouraged to integrate coprocessors and peripherals with the help of an open source TileLink interface bus.</p>
<p>The $999 HiFive Unleashed is available on Crowd Supply, with shipments due on June 30. The HiFive Unleashed board integrates a U540 SoC, 8GB of DDR4 RAM, and 32MB quad SPI flash. You also get a microSD slot, a GbE port, and an FMC expansion. Schematics and layout files will be available.</p>
<p>&nbsp;<br />
<b>RISC-V jumps out to a fast start</b></p>
<p>It’s too early to say whether RISC-V will ever rival ARM or x86, let alone match the reach of fading architectures such as MIPS and PowerPC. So far, however, there has been a surprising willingness on the part of major computer and semiconductor vendors to experiment with the new ISA. RISC-V Foundation Platinum members include heavy hitters like Draper, Google, Hewlett Packard Enterprise, IBM, Microsemi, Oracle, Microsoft, Nvidia, and Qualcomm. </p>
<table align=right vspace=5 hspace=10 border=0 cellpadding=0 cellspacing=0>
<tr>
<td align=center><img src="/files/riscv-logo.jpg" vspace=5 hspace=10><br /><b>RISC-V logo</b></td>
</tr>
</table>
<p>The widespread interest is partially due the fact that RISC-V has a free and permissive license that enables third parties to use the ISA to develop proprietary implementations. The expectation, however, is that most RISC-V SoCs will follow the early players’ leads in providing open source implementations.</p>
<p>RISC-V’s timing seems to be right, as the growing acceptance of open source software and hardware logically leads to a desire to open up of the processor. Opaque chip designs often create obstacles and blind spots &#8212; not only for open source projects, but also semiconductor vendors. Conceivably, hidden issues such as Intel’s <a href="https://techcrunch.com/2018/01/22/linus-torvalds-declares-intel-fix-for-meltdown-spectre-complete-and-utter-garbage/" target="new">Spectre and Meltdown</a> security problems might have come to light more quickly in the open source spotlight.</p>
<p>There’s also a sense that the dominance of two closed source architectures &#8212; ARM and Intel x86 &#8212; is limiting innovation, slowing time to market, and increasing cost. In addition, RISC-V advocates claim that both ARM and x86 platforms are burdened by legacy code. By comparison, RISC-V is starting with a clean slate of modern components.</p>
<table align=right vspace=5 hspace=10 border=0 cellpadding=0 cellspacing=0>
<tr>
<td align=center><img src="/files/ucb_krste_asanovic.jpg" vspace=5 hspace=10><br /><b>Krste Asanović</b></td>
</tr>
</table>
<p>SiFive was founded by RISC-V inventors including Yunsup Lee, Andrew Waterman, and <a href="https://www2.eecs.berkeley.edu/Faculty/Homepages/asanovic.html" target="new">Krste Asanović</a>, the current Chairman of the <a href="https://riscv.org/" target="new">RISC-V Foundation</a>, based in part on two earlier open source RISC ISAs: SPARC and OpenRISC. In 2014, Asanović and fellow UC Berkeley professor David Patterson, who coined the term RISC, posted a white paper on RISC-V, and development progressed rapidly from there.</p>
<p>SiFive has been the major RISC-V hardware player, while Microsemi has led the way in developing soft-core implementations that can run on FPGAs for prototyping. In Nov. 2016, SiFive announced an open source, Arduino compatible <a href="http://linuxgizmos.com/first-open-source-risc-v-chips-arrive-in-arduino-board/" target="new">HiFive1</a> development board for its <a href="http://linuxgizmos.com/first-socs-based-on-open-source-risc-v-run-linux/" target="new">Freedom E300</a> &#8212; an MCU-like RISC-V design with an E31 Coreplex core designed to run FreeRTOS. Developers could also use Microsemi’s soft-core <a href="https://www.microsemi.com/products/fpga-soc/soc-fpga/smartfusion2" target="new">SmartFusion 2</a> SoC FPGA to develop for the E300.</p>
<table align=right vspace=5 hspace=10 border=0 cellpadding=0 cellspacing=0>
<tr>
<td align=center><img src="/files/arduino_cinque-thm.jpg" vspace=5 hspace=10><br /><b>Arduino Cinque</b></td>
</tr>
</table>
<p>The HiFive1 was followed last May by an <a href="http://linuxgizmos.com/arduino-cinque-board-taps-sifive-risc-v-soc-and-an-esp32-wireless-chip/" target="new">Arduino Cinque</a> board based on the HiFive1, jointly developed by SiFive and Arduino. The key addition was an Espressif ESP32 SoC that supplies WiFi and Bluetooth.</p>
<p>SiFive and Microsemi aren’t the only vendors invested in RISC-V. Andes, Bluespec, Codasip, and Cortus sell RISC-V core IP that can be used to develop MCU-like SoCs. (SiFive also sells IP in addition to silicon and development services.) Like Microsemi, Rumble and Development and VectorBlox offer soft cores that run on FPGAs.</p>
<p>According to a recent summary of RISC-V developments posted on <a href="http://www.electronicdesign.com/embedded-revolution/11-myths-about-risc-v-isa" target="new">Electronic Design</a> by Microsemi’s Ted Marena, Vice Chair of the RIS-V Foundation’s RISC-V Marketing Committee, software support is also evolving. In the Linux realm, RISC-V support was added to the GNU/GCC and GNU/GDB toolchains last May. In addition, writes Marena, “several flavors of Linux are supported, including Yocto,” based on Linux 4.6. RISC-V support appears to be headed for a merge into kernel 4.14, which “means RISC-V will soon be a mainline platform in Linux.”</p>
<p>The HiFive Unleashed Crowd Supply page does not have much to say about software aside from noting Linux compatibility, and SiFive did not respond to our queries for more details. When the U540 SoC was announced, however, SiFive said the SoC would be supported by “a rich SDK with demo software and an easy-to-install binary toolchain.” Standard development and debug tools such as OpenOCD, GDB, and an Eclipse IDE, were also said to be in the works.</p>
<p>Performance questions should be partially answered when the HiFive Unleashed appears this Spring. According to an <a href="https://www.eetimes.com/document.asp?doc_id=1332398" target="new">EETimes story</a> posted in October, the “single issue” U54 core is expected to lag the performance of the “dual issue” Cortex-A53. Marena, however, claims that “the modularity of the RISC-V ISA design enables implementations to be more efficient than legacy ISAs such as x86 or ARM.”</p>
<p>In conjunction with the <a href="https://www.linux.com/blog/event/elc-open-iot/2018/1/elc-openiot-cloud-computing-robot-apocalypse" target="new">Embedded Linux Conference + OpenIoT</a> event to be held in Portland, Oregon on Mar. 12-14, SiFive will host the first hackathon for the HiFive Unleashed. Registered SiFive Developers will be able to attend the Portland event to try out the SBC. (More information may be found on the <a href="https://www.sifive.com/products/hifive-unleashed/" target="new">HiFive Unleashed product page</a>.) The ELC conference itself includes a presentation by Comcast’s Khem Raj called <a href="https://elciotna18.sched.com/event/DXmn" target="new">OpenEmbedded Yocto on RISC-V &#8212; New Kid on the Block</a>.</p>
<p><i>This article is copyright © 2018 Linux.com and was originally published <a href="https://www.linux.com/blog/event/elc-open-iot/2018/2/first-linux-based-risc-v-board-prepares-take" target="new">here</a>. It has been reproduced by this site with the permission of its owner. Please <a href="https://www.linux.com" target="new">visit Linux.com</a> for up-to-date news and articles about Linux and open source.</i></p>
</div><div class="crp_related "><h4>Related posts:</h4><ul><li><a href="http://linuxgizmos.com/arduino-shows-off-lora-gateway-and-node-shields/"><span class="crp_title">Arduino shows off LoRa gateway and node shields</span></a></li><li><a href="http://linuxgizmos.com/embedded-linux-conference-sessions-cover-real-time-linux-risc-v-zephyr-and-more/"><span class="crp_title">Mar. 12-14 Embedded Linux Conference sessions to&hellip;</span></a></li><li><a href="http://linuxgizmos.com/diy-a-risc-v-soc-with-sifives-hassle-free-process/"><span class="crp_title">Design your own RISC-V SoC with SiFive&#8217;s new&hellip;</span></a></li><li><a href="http://linuxgizmos.com/sifive-unleashes-the-first-linux-ready-64-bit-risc-v-soc/"><span class="crp_title">SiFive unleashes the first Linux-ready, 64-bit RISC-V SoC</span></a></li><li><a href="http://linuxgizmos.com/arduino-cinque-board-taps-sifive-risc-v-soc-and-an-esp32-wireless-chip/"><span class="crp_title">Arduino Cinque board taps SiFive RISC-V SoC and an&hellip;</span></a></li><li><a href="http://linuxgizmos.com/first-socs-based-on-open-source-risc-v-run-linux/"><span class="crp_title">First SoCs based on open source RISC-V run Linux</span></a></li><li><a href="http://linuxgizmos.com/first-open-source-risc-v-chips-arrive-in-arduino-board/"><span class="crp_title">First open source RISC-V chips arrive in Arduino board</span></a></li><li><a href="http://linuxgizmos.com/sifive-launches-first-risc-v-sbc-that-runs-linux/"><span class="crp_title">SiFive launches first RISC-V SBC that runs Linux</span></a></li><li><a href="http://linuxgizmos.com/arduino-announces-dev-workshop-following-musto-ouster/"><span class="crp_title">Arduino announces developer workshop following Musto ouster</span></a></li><li><a href="http://linuxgizmos.com/arm-becomes-arm-or-is-it-arm/"><span class="crp_title">Chip IP designer ARM becomes &#8220;Arm&#8221;&hellip;</span></a></li></ul><div class="crp_clear"></div></div> </div>
</div>
<table align=center border=0 bordercolor="#ebebeb" cellpadding=0 cellspacing=0>
<tr><td bgcolor="#f4f4f4" align=center valign=middle>

<script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=22&pid=0&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>

</td></tr></table>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
<br><br>

<div class="printfriendly pf-alignleft"><a href="#" rel="nofollow" onclick="window.print();if(typeof(_gaq) != 'undefined') { _gaq.push(['_trackEvent','PRINTFRIENDLY', 'print', 'NULL']);
          }else if(typeof(ga) != 'undefined') {  ga('send', 'event','PRINTFRIENDLY', 'print', 'NULL'); } return false;" class="noslimstat" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="https://cdn.printfriendly.com/buttons/printfriendly-button-nobg.png" alt="Print Friendly, PDF & Email" /></a></div>
<table width="100%" bordercolor="#ebebeb" border=1 cellpadding=10 cellspacing="0" align=center>
<tr><td align=center><b><font color="#4a8ca7" size=3>PLEASE COMMENT BELOW</font></b></td></tr></table>


<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Please comment here... <small><a rel="nofollow" id="cancel-comment-reply-link" href="/risc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe src="http://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&#038;postid=61264&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=blank&#038;greeting=Please+comment+here...&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.8&#038;sig=9849090e36c588ee9bb5950faa5dc46d948d01e6#parent=http%3A%2F%2Flinuxgizmos.com%2Frisc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
<!--[if !IE]><!-->
<script>
					document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});
				</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
<div id="footer">

<table width="100%" border=0 cellpadding=10 cellspacing=0><tr><td></td></tr></table>
<table align="center" width=728 height=90 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td border=1 bordercolor="#4a8ca7" bgcolor="#f4f4f4" align=center valign=middle>

<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=23&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>

</td></tr>
<tr><td></table>
<table width="100%" border=0 cellpadding=5 cellspacing=0><tr><td>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
</td></tr></table>

<div>
<font size=1><i>The content on this site is copyright &copy; 2007-2018 Rick Lehrbaum unless otherwise noted. Comments are the property of their submitters. LinuxGizmos is part of the <a href="http://deviceguru.com/about/" target="new"><u>DeviceGuru Blog Network</u></a>. Linux is a registered trademark of Linus Torvalds.</i></font>
</div>
<br>
<div align=center>
<font size=2><a href="/contact"><font color="#4a8ca7"><u>Contact us</u></font></a> | <a href="http://www.deviceguru.com/privacy/"><font color="#4a8ca7"><u>Privacy policy</u></font></a> | <a href="/terms-of-use" target="new"><font color="#4a8ca7"><u>Terms of use</u></font></a> | <a href="/about"><font color="#4a8ca7"><u>About us</u></font></a> | <a href="/feed"><font color="#4a8ca7"><u>RSS feed</u></font></a> </font>
</div>



</div>
</div>
<script type="text/javascript">

          var pfHeaderImgUrl = 'http://linuxgizmos.com/files/linuxgizmos-logo.jpg';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '1';
          var pfImagesSize = 'medium';
          var pfImageDisplayStyle = 'block';
          var pfDisableEmail = '1';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
      (function() {
            var e = document.createElement('script'); e.type="text/javascript";
            e.src = 'https://cdn.printfriendly.com/printfriendly.js';
            document.getElementsByTagName('head')[0].appendChild(e);
        })();
      </script>
<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css' href='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.9.4' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: 0px solid #59625c;
									
									
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px;
								}
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}
								
</style>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"M. d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201806'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=4.9.4'></script>
<script type='text/javascript'>
Main.boot( [] );
</script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>
<script async="async" type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.2'></script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=61264&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.8&sig=9849090e36c588ee9bb5950faa5dc46d948d01e6#parent=http%3A%2F%2Flinuxgizmos.com%2Frisc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=61264&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.8&sig=9849090e36c588ee9bb5950faa5dc46d948d01e6#parent=http%3A%2F%2Flinuxgizmos.com%2Frisc-v-gains-momentum-as-it-moves-from-mcus-to-linux-friendly-socs%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "http:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-201806.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.8',blog:'47422091',post:'61264',tz:'-8',srv:'linuxgizmos.com'} ]);
	_stq.push([ 'clickTrackerInit', '47422091', '61264' ]);
</script>



</body>
</html>