<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>Pi HAT brings Time-Sensitive Networking (TSN) to Raspberry Pi 4</title> 

<meta name="generator" content="WordPress 5.8" /> <!-- leave this for stats -->

<link rel="stylesheet" href="http://linuxgizmos.com/wp-content/themes/lg-theme/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com RSS Feed" href="http://linuxgizmos.com/feed/" />

<link rel="pingback" href="http://linuxgizmos.com/xmlrpc.php" />

<!-- G+ author attribution -->
<link rel="author" href="https://plus.google.com/104414840801731506333" />

<style type="text/css" media="screen">
	#headerimg { margin: 0; margin-top: 0px; height: 80px; width: 1022px; }
	#headerimg { background: url('http://linuxgizmos.com/wp-content/themes/lg-theme/images/header.jpg') no-repeat top;}
</style>

<script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v16.7 - https://yoast.com/wordpress/plugins/seo/ -->
	<link rel="canonical" href="http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Pi HAT brings Time-Sensitive Networking (TSN) to Raspberry Pi 4" />
	<meta property="og:description" content="InnoRoute has launched its &ldquo;Real-Time HAT,&rdquo; a HAT for Raspberry Pi 4 that enables support for TSN and other real-time protocols. The Artix-7 FPGA-based HAT supports TSN and PoE through its 3 GbE ports. InnoRoute has rolled out the Real-Time HAT, a HAT that brings Time-Sensitive Networking (TSN) capability to the Raspberry Pi 4. At [&hellip;]" />
	<meta property="og:url" content="http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/" />
	<meta property="og:site_name" content="LinuxGizmos.com" />
	<meta property="article:publisher" content="http://facebook.com/LinuxGizmos" />
	<meta property="article:published_time" content="2021-08-18T17:01:32+00:00" />
	<meta property="article:modified_time" content="2021-08-18T17:01:35+00:00" />
	<meta property="og:image" content="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-125x75.jpg" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@LinuxGizmos" />
	<meta name="twitter:site" content="@LinuxGizmos" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jeff Child" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://linuxgizmos.com/#website","url":"http://linuxgizmos.com/","name":"LinuxGizmos.com","description":"Embedded Linux news &amp; devices","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"http://linuxgizmos.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/#primaryimage","inLanguage":"en-US","url":"http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front.jpg","contentUrl":"http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front.jpg","width":750,"height":452},{"@type":"WebPage","@id":"http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/#webpage","url":"http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/","name":"Pi HAT brings Time-Sensitive Networking (TSN) to Raspberry Pi 4","isPartOf":{"@id":"http://linuxgizmos.com/#website"},"primaryImageOfPage":{"@id":"http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/#primaryimage"},"datePublished":"2021-08-18T17:01:32+00:00","dateModified":"2021-08-18T17:01:35+00:00","author":{"@id":"http://linuxgizmos.com/#/schema/person/48982457a83ccc92b3cbb2f7f1e1366a"},"breadcrumb":{"@id":"http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/"]}]},{"@type":"BreadcrumbList","@id":"http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"http://linuxgizmos.com/"},{"@type":"ListItem","position":2,"name":"Pi HAT brings Time-Sensitive Networking (TSN) to Raspberry Pi 4"}]},{"@type":"Person","@id":"http://linuxgizmos.com/#/schema/person/48982457a83ccc92b3cbb2f7f1e1366a","name":"Jeff Child","sameAs":["http://circuitcellar.com"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com &raquo; Pi HAT brings Time-Sensitive Networking (TSN) to Raspberry Pi 4 Comments Feed" href="http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/linuxgizmos.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://linuxgizmos.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='http://linuxgizmos.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='http://linuxgizmos.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='ssb-front-css-css'  href='http://linuxgizmos.com/wp-content/plugins/simple-social-buttons/assets/css/front.css?ver=3.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='kadence-blocks-gallery-css'  href='http://linuxgizmos.com/wp-content/plugins/kadence-blocks/dist/blocks/gallery.style.build.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='kadence-blocks-pro-slick-css'  href='http://linuxgizmos.com/wp-content/plugins/kadence-blocks/dist/vendor/kt-blocks-slick.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://linuxgizmos.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.9.1' type='text/css' media='all' />
<script id='st_insights_js' type='text/javascript' src="https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare" id='ssba-sharethis-js'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='ssb-front-js-js-extra'>
/* <![CDATA[ */
var SSB = {"ajax_url":"http:\/\/linuxgizmos.com\/wp-admin\/admin-ajax.php","fb_share_nonce":"595b7fe21d"};
/* ]]> */
</script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/simple-social-buttons/assets/js/front.js?ver=3.2.3' id='ssb-front-js-js'></script>
        <style>
            .eaa-clean {
                padding: 0 !important;
                border: none !important;
            }

            .eaa-ad.alignleft {
                margin-right: 10px;
            }

            .eaa-ad.alignright {
                margin-left: 10px;
            }
            .eaa-ad.debug{
                background:peachpuff;
                border:solid 2px #FF0000;
                box-sizing: border-box;
            }

        </style>


		<link rel="https://api.w.org/" href="http://linuxgizmos.com/wp-json/" /><link rel="alternate" type="application/json" href="http://linuxgizmos.com/wp-json/wp/v2/posts/77530" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://linuxgizmos.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://linuxgizmos.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8" />
<link rel='shortlink' href='https://wp.me/p3cYEr-kau' />
<link rel="alternate" type="application/json+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Fpi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Fpi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4%2F&#038;format=xml" />
 <style media="screen">

		.simplesocialbuttons.simplesocialbuttons_inline .ssb-fb-like {
	  margin: ;
	}
		 /*inline margin*/
	
	
	
	
	
		.simplesocialbuttons.simplesocialbuttons_inline.simplesocial-round-icon button{
	  margin: ;
	}

	
			 /*margin-digbar*/

	
	
	
	
	
	
	
</style>

<!-- Open Graph Meta Tags generated by Simple Social Buttons 3.2.3 -->
<meta property="og:title" content="Pi HAT brings Time-Sensitive Networking (TSN) to Raspberry Pi 4 - LinuxGizmos.com" />
<meta property="og:description" content="InnoRoute has launched its “Real-Time HAT,” a HAT for Raspberry Pi 4 that enables support for TSN and other real-time protocols. The Artix-7 FPGA-based HAT supports TSN and PoE through its 3 GbE ports.







InnoRoute has rolled out the Real-Time HAT, a HAT that brings Time-Sensitive Networking (TSN) capability to the Raspberry Pi 4. At the heart of the Real-Time HAT’s" />
<meta property="og:url" content="http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/" />
<meta property="og:site_name" content="LinuxGizmos.com" />
<meta property="og:image" content="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-125x75.jpg" />
<meta property="og:image" content="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-1.jpg" />
<meta property="og:image" content="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-on-a-RPi-4B.jpg" />
<meta property="og:image" content="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-details1-1024x716.png" />
<meta property="og:image" content="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-conncetions-1-1024x659.png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="InnoRoute has launched its “Real-Time HAT,” a HAT for Raspberry Pi 4 that enables support for TSN and other real-time protocols. The Artix-7 FPGA-based HAT supports TSN and PoE through its 3 GbE ports.







InnoRoute has rolled out the Real-Time HAT, a HAT that brings Time-Sensitive Networking (TSN) capability to the Raspberry Pi 4. At the heart of the Real-Time HAT’s" />
<meta name="twitter:title" content="Pi HAT brings Time-Sensitive Networking (TSN) to Raspberry Pi 4 - LinuxGizmos.com" />
<meta property="twitter:image" content="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-125x75.jpg" />
<meta property="twitter:image" content="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-1.jpg" />
<meta property="twitter:image" content="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-on-a-RPi-4B.jpg" />
<meta property="twitter:image" content="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-details1-1024x716.png" />
<meta property="twitter:image" content="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-conncetions-1-1024x659.png" />
			<style type="text/css" id="wp-custom-css">
				figcaption {
    text-align: center; margin: auto;
}			</style>
		
<!-- google adsense verification tag -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4310582701436176",
    enable_page_level_ads: true
  });
</script>
<!-- end google adsense verification tag -->
	
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5377446-2', 'linuxgizmos.com');
  ga('send', 'pageview');
</script>
	
<!-- clone of ssba css as of v7.4.10 -->
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=4.9.4' type='text/css' media='all' />

<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css'  href='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.9.4' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: 0px solid #59625c;
									
									
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								#ssba-classic-2 .ssbp-text {
									display: none!important;
								}
								
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px; }
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}
								
@font-face {
				font-family: 'ssbp';
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<!-- end clone of ssba css -->	
	
</head>
<body>
<div id="page">

<div id="header">

<!-- optional Advertserve page peel ad Display Code goes below here -->
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
_avp.push({ alias: '/', type: 'pagepeel', mid: 380, pid: 0 });
</script>
<!-- END ADVERTSERVE CODE -->

<a href="http://linuxgizmos.com/">
    <div id="headerimg">

     <!--
     <h1> <a href="http://linuxgizmos.com/">LinuxGizmos.com</a></h1> 
     <div class="description"><i>Embedded Linux news &amp; devices</i></div> 
     -->
    </div>

</a>

</div>

<hr />
<!-- section links start -->
<table align=center width="1022" height=25 border=0 cellpadding=0 cellspacing=0 bgcolor="#3b3b3b"><tr>
<td width="" align=center><a href="/"><font size="2em" color="white">All News</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/boards"><font size="2em" color="white">Boards</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/chips"><font size="2em" color="white">Chips</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/devices"><font size="2em" color="white">Devices</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/software"><font size="2em" color="white">Software</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="http://linuxdevices.org"><font size="2em" color="white"><font color="white">LinuxDevices.com Archive</b></font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/about"><font size="2em" color="white">About</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/contact"><font size="2em" color="white">Contact</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="#subscribe"><font size="2em" color="white">Subscribe</font></a></td>
</tr></table>
<!-- section links end -->

<table align=center width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

<!-- header banner wrapper starts -- NOTE: total width = 1022 px -->
<center><table width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white"><tr>

<td width=14></td>

<td align=left>
<!-- 728x90 ad goes below here -->
<table align=left width=728 height=90 border=1 bordercolor="#ebebeb" cellpadding=0 cellspacing=0 bgcolor="white"><tr><td>
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=20&pid=1&resolution='+screen.width+'x'+screen.height+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<!-- 728x90 ad goes above here -->
</td>

<td width=10></td>

<td width=250 border=0 align=center>
<!-- sharing and subscription block goes below here -->
<table align=left cellpadding=5 cellspacing=0 border=0>
<tr><td align=center valign=middle><font size=2em color="#4a8ca7"><b>Follow LinuxGizmos:</b></font></td></tr>
<tr><td align=center valign=middle>
<a href="https://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter-square-25px.png" alt="Twitter"></a> 
<a href="https://www.facebook.com/LinuxGizmos/posts/" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/facebook-square-25px.png" alt="Facebook"></a>  
<a href="https://www.pinterest.com/LinuxGizmos/" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/pinterest-square-25px.png" alt="Pinterest"></a> 
<a href="/feed/" target="new"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss-square-25px.png" target="new"></a>
</td></tr>
<tr><td align=center valign=middle><a href="/#subscribe"><font size=2em color="#4a8ca7"><b>*</b> &nbsp; get email updates &nbsp; <b>*</b></font></a></td></tr>
</table>
<!-- sharing and subscription block goes above here -->
</td>
</tr></table></center>
<!-- header banner wrapper ends -->

<table align=center width="100%" height=3 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

	<div id="sidebar">
	<div class="sidebar-right">
		<ul>
			<li id="search-3" class="widget widget_search"><h2 class="widgettitle">Search LinuxGizmos:</h2>
<form method="get" id="searchform" action="http://linuxgizmos.com/">
<div><input type="text" value="" name="s" id="s" />
<input type="submit" id="searchsubmit" value="Search" />
</div>
</form></li>
<li id="text-33" class="widget widget_text"><h2 class="widgettitle">Search LinuxGizmos.com + LinuxDevices Archive:</h2>
			<div class="textwidget"><form action="http://linuxgizmos.com/search" id="cse-search-box">
  <div>
    <input type="hidden" name="cx" value="partner-pub-3975801459690075:2161158331" />
    <input type="hidden" name="cof" value="FORID:10" />
    <input type="hidden" name="ie" value="UTF-8" />
    <input type="text" name="q" size="23" />
    <input type="submit" name="sa" value="Search" />
  </div>
</form>
<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script></div>
		</li>
<li id="text-35" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
			<div class="textwidget"><br><!-- BEGIN ZONE 2 ADVERTSERVE CODE --> <!-- set total to zone 2 (non-dg) campaigns minus 1 -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/unique/javascript/strip?zid=18&pid=1&total=13&layout=vertical&margin=0&padding=15&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent(document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
		</li>
<li id="top-posts-4" class="widget widget_top-posts"><h2 class="widgettitle">Top 10 trending posts&#8230;</h2>
<ul>				<li>
					<a href="http://linuxgizmos.com/pine64-preps-10-1-inch-e-ink-tablet-with-rk3566/" class="bump-view" data-bump-view="tp">Pine64 preps 10.1-inch E-Ink tablet with RK3566</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/qualcomms-latest-drone-platform-features-5g-and-seven-cameras/" class="bump-view" data-bump-view="tp">Qualcomm&#039;s latest drone platform features 5G and seven cameras</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/the-best-way-to-build-with-yocto-project-and-bitbake/" class="bump-view" data-bump-view="tp">The best way to build with Yocto Project and BitBake</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/" class="bump-view" data-bump-view="tp" aria-current="page">Pi HAT brings Time-Sensitive Networking (TSN) to Raspberry Pi 4</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/sata-hats-support-up-to-four-drives-on-raspberry-pi-4-or-rock-pi-4/" class="bump-view" data-bump-view="tp">SATA HATs support up to four drives on Raspberry Pi 4 or Rock Pi 4</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/intels-elkhart-lake-powers-three-new-thin-mini-itx-boards/" class="bump-view" data-bump-view="tp">Intel&#039;s Elkhart Lake powers three new thin Mini-ITX boards</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/turing-pi-2-clusters-four-raspberry-pi-cm4-modules/" class="bump-view" data-bump-view="tp">Turing Pi 2 clusters four Raspberry Pi CM4 modules</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/raspberry-pi-cm4-carriers-boast-dual-lan-ports/" class="bump-view" data-bump-view="tp">Raspberry Pi CM4 carriers boast dual LAN ports</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/i-mx8m-plus-powered-pico-itx-has-stackable-expansion-board/" class="bump-view" data-bump-view="tp">i.MX8M Plus powered Pico-ITX has stackable expansion board</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/linux-based-pinetab-tablet-launches-at-100-adds-m-2-slot/" class="bump-view" data-bump-view="tp">Linux-based PineTab tablet launches at $100, adds M.2 slot</a>					</li>
				</ul></li>
<li id="text-36" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
			<div class="textwidget"><br><!-- BEGIN ZONE 3 ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=21&pid=1&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
		</li>
<li id="text-18" class="widget widget_text">			<div class="textwidget"><a name="subscribe"></a></div>
		</li>
<li id="text-3" class="widget widget_text"><h2 class="widgettitle">Follow LinuxGizmos or subscribe to our posts:</h2>
			<div class="textwidget"></div>
		</li>
<li id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><table>
<tr><td align=center valign=middle>
&nbsp;&nbsp;
<a href="https://www.twitter.com/LinuxGizmos" target="new" rel="noopener"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter-square-25px.png" alt="Twitter"></a>
<a href="https://www.facebook.com/LinuxGizmos/posts/" target="new" rel="noopener"><img height=25 width=25 vspace=0 hspace=5 src="/files/facebook-square-25px.png" alt="Facebook"></a>
<a href="https://www.pinterest.com/LinuxGizmos/" target="new" rel="noopener"><img height=25 width=25 vspace=0 hspace=5 src="/files/pinterest-square-25px.png" alt="Pinterest"></a>
<a href="/feed/" target="new" rel="noopener"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss-square-25px.png" target="new"></a>
</td></tr></table></div></li>
<li id="blog_subscription-3" class="widget widget_blog_subscription jetpack_subscription_widget"><h2 class="widgettitle">Subscribe</h2>

            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
				                    <div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div>					<div class="jetpack-subscribe-count">
						<p>
						Join 1,338 other subscribers						</p>
					</div>
					                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-3">
							email address                        </label>
                        <input type="email" name="email" required="required"
                        			                                                value=""
                            id="subscribe-field-blog_subscription-3"
                            placeholder="email address"
                        />
                    </p>

					<p id="subscribe-submit"
											>
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-3"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Subscribe                        </button>
                    </p>
				            </form>
		
</li>

		</ul>
	</div>	<!--sidebar-left-->


	</div>


	<div id="content" class="narrowcolumn">
				
  		
		<div class="post" id="post-77530">
			<h2><a href="http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/" rel="bookmark" title="Permanent Link: Pi HAT brings Time-Sensitive Networking (TSN) to Raspberry Pi 4">Pi HAT brings Time-Sensitive Networking (TSN) to Raspberry Pi 4</a></h2>

		<small>Aug 18, 2021 &mdash; by Jeff Child </small>

	<!-- tag for gapp post pageviews plugin -->
    <small>  </small> 

	<!-- tag for WP Stats View Counter -->
 <small> &mdash; 78 views</small>
			
			<div class="entrytext">
				<div class="simplesocialbuttons simplesocial-round-icon simplesocialbuttons_inline simplesocialbuttons-align-left post-77530 post  simplesocialbuttons-inline-no-animation">
<button class="simplesocial-twt-share" data-href="https://twitter.com/share?text=Pi+HAT+brings+Time-Sensitive+Networking+%28TSN%29+to+Raspberry+Pi+4&url=http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/&via=@linuxgizmos" rel="nofollow" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">Twitter</span> </button>
<button class="simplesocial-fb-share" target="_blank" data-href="https://www.facebook.com/sharer/sharer.php?u=http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">Facebook </span> </button>
<button target="popup" class="simplesocial-linkedin-share" data-href="https://www.linkedin.com/cws/share?url=http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">LinkedIn</span></button>
<button class="simplesocial-reddit-share"  data-href="https://reddit.com/submit?url=http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/&title=Pi+HAT+brings+Time-Sensitive+Networking+%28TSN%29+to+Raspberry+Pi+4" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;" ><span class="simplesocialtxt">Reddit</span> </button>
<button rel="nofollow" class="simplesocial-pinterest-share" onclick="var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);return false;" ><span class="simplesocialtxt">Pinterest</span></button>
<button onclick="javascript:window.location.href = this.dataset.href;return false;" class="simplesocial-email-share" data-href="mailto:?subject=Pi+HAT+brings+Time-Sensitive+Networking+%28TSN%29+to+Raspberry+Pi+4&body=http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/"><span class="simplesocialtxt">Email</span></button>
</div>

<div class="wp-block-image"><figure class="alignleft size-thumbnail is-resized"><img loading="lazy" src="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-125x75.jpg" alt="" class="wp-image-77531" width="126" height="75" srcset="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-125x75.jpg 125w, http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-450x271.jpg 450w, http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front.jpg 750w" sizes="(max-width: 126px) 100vw, 126px" /></figure></div>



<p>InnoRoute has launched its “Real-Time HAT,” a HAT for Raspberry Pi 4 that enables support for TSN and other real-time protocols. The Artix-7 FPGA-based HAT supports TSN and PoE through its 3 GbE ports.</p>



<span id="more-77530"></span>



<p>InnoRoute has rolled out the Real-Time HAT, a HAT that brings Time-Sensitive Networking (TSN) capability to the Raspberry Pi 4. At the heart of the Real-Time HAT’s functionality is a Xilinx Artix-7 FPGA and three Analog Devices ADIN13007 Gbit Ethernet transceiver PHY chips. The HAT enables precise network timing for real time protocols such as TSN and others. It can do synchronization between HATs, over the network, or with external GPS PPS. Its connectors are set up so that additional HATs can be attached on top of the Real-Time HAT.</p>



<div class="wp-block-kadence-advancedgallery kb-gallery-wrap-id-_4990c5-c1"><div class="kb-gallery-ul kb-gallery-type-carousel kb-gallery-id-_4990c5-c1 kb-gallery-caption-style-bottom-hover kb-gallery-filter-none" data-image-filter="none" data-lightbox-caption="true"><div class="kt-blocks-carousel kt-carousel-container-dotstyle-dark"><div class="kt-blocks-carousel-init kb-gallery-carousel kt-carousel-arrowstyle-whiteondark kt-carousel-dotstyle-dark" data-columns-xxl="3" data-columns-xl="3" data-columns-md="3" data-columns-sm="2" data-columns-xs="1" data-columns-ss="1" data-slider-anim-speed="400" data-slider-scroll="1" data-slider-arrows="true" data-slider-dots="true" data-slider-hover-pause="false" data-slider-auto="false" data-slider-speed="7000"><div class="kb-slide-item kb-gallery-carousel-item"><div class="kadence-blocks-gallery-item"><div class="kadence-blocks-gallery-item-inner"><figure class="kb-gallery-figure kb-gallery-item-has-link kadence-blocks-gallery-item-hide-caption kb-has-image-ratio-land32"><a href="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-1.jpg" class="kb-gallery-item-link"><div class="kb-gal-image-radius"><div class="kb-gallery-image-contain kadence-blocks-gallery-intrinsic kb-gallery-image-ratio-land32"><img loading="lazy" src="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-1.jpg" width="750" height="452" alt="" data-full-image="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-1.jpg" data-light-image="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-1.jpg" data-id="77536" data-link="http://linuxgizmos.com/?attachment_id=77536" class="wp-image-77536 skip-lazy" srcset="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-1.jpg 750w, http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-1-450x271.jpg 450w, http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-front-1-125x75.jpg 125w" sizes="(max-width: 750px) 100vw, 750px" /></div></div></a></figure></div></div></div><div class="kb-slide-item kb-gallery-carousel-item"><div class="kadence-blocks-gallery-item"><div class="kadence-blocks-gallery-item-inner"><figure class="kb-gallery-figure kb-gallery-item-has-link kadence-blocks-gallery-item-hide-caption kb-has-image-ratio-land32"><a href="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-on-a-RPi-4B.jpg" class="kb-gallery-item-link"><div class="kb-gal-image-radius"><div class="kb-gallery-image-contain kadence-blocks-gallery-intrinsic kb-gallery-image-ratio-land32"><img loading="lazy" src="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-on-a-RPi-4B.jpg" width="744" height="545" alt="" data-full-image="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-on-a-RPi-4B.jpg" data-light-image="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-on-a-RPi-4B.jpg" data-id="77537" data-link="http://linuxgizmos.com/?attachment_id=77537" class="wp-image-77537 skip-lazy" srcset="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-on-a-RPi-4B.jpg 744w, http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-on-a-RPi-4B-450x330.jpg 450w, http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-on-a-RPi-4B-125x92.jpg 125w" sizes="(max-width: 744px) 100vw, 744px" /></div></div></a></figure></div></div></div></div></div></div></div>



<p class="has-text-align-center"><strong>Real-Time HAT (left) and Real-Time HAT on a Raspberry PI 4B</strong><br>(click images to enlarge)</p>



<p>InnoRoute says it created Real-Time HAT as a low-cost alternative to it high-end industrial Ethernet/TSN router, TrustNode. The company also saw a need for a general-purpose FPGA HAT with Ethernet ports, for network monitoring on a Raspberry PI, for hardware-accelerated routing and other applications. The Raspberry Pi’s Ethernet connection lacks features useful for many professional networking applications, like time-triggered sending of frames, precise reception timestamping for advanced traffic analysis, and precise and accurate network time synchronization, says the company. Meanwhile, the RPi cannot easily be used in between other network devices, because it provides just one network port. The Real-Time HAT solves these issues, while adding other network-related features.</p>



<p>We’ve covered a steady stream of Raspberry Pi HAT products so far in 2021, including Blinkinlabs’ <a href="http://linuxgizmos.com/openocd-ready-hat-turns-the-pi-into-a-debugger-with-cortex-m-and-jtag-headers/" target="_blank" rel="noreferrer noopener">JTAG HAT</a>, Seeed’s <a href="http://linuxgizmos.com/lorawan-hat-for-raspberry-pi-offers-gps-too/" target="_blank" rel="noreferrer noopener">WM1302 HAT</a> with LoRaWAN Gateway Module, Zymbit’s <a href="http://linuxgizmos.com/security-module-available-in-phat-kit-for-raspberry-pi-and-jetson/" target="_blank" rel="noreferrer noopener">HSM4 security module HAT</a>, and Raspberry Pi Trading’s own <a href="http://linuxgizmos.com/raspberry-pi-poe-hat-features-25-5w-poe/" target="_blank" rel="noreferrer noopener">PoE+ HAT</a>. This the first HAT we’ve seen for TSN, although we’ve seen TSN offered on other module and box products such as TQ-Embedded’s <a href="http://linuxgizmos.com/linux-powered-am65xx-module-supports-up-to-six-gigabit-tsn-ports/" target="_blank" rel="noreferrer noopener">TQMa65xx module</a>, Vecow’s <a href="http://linuxgizmos.com/fanless-elkhart-lake-embedded-pc-features-2-5gbe-with-tsn/" target="_blank" rel="noreferrer noopener">rSPC-6000 embedded PC</a>, and Adlink’s <a href="http://linuxgizmos.com/i-mx8m-based-smarc-module-adds-crypto-chip-and-optional-tsn/" target="_blank" rel="noreferrer noopener">LEC-iMX8M SMARC module</a>. The Adlink product offers IEEE-1588 compliant PTP (Precision Time Protocol) and optional TSN support.</p>



<p>As shown in the diagram below, the Real-Time HAT has a Xilinx Artik-7 FPGA and two memory chips for optional buffer extension. For networking, GbE port 0 provides IEEE1588/TSN signaling, GbE port 1 links to the Raspberry Pi 4 and GbE port 2 does PoE, without TSN. The board has a standard 40-pin Raspberry Pi header. Other components include JTAG and PMod connectors, 3x LEDs, and EEPROM for Raspberry Pi HAT compliance.</p>



<div class="wp-block-kadence-advancedgallery kb-gallery-wrap-id-_2cf175-61"><div class="kb-gallery-ul kb-gallery-type-slider kb-gallery-id-_2cf175-61 kb-gallery-caption-style-bottom-hover kb-gallery-filter-none" data-image-filter="none" data-lightbox-caption="true"><div class="kt-blocks-carousel kt-carousel-container-dotstyle-dark"><div class="kt-blocks-carousel-init kb-blocks-slider kt-carousel-arrowstyle-whiteondark kt-carousel-dotstyle-dark" data-slider-anim-speed="400" data-slider-type="slider" data-slider-scroll="1" data-slider-arrows="true" data-slider-dots="true" data-slider-hover-pause="false" data-slider-auto="false" data-slider-speed="7000"><div class="kb-slide-item kb-gallery-slide-item"><div class="kadence-blocks-gallery-item"><div class="kadence-blocks-gallery-item-inner"><figure class="kb-gallery-figure kb-gallery-item-has-link kadence-blocks-gallery-item-hide-caption kb-has-image-ratio-land32"><a href="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-details1.png" class="kb-gallery-item-link"><div class="kb-gal-image-radius"><div class="kb-gallery-image-contain kadence-blocks-gallery-intrinsic kb-gallery-image-ratio-land32"><img loading="lazy" src="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-details1-1024x716.png" width="1024" height="716" data-full-image="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-details1.png" data-light-image="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-details1.png" data-id="77552" data-link="http://linuxgizmos.com/?attachment_id=77552" class="wp-image-77552 skip-lazy" srcset="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-details1-1024x716.png 1024w, http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-details1-450x314.png 450w, http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-details1-125x87.png 125w, http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-details1.png 1408w" sizes="(max-width: 1024px) 100vw, 1024px" /></div></div></a></figure></div></div></div></div></div></div></div>



<p class="has-text-align-center"><strong>Real-Time HAT components</strong><br>(click image to enlarge)</p><div id="eaa_post_between_content" class="eaa-wrapper eaa_post_between_content eaa_desktop"><div class="eaa-ad  " style=""><p style="font-size:6px; text-align: center;">— ADVERTISEMENT —</p><img src="http://linuxgizmos.com/files/Clear.png"  style="width:70px"><!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=40&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script><br>
<!-- END ADVERTSERVE CODE --></div></div>



<p>The Real-Time HAT links with the Raspberry PI through two interfaces, as shown in diagram below. Packet transfer is done via a short Gbit Ethernet link, while the Raspberry PI’s GPIO header is used for configuration and status signaling. For throughput, the HAT provides line-rate forwarding at the selected speed (10/100/1000 Mbps per port). Forwarding is limited just by the Raspberry PI&#8217;s Ethernet interface. That means 1Gbps for the Raspberry PI 4. For the Raspberry PI 3B+ and below, throughput is limited by the USB network interface of the Raspberry PI mainboard, but the HAT supports Gbit line-speed, which is important for time-triggered transmission, for instance, says InnoRoute.</p>



<div class="wp-block-kadence-advancedgallery kb-gallery-wrap-id-_26a832-f7"><div class="kb-gallery-ul kb-gallery-type-slider kb-gallery-id-_26a832-f7 kb-gallery-caption-style-bottom-hover kb-gallery-filter-none" data-image-filter="none" data-lightbox-caption="true"><div class="kt-blocks-carousel kt-carousel-container-dotstyle-dark"><div class="kt-blocks-carousel-init kb-blocks-slider kt-carousel-arrowstyle-whiteondark kt-carousel-dotstyle-dark" data-slider-anim-speed="400" data-slider-type="slider" data-slider-scroll="1" data-slider-arrows="true" data-slider-dots="true" data-slider-hover-pause="false" data-slider-auto="false" data-slider-speed="7000"><div class="kb-slide-item kb-gallery-slide-item"><div class="kadence-blocks-gallery-item"><div class="kadence-blocks-gallery-item-inner"><figure class="kb-gallery-figure kb-gallery-item-has-link kadence-blocks-gallery-item-hide-caption kb-has-image-ratio-land32"><a href="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-conncetions-1.png" class="kb-gallery-item-link"><div class="kb-gal-image-radius"><div class="kb-gallery-image-contain kadence-blocks-gallery-intrinsic kb-gallery-image-ratio-land32"><img loading="lazy" src="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-conncetions-1-1024x659.png" width="1024" height="659" alt="" data-full-image="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-conncetions-1.png" data-light-image="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-conncetions-1.png" data-id="77556" data-link="http://linuxgizmos.com/?attachment_id=77556" class="wp-image-77556 skip-lazy" srcset="http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-conncetions-1-1024x659.png 1024w, http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-conncetions-1-450x290.png 450w, http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-conncetions-1-125x80.png 125w, http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-conncetions-1-1536x989.png 1536w, http://linuxgizmos.com/files/InnoRoute-Realtime-HAT-conncetions-1.png 1538w" sizes="(max-width: 1024px) 100vw, 1024px" /></div></div></a></figure></div></div></div></div></div></div></div>



<p class="has-text-align-center"><strong>Interconnect between Raspberry PI and Real-Time HAT in the TSN bridge to standard Ethernet</strong><br>(click image to enlarge)</p>



<p>TSN technology is used in industrial control applications, automotive control, professional audio/video processing, aerospace/defense on-board networks, and telecommunication/5G networks. These networks consist of TSN switches and TSN endpoints. InnoRoute says a Raspberry PI with a Real-Time HAT can be used as a TSN endpoint, even a switched TSN endpoint (line topology). The Real-Time HAT is based on InnoRoute’s TrustNode system, a software-defined networking (SDN)/TSN switch. The Real-Time HAT can be used the TrustNode.</p>



<p>The company describes several use cases for the HAT: (1) As a Linux-TSN Raspberry PI endpoint with high precision to inject precisely scheduled Ethernet traffic in a TSN Network; (2) To connect non-deterministic Ethernet services to real-time networks; (3) For time-accurate network device testing; and (4) As an FPGA-based network TAP (test access point). As is pointed out in the <a href="https://hackaday.com/2021/08/16/new-part-day-raspberry-pi-hat-for-ieee1588-precision-time-protocol/" target="_blank" rel="noreferrer noopener">Hackaday story</a> that brought this news to our attention, the nuclear research center CERN makes very heavy use of precision time protocols like IEEE1588 for its huge arrays of sensors and control equipment that enable all its LHC experiments.</p>



<p>For the TSN features, InnoRoute provides patches to the network driver of the Raspberry PI 4. However, for the Raspberry PI 3 the same changes need to be applied. As a result, InnoRoute started with the Raspberry PI 4 and plans to support the Raspberry PI 3 at a later time. Meanwhile, users can use the code from its <a href="https://github.com/InnoRoute/linux" target="_blank" rel="noreferrer noopener">github repository</a> and adapt it to other platforms.</p>



<p><strong>Further Information</strong></p>



<p>Although no pricing is available, InnoRoute is taking pre-orders now for the Real-time HAT, as well as a variant called the Real-Time HAT Automotive. Those pre-orders can be made from the Real-Time HAT’s <a href="https://innoroute.com/realtimehat/" target="_blank" rel="noreferrer noopener">product</a> page.</p>
<div class="crp_related  "><h4>LinuxGizmos related posts:</h4><ul><li><a href="http://linuxgizmos.com/automotive-hat-offers-canbus-and-12v-5v-converter/"     class="crp_link post-71209"><span class="crp_title">Automotive HAT offers CANBus and 12V-5V converter</span></a></li><li><a href="http://linuxgizmos.com/open-source-version-of-upc-ua-spec-for-m2m-launches/"     class="crp_link post-65412"><span class="crp_title">Open source version of OPC UA spec for M2M launches</span></a></li><li><a href="http://linuxgizmos.com/raspberry-pi-hat-offer-nmea-2000-link-for-marine-applications/"     class="crp_link post-74005"><span class="crp_title">Raspberry Pi HAT offers NMEA 2000 link for marine&hellip;</span></a></li><li><a href="http://linuxgizmos.com/20-add-on-provides-real-time-clock-for-the-raspberry-pi/"     class="crp_link post-75794"><span class="crp_title">$20 add-on provides Real-Time Clock for the Raspberry Pi</span></a></li><li><a href="http://linuxgizmos.com/raspberry-pi-poe-hat-features-25-5w-poe/"     class="crp_link post-76171"><span class="crp_title">Raspberry Pi PoE+ HAT features 25.5W PoE+</span></a></li><li><a href="http://linuxgizmos.com/can-bus-hat-for-raspberry-pi-4-offers-rtc-and-wide-range-power/"     class="crp_link post-65356"><span class="crp_title">CAN-Bus HAT for Raspberry Pi 4 offers RTC and&hellip;</span></a></li><li><a href="http://linuxgizmos.com/4-channel-temp-measurement-hat-can-be-stacked-eight-high-per-pi/"     class="crp_link post-64640"><span class="crp_title">4-channel temp measurement HAT can be stacked eight&hellip;</span></a></li><li><a href="http://linuxgizmos.com/hat-offers-hardware-watchdog-for-raspberry-pi/"     class="crp_link post-65379"><span class="crp_title">HAT offers hardware watchdog for Raspberry Pi</span></a></li><li><a href="http://linuxgizmos.com/indoor-air-quality-hat-for-raspberry-pi-boasts-high-res-tvoc-sensor/"     class="crp_link post-70551"><span class="crp_title">Indoor air quality HAT for Raspberry Pi boasts&hellip;</span></a></li><li><a href="http://linuxgizmos.com/raspberry-pi-hat-offers-up-to-40w-class-d-amp/"     class="crp_link post-69026"><span class="crp_title">Raspberry Pi HAT offers up to 40W class D amp</span></a></li></ul><div class="crp_clear"></div></div></p>							</div>
		</div>

<table align=center border=0 bordercolor="#ebebeb" cellpadding=0 cellspacing=0>
<tr><td bgcolor="#f4f4f4" align=center valign=middle>
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=22&pid=0&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
<br><br> 
<!-- tag for printer friendly display or pdf printout -->
<div class="printfriendly pf-button  pf-alignleft"><a href="#" rel="nofollow" onclick="window.print();if(typeof(_gaq) != 'undefined') { _gaq.push(['_trackEvent','PRINTFRIENDLY', 'print', 'NULL']);
          }else if(typeof(ga) != 'undefined') {  ga('send', 'event','PRINTFRIENDLY', 'print', 'NULL'); } return false;" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; -moz-box-shadow: none; box-shadow:none; padding:0; margin:0" src="https://cdn.printfriendly.com/buttons/printfriendly-button-nobg.png" alt="Print Friendly, PDF & Email" /></a></div><!-- end of tag -->
<table width="100%" bordercolor="#ebebeb" border=1 cellpadding=10 cellspacing="0" align=center>
<tr><td align=center><b><font color="#4a8ca7" size=3>PLEASE COMMENT BELOW</font></b></td></tr></table>

	
<!-- You can start editing here. -->


			<!-- If comments are open, but there are no comments. -->

	

		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Please comment here...					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&#038;postid=77530&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=blank&#038;greeting=Please+comment+here...&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.9.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=b2159e35f67848bf2382a320277c890e2eed34f3#parent=http%3A%2F%2Flinuxgizmos.com%2Fpi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
		
	</div>

<div id="footer">
<table width="100%" border=0 bgcolor="#ebebeb" cellpadding=10 cellspacing=0><tr><td></td></tr></table>
<table align="center" width=100% height=90 border=0 bgcolor="#ebebeb" cellpadding=0 cellspacing=0><tr><td align="center" valign="middle">
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=23&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<center><a href="/contact"><font size="1.2em" color="#4a8ca7">(advertise here)</font></a></center>
<table width="100%" align=center border=0 bgcolor="#ebebeb" cellpadding=10 cellspacing=0><tr><td>	
<font size="1.2em"><i>The content on this site is copyright &copy; 2007-2021 LinuxGizmos.com unless otherwise noted.  Comments are the property of their submitters. LinuxGizmos is part of the <a href="http://circuitcellar.com/about-us/" target="new"><font color="#4a8ca7">KCK Media Corp. network</font></a>. Linux is a registered trademark of Linus Torvalds.</i></font></td></tr></table>
<!-- <br /><a href="feed:http://linuxgizmos.com/feed/">Entries (RSS)</a> --> <!-- and <a href="feed:http://linuxgizmos.com/comments/feed/">Comments (RSS)</a>. --> 	<!-- 57 queries. 0.224 seconds. -->
<!-- optional advertserve page peel tag can go below here -->
	<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/pagepeel/javascript/media?mid=974&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
<!-- optional advertserve page peel tag can go above here -->
</div>
		<script type="text/javascript" id="pf_script">
		  var pfHeaderImgUrl = 'http://linuxgizmos.com/files/linuxgizmos-logo.jpg';
		  var pfHeaderTagline = '';
		  var pfdisableClickToDel = '1';
		  var pfImagesSize = 'medium';
		  var pfImageDisplayStyle = 'block';
		  var pfEncodeImages = '0';
		  var pfDisableEmail = '1';
		  var pfDisablePDF = '0';
		  var pfDisablePrint = '0';
		  var pfCustomCSS = '';
		  var pfPlatform = 'WordPress';
		</script>
		<script async src='https://cdn.printfriendly.com/printfriendly.js'></script>
			<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=5.8' id='simple-share-buttons-adder-ssba-js'></script>
<script type='text/javascript' id='simple-share-buttons-adder-ssba-js-after'>
Main.boot( [] );
</script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/kadence-blocks/dist/vendor/slick.min.js?ver=2.1.1' id='kadence-slick-js'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/kadence-blocks/dist/kt-slick-init.js?ver=2.1.1' id='kadence-blocks-slick-init-js'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/wp-embed.min.js?ver=5.8' id='wp-embed-js'></script>
<script defer type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.10' id='akismet-form-js'></script>
<script type="text/javascript">
		document.addEventListener("DOMContentLoaded", function() {
			var if_ssb_exist = document.getElementsByClassName( "simplesocialbuttons" ).length > 0;
			if (if_ssb_exist) {
				var ssb_admin_ajax = 'http://linuxgizmos.com/wp-admin/admin-ajax.php';
				var ssb_post_id = 77530 ;
				var ssb_post_url = 'http://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/';
				var ssb_alternate_post_url = 'https://linuxgizmos.com/pi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4/';
				jQuery( document ).ready(function(){
				var is_ssb_used = jQuery('.simplesocialbuttons');
				if( is_ssb_used ) {

					var data = {
					'action': 'ssb_fetch_data',
					'postID': ssb_post_id
				};
					jQuery.post(ssb_admin_ajax, data, function(data, textStatus, xhr) {
						var array = JSON.parse(data);
						jQuery.each( array, function( index, value ){

							if( index == 'total' ){
								jQuery('.ssb_'+ index +'_counter').html(value + '<span>Shares</span>');
							}else{
								jQuery('.ssb_'+ index +'_counter').html(value);
							}
						});

					});
				}
				})

			//ssbPlugin.fetchFacebookShares();
			}
		});

		</script><script type='text/javascript'>function initTwitCount(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://static1.twitcount.com/js/twitcount.js';fjs.parentNode.insertBefore(js,fjs)}}
        var ssb_twit_count_init=!1;addEventListener('mouseover',function(event){if(!ssb_twit_count_init){initTwitCount(document,'script','twitcount_plugins')
        ssb_twit_count_init=!0}})</script>
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=77530&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=b2159e35f67848bf2382a320277c890e2eed34f3#parent=http%3A%2F%2Flinuxgizmos.com%2Fpi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=77530&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=b2159e35f67848bf2382a320277c890e2eed34f3#parent=http%3A%2F%2Flinuxgizmos.com%2Fpi-hat-brings-time-sensitive-networking-tsn-to-raspberry-pi-4%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202133.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.9.1',blog:'47422091',post:'77530',tz:'-7',srv:'linuxgizmos.com'} ]);
	_stq.push([ 'clickTrackerInit', '47422091', '77530' ]);
</script>
 
</body>
</html>
<!-- Dynamic page generated in 0.226 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2021-08-18 17:13:11 -->

<!-- super cache -->