<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<!-- <title>MXM3-enabled RK3399 board blurs lines between SBC and COM</title> -->

<title>MXM3-enabled RK3399 board blurs lines between SBC and COM</title> 

<meta name="generator" content="WordPress 4.9.7" /> <!-- leave this for stats -->

<link rel="stylesheet" href="http://linuxgizmos.com/wp-content/themes/BlackTower-lgw/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com RSS Feed" href="http://linuxgizmos.com/feed/" />

<link rel="pingback" href="http://linuxgizmos.com/xmlrpc.php" />

<!-- G+ author attribution -->
<link rel="author" href="https://plus.google.com/104414840801731506333" />

<style type="text/css" media="screen">
	#headerimg { margin: 0; margin-top: 0px; height: 80px; width: 1022px; }
	#headerimg { background: url('http://linuxgizmos.com/wp-content/themes/BlackTower-lgw/images/header.jpg') no-repeat top;}
</style>

<script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script>
<!-- This site is optimized with the Yoast SEO plugin v7.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="The “Khadas Edge” SBC runs Linux or Android on a Rockchip RK3399 and offers WiFi/BT, HDMI 2.0, USB 3.0 and 2.0, and dual USB Type-C ports, as well as an MXM3 connector to plug into an upcoming “Khadas Captain” carrier."/>
<link rel="canonical" href="http://linuxgizmos.com/mxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com/" />
<link rel="publisher" href="https://plus.google.com/b/104414840801731506333/+LinuxGizmos"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="MXM3-enabled RK3399 board blurs lines between SBC and COM" />
<meta property="og:description" content="The “Khadas Edge” SBC runs Linux or Android on a Rockchip RK3399 and offers WiFi/BT, HDMI 2.0, USB 3.0 and 2.0, and dual USB Type-C ports, as well as an MXM3 connector to plug into an upcoming “Khadas Captain” carrier." />
<meta property="og:url" content="http://linuxgizmos.com/mxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com/" />
<meta property="og:site_name" content="LinuxGizmos.com" />
<meta property="article:publisher" content="http://facebook.com/LinuxGizmos" />
<meta property="article:section" content="SBCs &amp; COMs" />
<meta property="article:published_time" content="2018-07-24T09:12:21-07:00" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="The “Khadas Edge” SBC runs Linux or Android on a Rockchip RK3399 and offers WiFi/BT, HDMI 2.0, USB 3.0 and 2.0, and dual USB Type-C ports, as well as an MXM3 connector to plug into an upcoming “Khadas Captain” carrier." />
<meta name="twitter:title" content="MXM3-enabled RK3399 board blurs lines between SBC and COM" />
<meta name="twitter:site" content="@LinuxGizmos" />
<meta name="twitter:image" content="http://linuxgizmos.com/files/khadas_edge-thm.jpg" />
<meta name="twitter:creator" content="@LinuxGizmos" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"http:\/\/linuxgizmos.com\/","sameAs":["http:\/\/facebook.com\/LinuxGizmos","https:\/\/plus.google.com\/b\/104414840801731506333\/+LinuxGizmos","https:\/\/twitter.com\/LinuxGizmos"],"@id":"http:\/\/linuxgizmos.com\/#organization","name":"KCK Media Network","logo":""}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com &raquo; MXM3-enabled RK3399 board blurs lines between SBC and COM Comments Feed" href="http://linuxgizmos.com/mxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/linuxgizmos.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.7"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://linuxgizmos.com/wp-includes/css/dashicons.min.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='http://linuxgizmos.com/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css?ver=20170506' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://linuxgizmos.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.3.2' type='text/css' media='all' />
<script id='st_insights_js' type='text/javascript' src='http://w.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://linuxgizmos.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://linuxgizmos.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://linuxgizmos.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.7" />
<link rel='shortlink' href='https://wp.me/p3cYEr-ghy' />
<link rel="alternate" type="application/json+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Fmxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Fmxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com%2F&#038;format=xml" />
    <style type="text/css" media="screen">
      div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited {
        text-decoration: none;
        border: none;
      }
    </style>
           <style type="text/css" media="screen">
          div.printfriendly {
            margin: 12px 12px 12px 30px;
            position: relative;
            z-index: 1000;
          }
          div.printfriendly a, div.printfriendly a:link, div.printfriendly a:visited {
            font-size: 14px;
            color: #6D9F00;
            vertical-align: bottom;
          }
          .printfriendly a {
            box-shadow:none;
          }
          .printfriendly a:hover {
            cursor: pointer;
          }
          .printfriendly a img  {
            border: none;
            padding:0;
            margin-right: 6px;
            box-shadow: none;
            -webkit-box-shadow: none;
            -moz-box-shadow: none;
          }
          .printfriendly a span{
            vertical-align: bottom;
          }
          .pf-alignleft {
            float: left;
          }
          .pf-alignright {
            float: right;
          }
          div.pf-aligncenter {
            display: block;
            margin-left: auto;
            margin-right: auto;
            text-align: center;
          }
        </style>
        <style type="text/css" media="print">
          .printfriendly {
            display: none;
          }
        </style>

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
			<style type="text/css" id="wp-custom-css">
				/*
Welcome to Custom CSS!

To learn how this works, see http://wp.me/PEmnE-Bt
*/
.commentlist li {
	font-size: 1em;
}			</style>
		
<!-- google adsense verification tag -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4310582701436176",
    enable_page_level_ads: true
  });
</script>
<!-- end google adsense verification tag -->
	
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5377446-2', 'linuxgizmos.com');
  ga('send', 'pageview');
</script>
	
<!-- clone of ssba css as of v7.4.10 -->
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=4.9.4' type='text/css' media='all' />

<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css'  href='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.9.4' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: 0px solid #59625c;
									
									
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								#ssba-classic-2 .ssbp-text {
									display: none!important;
								}
								
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px; }
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}
								
@font-face {
				font-family: 'ssbp';
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<!-- end clone of ssba css -->	
	
</head>
<body>
<div id="page">

<div id="header">

<!-- optional Advertserve page peel ad Display Code goes below here -->
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
_avp.push({ alias: '/', type: 'pagepeel', mid: 380, pid: 0 });
</script>
<!-- END ADVERTSERVE CODE -->

<a href="http://linuxgizmos.com/">
    <div id="headerimg">

     <!--
     <h1> <a href="http://linuxgizmos.com/">LinuxGizmos.com</a></h1> 
     <div class="description"><i>Embedded Linux news &amp; devices</i></div> 
     -->
    </div>

</a>

</div>

<hr />
<!-- section links start -->
<table align=center width="1022" height=25 border=0 cellpadding=0 cellspacing=0 bgcolor="#3b3b3b"><tr>
<td width="" align=center><a href="/"><font size="2em" color="white">All News</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/boards"><font size="2em" color="white">Boards</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/chips"><font size="2em" color="white">Chips</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/devices"><font size="2em" color="white">Devices</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/software"><font size="2em" color="white">Software</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="http://linuxdevices.io"><font size="2em" color="white"><font color="white">LinuxDevices.com Archive</b></font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/about"><font size="2em" color="white">About</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/contact"><font size="2em" color="white">Contact</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="#subscribe"><font size="2em" color="white">Subscribe</font></a></td>
</tr></table>
<!-- section links end -->

<table align=center width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

<!-- header banner wrapper starts -- NOTE: total width = 1022 px -->
<center><table width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white"><tr>

<td width=14></td>

<td align=left>
<!-- 728x90 ad goes below here -->
<table align=left width=728 height=90 border=1 bordercolor="#ebebeb" cellpadding=0 cellspacing=0 bgcolor="white"><tr><td>
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=20&pid=1&resolution='+screen.width+'x'+screen.height+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<!-- 728x90 ad goes above here -->
</td>

<td width=10></td>

<td width=250 border=0 align=center>
<!-- sharing and subscription block goes below here -->
<table align=left cellpadding=5 cellspacing=0 border=0>
<tr><td align=center valign=middle><font size=2em color="#4a8ca7"><b>Follow LinuxGizmos:</b></font></td></tr>
<tr><td align=center valign=middle>
<a href="http://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter-square-25px.png" alt="Twitter"></a> 
<a href="https://plus.google.com/+LinuxGizmos/posts" rel="publisher" style="text-decoration:none;" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/googleplus-square-25px.png" alt="Google+"></a> 
<a href="https://www.facebook.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="http://linuxgizmos.com/files/facebook-square-25px.png" alt="Facebook"></a>  
<a href="/feed/" target="new"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss-square-25px.png" target="new"></a>
</td></tr>
<tr><td align=center valign=middle><a href="/#subscribe"><font size=2em color="#4a8ca7"><b>*</b> &nbsp; get email updates &nbsp; <b>*</b></font></a></td></tr>
</table>
<!-- sharing and subscription block goes above here -->
</td>
</tr></table></center>
<!-- header banner wrapper ends -->

<table align=center width="100%" height=3 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

	<div id="sidebar">
	<div class="sidebar-right">
		<ul>
			<li id="search-3" class="widget widget_search"><h2 class="widgettitle">Search LinuxGizmos:</h2>
<form method="get" id="searchform" action="http://linuxgizmos.com/">
<div><input type="text" value="" name="s" id="s" />
<input type="submit" id="searchsubmit" value="Search" />
</div>
</form></li>
<li id="text-33" class="widget widget_text"><h2 class="widgettitle">Search LinuxGizmos.com + LinuxDevices Archive:</h2>
			<div class="textwidget"><form action="http://linuxgizmos.com/search" id="cse-search-box">
  <div>
    <input type="hidden" name="cx" value="partner-pub-3975801459690075:2161158331" />
    <input type="hidden" name="cof" value="FORID:10" />
    <input type="hidden" name="ie" value="UTF-8" />
    <input type="text" name="q" size="23" />
    <input type="submit" name="sa" value="Search" />
  </div>
</form>
<script type="text/javascript" src="http://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script></div>
		</li>
<li id="text-35" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
			<div class="textwidget"><br><!-- BEGIN ZONE 2 ADVERTSERVE CODE --> <!-- set total to zone 2 (non-dg) campaigns minus 1 -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/unique/javascript/strip?zid=18&pid=0&total=13&layout=vertical&margin=0&padding=15&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent(document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
		</li>
<li id="top-posts-3" class="widget widget_top-posts"><h2 class="widgettitle">Top 10 trending posts&#8230; </h2>
<ul>				<li>
										<a href="http://linuxgizmos.com/industrial-apollo-lake-based-enuc-sbc-offers-dual-m-2-slots/" class="bump-view" data-bump-view="tp">
						Industrial Apollo Lake based eNUC SBC offers dual M.2 slots					</a>
									</li>
							<li>
										<a href="http://linuxgizmos.com/mxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com/" class="bump-view" data-bump-view="tp">
						MXM3-enabled RK3399 board blurs lines between SBC and COM					</a>
									</li>
							<li>
										<a href="http://linuxgizmos.com/skylake-in-vehicle-pc-features-4x-gbe-ports-with-poe/" class="bump-view" data-bump-view="tp">
						Skylake in-vehicle PC features 4x GbE ports with PoE					</a>
									</li>
							<li>
										<a href="http://linuxgizmos.com/rugged-new-jetson-tx2i-module-gains-carrier-support/" class="bump-view" data-bump-view="tp">
						Rugged new Jetson TX2i module gains carrier support					</a>
									</li>
							<li>
										<a href="http://linuxgizmos.com/pico-itx-and-3-5-inch-sbcs-run-linux-or-android-on-i-mx6/" class="bump-view" data-bump-view="tp">
						Pico-ITX and 3.5-inch SBCs run Linux or Android on i.MX6					</a>
									</li>
							<li>
										<a href="http://linuxgizmos.com/open-spec-nas-sbc-with-4x-sata-3-0-ports-relaunches/" class="bump-view" data-bump-view="tp">
						Open-spec NAS SBC with 4x SATA 3.0 ports relaunches					</a>
									</li>
							<li>
										<a href="http://linuxgizmos.com/rk3399-based-odroid-n1-sbc-doubles-up-on-sata-iii/" class="bump-view" data-bump-view="tp">
						RK3399 based Odroid-N1 SBC doubles up on SATA III					</a>
									</li>
							<li>
										<a href="http://linuxgizmos.com/streamlining-build-environment-management-with-linux-containers/" class="bump-view" data-bump-view="tp">
						Streamlining build environment management with Linux containers					</a>
									</li>
							<li>
										<a href="http://linuxgizmos.com/open-source-125-nas-sbc-has-four-sata-3-0-ports/" class="bump-view" data-bump-view="tp">
						Open source, $125 NAS SBC has four SATA 3.0 ports					</a>
									</li>
							<li>
										<a href="http://linuxgizmos.com/tiny-hacker-board-features-dual-ethernet-and-a-13-90-price/" class="bump-view" data-bump-view="tp">
						Tiny Linux hacker board features dual Ethernet and a $14 price					</a>
									</li>
			</ul></li>
<li id="text-36" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
			<div class="textwidget"><br><!-- BEGIN ZONE 3 ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=21&pid=1&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
		</li>
<li id="text-18" class="widget widget_text">			<div class="textwidget"><a name="subscribe"></a></div>
		</li>
<li id="text-3" class="widget widget_text"><h2 class="widgettitle">Follow LinuxGizmos or subscribe to our posts:</h2>
			<div class="textwidget"></div>
		</li>
<li id="text-37" class="widget widget_text">			<div class="textwidget"><table align=center><tr><td align=center valign=middle><h2>Follow:</h2></td><td align=center valign=middle><a href="http://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/twitter.png" alt="Twitter" target="new"></a> <a href="https://plus.google.com/+LinuxGizmos/posts" rel="publisher" style="text-decoration:none;" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/gplus.png" alt="Google+"></a> <a href="https://www.facebook.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/facebook.png" alt="Facebook"></a>  <a href="/feed/"><img height=25 width=25 vspace=5 hspace=5 alt="RSS feed" src="http://linuxgizmos.com/files/rss.png" target="new"></a></td></tr></table></div>
		</li>
<li id="blog_subscription-2" class="widget jetpack_subscription_widget"><h2 class="widgettitle">Subscribe:</h2>

			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
				<div id="subscribe-text"><p>Enter your email address to receive notifications of new posts:</p>
</div>					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-2">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-2" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="http://linuxgizmos.com/mxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com/" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-2" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-2]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-2'),
					input = d.getElementById('subscribe-field-blog_subscription-2'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</li>

		</ul>
	</div>	<!--sidebar-left-->


	</div>


	<div id="content" class="narrowcolumn">
				
  		
		<div class="post" id="post-62592">
			<h2><a href="http://linuxgizmos.com/mxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com/" rel="bookmark" title="Permanent Link: MXM3-enabled RK3399 board blurs lines between SBC and COM">MXM3-enabled RK3399 board blurs lines between SBC and COM</a></h2>

		<small>Jul 24, 2018 &mdash; by Eric Brown </small>

	<!-- tag for gapp post pageviews plugin -->
    <small>  </small> 

	<!-- tag for WP Stats View Counter -->
 <small> &mdash; 311 views</small>
			
			<div class="entrytext">
				<!-- Simple Share Buttons Adder (7.4.18) simplesharebuttons.com --><div id="ssba-classic-2" class="ssba ssbp-wrap left ssbp--theme-1"><div style="text-align:center"><span class="ssba-share-text">Please share:     </span><a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=http://linuxgizmos.com/mxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com/&amp;text=MXM3-enabled%20RK3399%20board%20blurs%20lines%20between%20SBC%20and%20COM%20"  target=&quot;_blank&quot; ><img src="http://linuxgizmos.com/files/twitter-square-25px.png" style="width: 25px;" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /><div title="Twitter" class="ssbp-text">Twitter</div></a><a data-site="" class="ssba_google_share" href="https://plus.google.com/share?url=http://linuxgizmos.com/mxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com/"  target=&quot;_blank&quot; ><img src="http://linuxgizmos.com/files/googleplus-square-25px.png" style="width: 25px;" title="Share on Google+" class="ssba ssba-img" alt="Google+" /><div title="Google+" class="ssbp-text">Google+</div></a><a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=http://linuxgizmos.com/mxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com/"  target="_blank" ><img src="http://linuxgizmos.com/files/facebook-square-25px.png" title="Facebook" style="width: 25px;" class="ssba ssba-img" alt="Share on Facebook" /><div title="Facebook" class="ssbp-text">Facebook</div></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http://linuxgizmos.com/mxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com/"  target=&quot;_blank&quot; ><img src="http://linuxgizmos.com/files/linkedin-square-25px.png" alt="Share on LinkedIn" style="width: 25px;" title="LinkedIn" class="ssba ssba-img" /><div title="Linkedin" class="ssbp-text">Linkedin</div></a><a data-site="reddit" class="ssba_reddit_share" href="http://reddit.com/submit?url=http://linuxgizmos.com/mxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com/&amp;title=MXM3-enabled RK3399 board blurs lines between SBC and COM"  target=&quot;_blank&quot; ><img src="http://linuxgizmos.com/files/reddit-square-25px.png" style="width: 25px;" title="Reddit" class="ssba ssba-img" alt="Share on Reddit" /><div title="Reddit" class="ssbp-text">Reddit</div></a><a data-site='pinterest' class='ssba_pinterest_share' href='javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;//assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());'><img style="width: 25px;" title="Pinterest" class="ssba ssba-img" src="http://linuxgizmos.com/files/pinterest-square-25px.png" alt="Pin on Pinterest" /><div title="Pinterest" class="ssbp-text">Pinterest</div></a><a data-site="email" class="ssba_email_share" href="/cdn-cgi/l/email-protection#221d515740484741561f6f7a6f110f474c43404e4746071012706911111b1b071012404d435046071012404e5750510710124e4b4c47510710124047565547474c071012716061071012434c46071012616d6f040112111a19404d465b1f0710124a565652180d0d4e4b4c575a454b584f4d510c414d4f0d4f5a4f110f474c43404e47460f504911111b1b0f404d4350460f404e5750510f4e4b4c47510f4047565547474c0f5140410f434c460f414d4f0d"><img src="http://linuxgizmos.com/files/email-square-25px.png" style="width: 25px;" title="Email" class="ssba ssba-img" alt="Email to someone" /><div title="email" class="ssbp-text">email</div></a></div></div><div class="pf-content"><p><img align=left vspace=5 hspace=10 src="/files/khadas_edge-thm.jpg">The “Khadas Edge” SBC runs Linux or Android on a Rockchip RK3399 and offers WiFi/BT, HDMI 2.0, USB 3.0 and 2.0, and dual USB Type-C ports, as well as an MXM3 connector to plug into an upcoming “Khadas Captain” carrier.<br />
<span id="more-62592"></span><br />
Shenzhen Wesion’s Khadas project has posted specs for a “Khadas Edge” board that combines attributes of both a single board computer and a computer-on-module. Unlike the Amlogic based Khadas Vim and <a href="http://linuxgizmos.com/open-spec-sbc-features-octa-core-a53-soc/" target="new">Khadas Vim2</a> SBCs, the Khadas Edge features the hexa-core Rockchip RK3399. Presumably, the Khadas Edge will be an open-spec board like the similarly dimensioned, 82 x 57.5mm Vim models. OS support includes Android Oreo, Ubuntu 18.04, and Debian 9.0 with mainline Linux.<br />
<center><br />
<a href="/files/khadas_edge_front.jpg" target="new"><img src="/files/khadas_edge_front-sm.jpg" vspace=10 hspace=5 border=0></a> <a href="/files/khadas_edge_back.jpg" target="new"><img src="/files/khadas_edge_back-sm.jpg" vspace=10 hspace=5 border=0></a><br />
<b>Khadas Edge front and back</b><br />
(click images to enlarge)<br />
</center><br />
We have previously referred to minimalist SBCs such as the Raspberry Pi Zero as being COM-like because they offer only limited coastline ports. In the case of the Khadas Edge, however, the board has plenty of real-world ports, but also integrates a 314-pin MXM3 edge connector, which is protected by a removable cover. MXM3 connectors are found on SMARC modules, such as iWave’s i.MX8 QuadMax based <a href="http://linuxgizmos.com/smarc-module-features-hexa-core-i-mx8-quadmax/" target="new">iW-RainboW-G27M</a>. </p>
<p>The Khadas Edge will plug into a Khadas Captain baseboard but can also be used as a standalone SBC. The Khadas Edge and Khadas Captain will launch in a crowdfunding campaign in August, according to the <a href="https://www.cnx-software.com/2018/07/24/khadas-edge-rk3399-single-board-computer-system-on-module/" target="new">CNXSoft</a> story that alerted us to the product.<br />
<center><br />
<a href="/files/khadas_edge.jpg" target="new"><img src="/files/khadas_edge-sm.jpg" vspace=10 hspace=5 border=0></a><br />
<b>Khadas Edge</b><br />
(click image to enlarge)<br />
</center><br />
The closest competitor for the combined Edge/Captain product would be Vamrs’ <a href="http://linuxgizmos.com/linuxandroid-hacker-sbc-with-hexa-core-rockchip-soc-debuts-at-75/" target="new">Rockchip RK3399 Sapphire</a> SBC when deployed sandwich style on the optional Excavator EVB Kit. The other <a href="http://linuxgizmos.com/2018-reader-survey-of-116-open-spec-linux-android-sbcs/" target="new">RK3399 boards</a> we’ve seen, such as the <a href="http://linuxgizmos.com/first-rockchip-based-orange-pi-sbc-taps-rk3399/" target="new">Orange Pi RK3999</a> are monolithic SBCs, although there has also been at least one COM: Theobroma’s <a href="http://linuxgizmos.com/qseven-modules-adopt-hexa-and-octa-core-rockchip-socs/" target="new">RK3399-Q7</a>.<br />
<center><br />
<img src="/files/geekbuying_geekbox_detach.jpg" vspace=10 hspace=5 border=0><br />
<b>GeekBox board plugging into GeekBox Landingship carrier board</b><br />
</center><br />
As noted by CNXSoft, Shenzhen Wesion is also the company behind the open-spec <a href="" target="new">GeekBox</a> SBC and mini-PC, which similarly adds an MXM3 golden finger to a Rockchip-based SBC. The MXM3 connector on the RK3368 based GeekBox plugs into an optional Landingship carrier board.</p>
<p>The Khadas Edge will be available in Basic, Pro, and Max models, each with different combinations of RAM and eMMC ranging up to 4GB/64GB. The Pro and Max models also boost the wireless to a new Broadcom AP6938S module that boosts the Bluetooth to 5.0 and enhances the dual-band WiFi-ac with <a href="https://www.broadcom.com/blog/rsdb-gets-a-boost-from-broadcom-at-mwc" target="new">RSDB</a> (real simultaneous dual band) technology. RSDB permits simultaneous independent operation of the 2.4GHz and 5GHz bands, thereby enabling streaming of a game to a smartphone while streaminging video from the smartphone to a smart TV. In automotive applications, it would dedicate the 5GHz band for infotainment and in-vehicle use while using the 2.4GHz band for a WiFi hotspot. </p>
<p>All three models of the Khadas Edge provide a 4K-ready HDMI 2.0a port, as well as dual USB Type-C ports, one of which supports DisplayPort 1.2. The other Type-C port is dedicated to power, although you can also draw the wide-range power from onboard Pogo Pads or the MXM3 gold finger.</p>
<p>The Khadas Edge is further equipped with USB 3.0 and 2.0 host ports and dual 10-pin FPC expansion connectors. The FPC B connector supports the Edge’s onboard 8-bit STM8S003 MCU with programmable EEPROM. It appears that the FPC A connector will support a new <a href="https://docs.khadas.com/edge/SetupSerialTool.html" target="new">Edge IO</a> daughter board, which will enable serial debug, as well as easier GPIO expansion.<br />
<center><br />
<a href="/files/khadas_edgeio.jpg" target="new"><img src="/files/khadas_edgeio-sm.jpg" vspace=10 hspace=5 border=0></a><br />
<b>Edge IO board</b><br />
(click image to enlarge)<br />
</center><br />
The MXM3 connector, meanwhile, supplies the full panoply of the RK3399’s I/O to the undocumented Khadas Captain board. These include high-speed interfaces like PCIe, eDP, DVP, and MIPI-CSI and -DSI. It also enables the Edge’s GbE controller to express itself via a real-world RJ45 port on the Captain. The lack of an RJ45 on the Edge itself enables a thin, 5.7mm profile.</p>
<p>Preliminary specifications listed for the Khadas Edge include:</p>
<ul>
<li>Processor &#8212; Rockchip RK3399 (2x Cortex-A72 at up to 2.0GHz, 4x Cortex-A53) with Mali-T860 GPU; 8-bit STM8S003 with programmable EEPROM
<li>Memory:
<ul>
<li>Basic &#8212; 2GB LPDDR4 RAM, 16GB eMMC 5.1
<li>Pro &#8212; 4GB/32GB
<li>Max &#8212; 4GB/64GB
<li>All models &#8212; 16MB SPI flash
</ul>
<li>Wireless:
<ul>
<li>Basic &#8212; 802.11b/g/n/ac 2.4GHz/5GHz 2&#215;2 MIMO with Bluetooth 4.1 (Broadcom AP6356S)
<li>Pro and Max &#8212; 802.11b/g/n/ac 2.4GHz/5GHz 2&#215;2 MIMO with RSDB and Bluetooth 5.0 (Broadcom AP6938S)
<li>2x WiFi antennas
</ul>
<li>Networking &#8212; GbE controller with WoL (PHY only, no port)
<li>Display/camera:
<ul>
<li>HDMI 2.0a port with CEC for up to up to <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="5f6b141f696f1725">[email&#160;protected]</a>, HDCP 2.2
<li>DisplayPort 1.2 available via 1x USB Type-C
<li>Simultaneous dual display support
</ul>
<li>Other I/O:
<ul>
<li>2x USB 3.0 Type-C ports (1x power only, 1x with DP and USB support)
<li>USB 3.0 host port
<li>USB 2.0 host port
<li>Fan header
</ul>
<li>Expansion:
<ul>
<li>FPC connector A &#8212; UART, I2C, SPI, SD/MMC, ADC, PWM, IOs
<li>FPC connector B &#8212; USB, I2S (8 ch.), I2C, MCU IOs
<li>314-pin MXM3 board-to-board connector
</ul>
<li>Other features &#8212; 3x buttons; 2x LEDs; heatsink (TBC); optional Edge IO and Khadas Captain boards
<li>Power &#8212; 5-20V DC input via USB Type-C, Pogo Pads, MXM3; 2-cell battery module
<li>Weight &#8212; 25 gm
<li>Dimensions &#8212; 82.0 x 57.5 x 5.7mm
<li>Operating system &#8212; Android Oreo, Ubuntu 18.04, Debian 9.0, etc. with mainline Linux and U-Boot; support for TensorFlow and Android NN (Neural Networks API)</ul>
<p>&nbsp;<br />
<b>Further information</b></p>
<p>The Khadas Edge will launch on a crowdfunding site in August at an undisclosed price. More information may be found on the Khadas project’s preliminary <a href="https://www.khadas.com/edge" target="new">Khadas Edge product page</a>.<br />
&nbsp;</p>
</div><div class="crp_related "><h4>Related posts:</h4><ul><li><a href="http://linuxgizmos.com/qseven-modules-adopt-hexa-and-octa-core-rockchip-socs/"    ><span class="crp_title">Linux-friendly modules adopt hexa- and octa-core&hellip;</span></a></li><li><a href="http://linuxgizmos.com/open-spec-sbc-dual-boots-android-and-ubuntu-on-hexa-core-rk3399/"    ><span class="crp_title">Hacker board boots Android and Ubuntu on hexa-core RK3399</span></a></li><li><a href="http://linuxgizmos.com/linuxandroid-hacker-sbc-with-hexa-core-rockchip-soc-debuts-at-75/"    ><span class="crp_title">Linux/Android hacker SBC with hexa-core Rockchip SoC&hellip;</span></a></li><li><a href="http://linuxgizmos.com/sbc-expands-on-rockchip-rk3399-with-eye-popping-feature-list/"    ><span class="crp_title">SBC expands on 2GHz Rockchip RK3399 with eye-popping&hellip;</span></a></li><li><a href="http://linuxgizmos.com/open-spec-sbc-features-octa-core-a53-soc/"    ><span class="crp_title">Open-spec SBC features octa-core -A53 SoC</span></a></li><li><a href="http://linuxgizmos.com/quad-core-64-bit-arm-hacker-sbc-has-onboard-wireless-and-emmc/"    ><span class="crp_title">Quad-core, 64-bit ARM hacker SBC has onboard&hellip;</span></a></li><li><a href="http://linuxgizmos.com/mini-pc-doubles-as-open-spec-octa-core-hacker-sbc/"    ><span class="crp_title">Mini-PC doubles as open-spec, octa-core hacker SBC</span></a></li><li><a href="http://linuxgizmos.com/sandwich-style-board-set-runs-android-or-linux-on-hexa-core-rockchip/"    ><span class="crp_title">Sandwich-style board-set runs Android or Linux on&hellip;</span></a></li><li><a href="http://linuxgizmos.com/first-rockchip-based-orange-pi-sbc-taps-rk3399/"    ><span class="crp_title">First Rockchip based Orange Pi SBC taps RK3399</span></a></li><li><a href="http://linuxgizmos.com/rk3399-sbc-offers-dual-type-c-with-dp-and-optional-poe/"    ><span class="crp_title">RK3399 SBC offers dual Type-C with DP and optional PoE</span></a></li></ul><div class="crp_clear"></div></div>							</div>
		</div>

<table align=center border=0 bordercolor="#ebebeb" cellpadding=0 cellspacing=0>
<tr><td bgcolor="#f4f4f4" align=center valign=middle>
<!-- BEGIN ADVERTSERVE CODE -->
<script data-cfasync="false" src="/cdn-cgi/scripts/f2bf09f8/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=22&pid=0&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
<br><br> 
<!-- tag for printer friendly display or pdf printout -->
<div class="printfriendly pf-alignleft"><a href="#" rel="nofollow" onclick="window.print();if(typeof(_gaq) != 'undefined') { _gaq.push(['_trackEvent','PRINTFRIENDLY', 'print', 'NULL']);
          }else if(typeof(ga) != 'undefined') {  ga('send', 'event','PRINTFRIENDLY', 'print', 'NULL'); } return false;" class="noslimstat" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="https://cdn.printfriendly.com/buttons/printfriendly-button-nobg.png" alt="Print Friendly, PDF & Email" /></a></div><!-- end of tag -->
<table width="100%" bordercolor="#ebebeb" border=1 cellpadding=10 cellspacing="0" align=center>
<tr><td align=center><b><font color="#4a8ca7" size=3>PLEASE COMMENT BELOW</font></b></td></tr></table>

	
<!-- You can start editing here. -->


			<!-- If comments are open, but there are no comments. -->

	 

		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Please comment here...					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/mxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="http://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&#038;postid=62592&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=blank&#038;greeting=Please+comment+here...&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=6.3.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;sig=719db9880977e0d9143830eac91325355c7d2348#parent=http%3A%2F%2Flinuxgizmos.com%2Fmxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
		
	</div>

<div id="footer">
<table width="100%" border=0 bgcolor="#ebebeb" cellpadding=10 cellspacing=0><tr><td></td></tr></table>
<table align="center" width=100% height=90 border=0 bgcolor="#ebebeb" cellpadding=0 cellspacing=0><tr><td align="center" valign="middle">
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=23&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<center><a href="/contact"><font size="1.2em" color="#4a8ca7">(advertise here)</font></a></center>
<table width="100%" align=center border=0 bgcolor="#ebebeb" cellpadding=10 cellspacing=0><tr><td>	
<font size="1.2em"><i>The content on this site is copyright &copy; 2007-2018 LinuxGizmos.com unless otherwise noted.  Comments are the property of their submitters. LinuxGizmos is part of the <a href="http://circuitcellar.com/about-us/" target="new"><font color="#4a8ca7">KCK Media Corp. network</font></a>. Linux is a registered trademark of Linus Torvalds.</i></font></td></tr></table>
<!-- <br /><a href="feed:http://linuxgizmos.com/feed/">Entries (RSS)</a> --> <!-- and <a href="feed:http://linuxgizmos.com/comments/feed/">Comments (RSS)</a>. --> 	<!-- 42 queries. 0.104 seconds. -->
<!-- optional advertserve page peel tag can go below here -->
<!-- optional advertserve page peel tag can go above here -->
</div>
      <script type="text/javascript">

          var pfHeaderImgUrl = 'http://linuxgizmos.com/files/linuxgizmos-logo.jpg';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '1';
          var pfImagesSize = 'medium';
          var pfImageDisplayStyle = 'block';
          var pfDisableEmail = '1';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
      (function() {
            var e = document.createElement('script'); e.type="text/javascript";
            e.src = 'https://cdn.printfriendly.com/printfriendly.js';
            document.getElementsByTagName('head')[0].appendChild(e);
        })();
      </script>
<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css'  href='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.9.7' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: 0px solid #59625c;
									
									
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								#ssba-classic-2 .ssbp-text {
									display: none!important;
								}
								
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px; }
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}
								
@font-face {
				font-family: 'ssbp';
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201830'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=4.9.7'></script>
<script type='text/javascript'>
Main.boot( [] );
</script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/wp-embed.min.js?ver=4.9.7'></script>
<script async="async" type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.8'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=62592&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=6.3.2&show_cookie_consent=10&has_cookie_consent=0&sig=719db9880977e0d9143830eac91325355c7d2348#parent=http%3A%2F%2Flinuxgizmos.com%2Fmxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=62592&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=6.3.2&show_cookie_consent=10&has_cookie_consent=0&sig=719db9880977e0d9143830eac91325355c7d2348#parent=http%3A%2F%2Flinuxgizmos.com%2Fmxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "http:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-201830.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.3.2',blog:'47422091',post:'62592',tz:'-7',srv:'linuxgizmos.com'} ]);
	_stq.push([ 'clickTrackerInit', '47422091', '62592' ]);
</script>
 
</body>
</html>