<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
 
<title>Mozilla launches Project Things IoT framework on Raspberry Pi</title>
<meta name="generator" content="WordPress 4.8"/>  
<link rel="stylesheet" href="http://linuxgizmos.com/wp-content/themes/BlackTower-lgw/style.css" type="text/css" media="screen"/>
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com RSS Feed" href="http://linuxgizmos.com/feed/"/>
<link rel="pingback" href="http://linuxgizmos.com/xmlrpc.php"/>
 
<link rel="author" href="https://plus.google.com/104414840801731506333"/>
<style type="text/css" media="screen">#headerimg{margin:0;margin-top:0px;height:80px;width:1022px;}#headerimg{background:url('http://linuxgizmos.com/wp-content/themes/BlackTower-lgw/images/header.jpg') no-repeat top;}</style>
 
<meta name="description" content="Mozilla unveiled “Project Things,” which builds upon standard web technologies and the Web of Things project, and released code that runs on a Raspberry Pi."/>
<link rel="canonical" href="http://linuxgizmos.com/mozilla-launches-project-things-iot-framework-on-raspberry-pi/"/>
<link rel="publisher" href="https://plus.google.com/b/104414840801731506333/+LinuxGizmos"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Mozilla launches Project Things IoT framework on Raspberry Pi"/>
<meta property="og:description" content="Mozilla unveiled “Project Things,” which builds upon standard web technologies and the Web of Things project, and released code that runs on a Raspberry Pi."/>
<meta property="og:url" content="http://linuxgizmos.com/mozilla-launches-project-things-iot-framework-on-raspberry-pi/"/>
<meta property="og:site_name" content="LinuxGizmos.com"/>
<meta property="article:publisher" content="http://facebook.com/LinuxGizmos"/>
<meta property="article:section" content="Software"/>
<meta property="article:published_time" content="2017-07-07T12:55:38-07:00"/>
<meta property="og:image" content="http://linuxgizmos.com/files/mozilla_projecthings_rpi-thm.jpg"/>
<meta property="og:image" content="http://linuxgizmos.com/files/mozilla_projecthings_iot_vertical-sm.jpg"/>
<meta property="og:image" content="http://linuxgizmos.com/files/mozilla_projecthings-sm.jpg"/>
<meta property="og:image" content="http://linuxgizmos.com/files/mozilla_projecthings2-sm.jpg"/>
<meta property="og:image" content="http://linuxgizmos.com/files/mozilla_projecthings_thingsgateway-sm.jpg"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:description" content="Mozilla unveiled “Project Things,” which builds upon standard web technologies and the Web of Things project, and released code that runs on a Raspberry Pi."/>
<meta name="twitter:title" content="Mozilla launches Project Things IoT framework on Raspberry Pi"/>
<meta name="twitter:site" content="@LinuxGizmos"/>
<meta name="twitter:image" content="http://linuxgizmos.com/files/mozilla_projecthings_rpi-thm.jpg"/>
<meta name="twitter:creator" content="@LinuxGizmos"/>
 
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//ajax.googleapis.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com &raquo; Mozilla launches Project Things IoT framework on Raspberry Pi Comments Feed" href="http://linuxgizmos.com/mozilla-launches-project-things-iot-framework-on-raspberry-pi/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/linuxgizmos.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='xyz_cfm_short_code_style-css' href='http://linuxgizmos.com/wp-content/plugins/contact-form-manager/css/xyz_cfm_shortcode_style.css?ver=4.8' type='text/css' media='all'/>
<link rel='stylesheet' id='jquery-style-css' href='http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=4.8' type='text/css' media='all'/>
<link rel='stylesheet' id='jetpack_css-css' href='http://linuxgizmos.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.1' type='text/css' media='all'/>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://linuxgizmos.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://linuxgizmos.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://linuxgizmos.com/wp-includes/wlwmanifest.xml"/>
<meta name="generator" content="WordPress 4.8"/>
<link rel='shortlink' href='http://wp.me/p3cYEr-fcj'/>
<link rel="alternate" type="application/json+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Fmozilla-launches-project-things-iot-framework-on-raspberry-pi%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Fmozilla-launches-project-things-iot-framework-on-raspberry-pi%2F&#038;format=xml"/>
<style type="text/css">.ssba{padding:0px;border:0px solid #59625c;}.ssba img{width:25px!important;padding:15px;border:0;box-shadow:none!important;display:inline!important;vertical-align:middle;}.ssba,.ssba a{text-decoration:none;border:0;background:none;font-size:12px;color:#4d4d4d!important;font-weight:normal;}</style>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<style type="text/css" id="wp-custom-css">.commentlist li{font-size:1em;}</style>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5377446-2', 'linuxgizmos.com');
  ga('send', 'pageview');
</script>
</head>
<body>
<div id="page">
<div id="header">
 
 
<script type="text/javascript">
_avp.push({ alias: '/', type: 'pagepeel', mid: 380, pid: 0 });
</script>
 
<a href="http://linuxgizmos.com/">
<div id="headerimg">
 
</div>
</a>
</div>
<hr/>
 
<table align=center width="1022" height=25 border=0 cellpadding=0 cellspacing=0 bgcolor="#3b3b3b"><tr>
<td width="" align=center><a href="/"><font size="2em" color="white">All News</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/boards"><font size="2em" color="white">Boards</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/chips"><font size="2em" color="white">Chips</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/devices"><font size="2em" color="white">Devices</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/software"><font size="2em" color="white">Software</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="http://linuxdevices.linuxgizmos.com"><font size="2em" color="white"><font color="white">LinuxDevices.com Archive</b></font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/about"><font size="2em" color="white">About</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/contact"><font size="2em" color="white">Contact</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="#subscribe"><font size="2em" color="white">Subscribe</font></a></td>
</tr></table>
 
<table align=center width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>
 
<center><table width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white"><tr>
<td width=14></td>
<td align=left>
 
<table align=left width=728 height=90 border=1 bordercolor="#ebebeb" cellpadding=0 cellspacing=0 bgcolor="white"><tr><td>
 
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=20&pid=1&resolution='+screen.width+'x'+screen.height+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
 
</td></tr></table>
 
</td>
<td width=10></td>
<td width=250 border=0 align=center>
 
<table align=left cellpadding=5 cellspacing=0 border=0>
<tr><td align=center valign=middle><font size=2em color="#4a8ca7"><b>Follow LinuxGizmos:</b></font></td></tr>
<tr><td align=center valign=middle>
<a href="http://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter.png" alt="Twitter"></a>
<a href="https://plus.google.com/+LinuxGizmos/posts" rel="publisher" style="text-decoration:none;" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/gplus.png" alt="Google+"></a>
<a href="https://www.facebook.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="http://linuxgizmos.com/files/facebook.png" alt="Facebook"></a>
<a href="/feed/" target="new"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss.png" target="new"></a>
</td></tr>
<tr><td align=center valign=middle><b>&gt;</b>&nbsp;<a href="/#subscribe"><font size=2em color="#4a8ca7">get email updates</font></a>&nbsp;<b>&lt;</b></td></tr>
</table>
 
</td>
</tr></table></center>
 
<table align=center width="100%" height=3 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>
<div id="sidebar">
<div class="sidebar-right">
<ul>
<li id="search-3" class="widget widget_search"><h2 class="widgettitle">Search LinuxGizmos:</h2>
<form method="get" id="searchform" action="http://linuxgizmos.com/">
<div><input type="text" value="" name="s" id="s"/>
<input type="submit" id="searchsubmit" value="Search"/>
</div>
</form></li>
<li id="text-33" class="widget widget_text"><h2 class="widgettitle">Search LinuxGizmos.com + LinuxDevices Archive:</h2>
<div class="textwidget"><form action="http://linuxgizmos.com/search" id="cse-search-box">
<div>
<input type="hidden" name="cx" value="partner-pub-3975801459690075:2161158331"/>
<input type="hidden" name="cof" value="FORID:10"/>
<input type="hidden" name="ie" value="UTF-8"/>
<input type="text" name="q" size="23"/>
<input type="submit" name="sa" value="Search"/>
</div>
</form>
<script type="text/javascript" src="http://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script></div>
</li>
<li id="text-35" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
<div class="textwidget"><br>   
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/unique/javascript/strip?zid=18&pid=0&total=10&layout=vertical&margin=0&padding=15&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent(document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
 
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
</li>
<li id="top-posts-3" class="widget widget_top-posts"><h2 class="widgettitle">Top 10 trending posts&#8230; </h2>
<ul> <li>
<a href="http://linuxgizmos.com/industrial-touch-panel-computer-builds-on-raspberry-pi-3/" class="bump-view" data-bump-view="tp">
Industrial touch-panel computer builds on Raspberry Pi 3 </a>
</li>
<li>
<a href="http://linuxgizmos.com/9-orange-pi-may-be-first-96boards-iot-sbc-to-run-linux/" class="bump-view" data-bump-view="tp">
Tiny, $9 Orange Pi may be first 96Boards IoT SBC to run Linux </a>
</li>
<li>
<a href="http://linuxgizmos.com/open-spec-rpi-style-sbc-features-new-rockchip-rk3328/" class="bump-view" data-bump-view="tp">
Open-spec, RPi-style SBC features new Rockchip RK3328 </a>
</li>
<li>
<a href="http://linuxgizmos.com/linux-under-fire-malware-reports-detail-growing-threats/" class="bump-view" data-bump-view="tp">
Linux under fire: Malware reports detail growing threats </a>
</li>
<li>
<a href="http://linuxgizmos.com/mozilla-launches-project-things-iot-framework-on-raspberry-pi/" class="bump-view" data-bump-view="tp">
Mozilla launches Project Things IoT framework on Raspberry Pi </a>
</li>
<li>
<a href="http://linuxgizmos.com/catalog-of-98-open-spec-hacker-friendly-sbcs/" class="bump-view" data-bump-view="tp">
Catalog of 98 open-spec, hacker friendly SBCs </a>
</li>
<li>
<a href="http://linuxgizmos.com/ringing-in-2017-with-90-hacker-friendly-single-board-computers/" class="bump-view" data-bump-view="tp">
Ringing in 2017 with 90 hacker-friendly single board computers </a>
</li>
<li>
<a href="http://linuxgizmos.com/heres-who-won-26-sbcs-in-our-annual-hacker-sbc-survey/" class="bump-view" data-bump-view="tp">
Here&#039;s who won 26 SBCs in our annual Hacker SBC Survey </a>
</li>
<li>
<a href="http://linuxgizmos.com/kaby-lake-box-computer-targets-vision-systems/" class="bump-view" data-bump-view="tp">
Rugged, Kaby Lake box-PC targets vision systems </a>
</li>
<li>
<a href="http://linuxgizmos.com/2017-hacker-board-survey-raspberry-pi-still-rules-but-x86-sbcs-make-gains/" class="bump-view" data-bump-view="tp">
2017 hacker board survey: Raspberry Pi still rules, but x86 SBCs make gains </a>
</li>
</ul></li>
<li id="text-18" class="widget widget_text"> <div class="textwidget"><a name="subscribe"></a></div>
</li>
<li id="text-3" class="widget widget_text"><h2 class="widgettitle">Follow LinuxGizmos or subscribe to our posts:</h2>
<div class="textwidget"></div>
</li>
<li id="text-37" class="widget widget_text"> <div class="textwidget"><table align=center><tr><td align=center valign=middle><h2>Follow:</h2></td><td align=center valign=middle><a href="http://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/twitter.png" alt="Twitter" target="new"></a> <a href="https://plus.google.com/+LinuxGizmos/posts" rel="publisher" style="text-decoration:none;" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/gplus.png" alt="Google+"></a> <a href="https://www.facebook.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/facebook.png" alt="Facebook"></a> <a href="/feed/"><img height=25 width=25 vspace=5 hspace=5 alt="RSS feed" src="http://linuxgizmos.com/files/rss.png" target="new"></a></td></tr></table></div>
</li>
<li id="blog_subscription-2" class="widget jetpack_subscription_widget"> <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
<div id="subscribe-text"><p>Enter your email address to receive notifications of new posts:</p>
</div> <p id="subscribe-email">
<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-2">
Email Address </label>
<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-2" placeholder="Email Address"/>
</p>
<p id="subscribe-submit">
<input type="hidden" name="action" value="subscribe"/>
<input type="hidden" name="source" value="http://linuxgizmos.com/mozilla-launches-project-things-iot-framework-on-raspberry-pi/"/>
<input type="hidden" name="sub-type" value="widget"/>
<input type="hidden" name="redirect_fragment" value="blog_subscription-2"/>
<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget"/>
</p>
</form>
<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-2]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-2'),
					input = d.getElementById('subscribe-field-blog_subscription-2'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
</li>
<li id="text-36" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
<div class="textwidget"><br> 
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=21&pid=1&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
 
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
</li>
</ul>
</div>  
</div>
<div id="content" class="narrowcolumn">
<div class="post" id="post-58423">
<h2><a href="http://linuxgizmos.com/mozilla-launches-project-things-iot-framework-on-raspberry-pi/" rel="bookmark" title="Permanent Link: Mozilla launches Project Things IoT framework on Raspberry Pi">Mozilla launches Project Things IoT framework on Raspberry Pi</a></h2>
<small>Jul 7, 2017 &mdash; by Eric Brown </small>
 
<small> &mdash; 236 views </small>
<div class="entrytext">
 <div class="ssba ssba-wrap"><div style="text-align:center"><a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=http://linuxgizmos.com/mozilla-launches-project-things-iot-framework-on-raspberry-pi/&amp;text=Mozilla+launches+Project+Things+IoT+framework+on+Raspberry+Pi+" target="_blank"><img src="http://linuxgizmos.com/files/ssarbenta-twitter-lg.png" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter"/></a><a data-site="" class="ssba_google_share" href="https://plus.google.com/share?url=http://linuxgizmos.com/mozilla-launches-project-things-iot-framework-on-raspberry-pi/" target="_blank"><img src="http://linuxgizmos.com/files/ssarbenta-google-lg.png" title="Share on Google+" class="ssba ssba-img" alt="Google+"/></a><a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=http://linuxgizmos.com/mozilla-launches-project-things-iot-framework-on-raspberry-pi/" target="_blank"><img src="http://linuxgizmos.com/files/ssarbenta-facebook-lg.png" title="Facebook" class="ssba ssba-img" alt="Share on Facebook"/></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http://linuxgizmos.com/mozilla-launches-project-things-iot-framework-on-raspberry-pi/" target="_blank"><img src="http://linuxgizmos.com/files/ssarbenta-linkedin-lg.png" alt="Share on LinkedIn" title="LinkedIn" class="ssba ssba-img"/></a><a data-site="reddit" class="ssba_reddit_share" href="http://reddit.com/submit?url=http://linuxgizmos.com/mozilla-launches-project-things-iot-framework-on-raspberry-pi/&amp;title=Mozilla launches Project Things IoT framework on Raspberry Pi" target="_blank"><img src="http://linuxgizmos.com/files/ssarbenta-reddit-lg.png" title="Reddit" class="ssba ssba-img" alt="Share on Reddit"/></a></div></div><p><img align=left vspace=5 hspace=10 src="/files/mozilla_projecthings_rpi-thm.jpg">Mozilla unveiled “Project Things,” which builds upon standard web technologies and the Web of Things project, and released code that runs on a Raspberry Pi.<br/>
<span id="more-58423"></span><br/>
In March of last year, a few months after Mozilla announced it was<a href="http://linuxgizmos.com/rip-firefox-os-phones-we-hardly-knew-ye/" target="new"> shutting down its Firefox OS</a> project for Linux-based mobile phones, it <a href="http://linuxgizmos.com/mozilla-unveils-firefox-os-based-iot-projects/" target="new">unveiled</a> four Firefox OS based “Connected Devices” projects for the Internet of Things. The Connected Devices project has since shut down, but a <a href="https://wiki.mozilla.org/Connected_Devices/Projects" target="new">website</a> is still available for others to advance the code. Instead, Mozilla turned its IoT team toward an existing <a href="http://webofthings.org/" target="new">Web of Things</a> (WoT) project aimed at developing a decentralized, open source IoT framework built as much as possible using existing World Wide Web technologies.</p>
<p>Mozilla has now announced its own Project Things framework designed to pull together existing Web of Things specifications and code under a global framework comprised of device, gateway, and cloud components. As a starting point, it released a prototype version of a Things Gateway stack that runs on a Raspberry Pi.<br/>
<center><br/>
<a href="/files/mozilla_projecthings_iot_vertical.jpg" target="new"><img src="/files/mozilla_projecthings_iot_vertical-sm.jpg" vspace=10 hspace=5 border=0></a> <a href="/files/mozilla_projecthings.jpg" target="new"><img src="/files/mozilla_projecthings-sm.jpg" vspace=10 hspace=5 border=0></a><br/>
<b>Vertical IoT silos (left) and Web of Things metalayer</b><br/>
(click images to enlarge)<br/>
</center><br/>
Project Things is said to be compatible with WoT and related standardization efforts at the <a href="https://www.ietf.org/id/draft-keranen-t2trg-rest-iot-04.txt" target="new">IETF</a>, the <a href="https://www.w3.org/WoT/" target="new">W3C</a>, the <a href="https://github.com/opengeospatial/sensorthings" target="new">OGC</a> (SensorThings), and the <a href="https://openconnectivity.org/" target="new">OCF</a>. The Linux Foundation backed OCF (Open Connectivity Foundation) which is in the process of integrating the AllSeen Alliance’s AllJoyn standard into its <a href="http://linuxgizmos.com/how-iotivity-plus-alljoyn-could-form-a-best-of-breed-iot-framework/" target="new">IoTivity</a> framework, is probably the largest of the many vendor-agnostic, open source <a href="http://linuxgizmos.com/open-source-projects-for-the-internet-of-things-from-a-to-z/" target="new">IoT standardization efforts</a>.</p>
<p>Yet most home and industrial IoT vendors more often align themselves with one or more of the IoT ecosystems pushed by a handful of the world’s largest tech companies. All of these stacks include proprietary technology, as well as varying degrees of more open technologies that are more or less controlled by a single company.</p>
<p>The Project Things framework (and WoT in general) is designed to act as a metalayer that sits atop these IoT ecosystems to bridge the gaps, writes Mozilla’s Ben Francis in a June 28 Mozilla Hacks blog. As illustrated in the chart above, each ecosystem is a vertical silo that prevents true interoperability. As the ecosystems mature, they may add interoperability with other frameworks on the edges, but the dependence on core technologies or cloud platforms further strengthens the barriers between the silos. </p>
<p>The three more Linux-oriented ecosystems listed here &#8212; Google/Nest, <a href="http://linuxgizmos.com/amazon-releases-aws-greengrass-for-local-iot-processing-on-linux-devices/" target="new">Amazon AWS IoT</a>, and Samsung <a href="http://linuxgizmos.com/latest-samsung-artik-module-runs-tizen-rt-on-a-cortex-m4/" target="new">Artik</a>/<a href="http://linuxgizmos.com/linux-based-smart-home-hubs-advance-into-ai/" target="new">SmartThings</a> &#8212; offer more open technologies and more cross-interoperability than the Apple or Microsoft silos, but the gaps are still large. Even within the silos, there are technologies that are not fully integrated, such as the different versions of Weave used by Google and Nest, or Samsung’s yet to be integrated Artik, SmartThings, and Tizen product families.</p>
<p>The basic concept of Project Things and WoT is similar to that of the Web. As Francis puts it, the goal is “creating a decentralized Internet of Things by giving Things URLs on the web to make them linkable and discoverable, and defining a standard data model and APIs to make them interoperable.” Mozilla’s role in WoT is to “help define new web standards and promote best practices around privacy, security and interoperability,” he adds.</p>
<p>Project Things and WoT use existing web standards like REST, HTTP, JSON, WebSockets, and TLS (Transport Layer Security). The W3C is considering adding new standards to enable WoT. According to Francis, Mozilla believes there is a need for a new “Web Thing Description format to describe things, a REST style Web Thing API to interact with them, and possibly a new generation of HTTP better optimised for IoT use cases and use by resource constrained devices.”</p>
<p>On July 4, Mozilla submitted a <a href="http://iot.mozilla.org/wot/" target="new">Web Thing API</a> spec proposal to the W3C. The spec includes a “simple but extensible Web Thing Description format with a default JSON encoding, and a REST + WebSockets Web Thing API,” writes Francis.<br/>
<center><br/>
<a href="/files/mozilla_projecthings2.jpg" target="new"><img src="/files/mozilla_projecthings2-sm.jpg" vspace=10 hspace=5 border=0></a><br/>
<b>Project Things in three flavors</b><br/>
(click image to enlarge)<br/>
</center><br/>
Like many IoT frameworks, Project Things is split into device (smart node/endpoint), gateway, and cloud components. Devices use a Direct Integration Pattern within a Things Framework to directly expose a WoT API. Such endpoints need WiFi or an equivalent, backed up with TCP/IP and HTTP. </p>
<p>The Things Gateway component runs on gateways that aggregate communications from low-end or PAN networked devices. The Things Cloud component use a cloud server to expose a WoT API, and can control numerous gateways and smart IoT devices over a wide geographic area.</p>
<p>&nbsp;<br/>
<b>Prototype software runs on Raspberry Pi</b></p>
<p>Mozilla’s prototype of the Things Gateway is designed to run under Linux on a Raspberry Pi 3 SBC. The “experimental pre-release software” can be adapted to run on other developer boards or even a desktop computer, says Mozilla. The software is implemented in JavaScript with a NodeJS web server, but Mozilla is working on an “adapter add-on system” to enable other programming languages such as Rust.<br/>
<center><br/>
<a href="/files/mozilla_projecthings_thingsgateway.jpg" target="new"><img src="/files/mozilla_projecthings_thingsgateway-sm.jpg" vspace=10 hspace=5 border=0></a><br/>
<b>Things Gateway architecture</b><br/>
(click image to enlarge)<br/>
</center><br/>
The Things Gateway prototype software is designed to let you:</p>
<ul>
<li>Easily discover the gateway on your local network
<li>Choose a web address which connects your home to the Internet via a secure TLS tunnel requiring zero configuration on your home network
<li>Create a username and password to authorize access to your gateway
<li>Discover and connect commercially available ZigBee and Z-Wave smart plugs to the gateway
<li>Turn those smart plugs on and off from a web app hosted on the gateway itself</ul>
<p><center><br/>
<iframe width="480" height="270" src="https://www.youtube.com/embed/nODlPf9P3Vk" frameborder="0" allowfullscreen></iframe><br/>
</center><br/>
<center><b>Simple Project Things prototype light-switch demo</b></center></p>
<p>&nbsp;<br/>
<b>Further information</b></p>
<p>More information on Project Things may be found on Mozilla’s <a href="https://hacks.mozilla.org/2017/06/building-the-web-of-things/" target="new">blog announcement</a> and <a href="http://iot.mozilla.org/wot/" target="new">Web Thing API page</a>. The Raspberry Pi Thing Gateway prototype image may be downloaded <a href="http://iot.mozilla.org/gateway/" target="new">here</a>.<br/>
&nbsp;</p>
<div class="crp_related "><h4>Related posts:</h4><ul><li><a href="http://linuxgizmos.com/open-source-iot-software-framework-project-releases-preview/"><span class="crp_title">Open-source IoT software framework releases preview</span></a></li><li><a href="http://linuxgizmos.com/open-source-group-focuses-on-industrial-iot-gateway-middleware/"><span class="crp_title">Open source group focuses on industrial IoT gateway&hellip;</span></a></li><li><a href="http://linuxgizmos.com/two-key-open-source-iot-frameworks-get-cozy/"><span class="crp_title">Two key open source IoT frameworks get cozy</span></a></li><li><a href="http://linuxgizmos.com/an-open-source-perspective-on-the-internet-of-things-part-1/"><span class="crp_title">An open source perspective on the Internet of Things&hellip;</span></a></li><li><a href="http://linuxgizmos.com/linuxs-domination-of-home-automation-gizmos-continues/"><span class="crp_title">Linux&#039;s domination of home automation gizmos continues</span></a></li><li><a href="http://linuxgizmos.com/mozilla-unveils-firefox-os-based-iot-projects/"><span class="crp_title">Mozilla unveils Firefox OS based IoT projects</span></a></li><li><a href="http://linuxgizmos.com/open-source-projects-for-the-internet-of-things-from-a-to-z/"><span class="crp_title">Open source projects for the Internet of Things, from A to Z</span></a></li><li><a href="http://linuxgizmos.com/mozilla-preps-firefox-os-for-the-raspberry-pi/"><span class="crp_title">Mozilla preps Firefox OS for the Raspberry Pi</span></a></li><li><a href="http://linuxgizmos.com/linux-based-smart-home-hubs-advance-into-ai/"><span class="crp_title">Linux-based smart home hubs advance into AI</span></a></li><li><a href="http://linuxgizmos.com/rip-firefox-os-phones-we-hardly-knew-ye/"><span class="crp_title">RIP Firefox OS phones, we hardly knew ye</span></a></li></ul><div class="crp_clear"></div></div> </div>
</div>
<table width=468 height=60 align=center border=1 bordercolor="#ebebeb" cellpadding=0 cellspacing=0>
<tr><td bgcolor="#f4f4f4" align=center valign=middle>
 
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=22&pid=0&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
 
</td></tr></table>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
<br><br>
<table width="100%" bordercolor="#ebebeb" border=1 cellpadding=10 cellspacing="0" align=center>
<tr><td align=center><b><font color="#4a8ca7" size=3>PLEASE COMMENT BELOW</font></b></td></tr></table>
 
 
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Please comment here... <small><a rel="nofollow" id="cancel-comment-reply-link" href="/mozilla-launches-project-things-iot-framework-on-raspberry-pi/#respond" style="display:none;">Cancel reply</a></small></h3>
<form id="commentform" class="comment-form">
<iframe src="http://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&#038;postid=58423&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=blank&#038;greeting=Please+comment+here...&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.1&#038;sig=4ed8d653c773237b67c9ea9bba05c55f7467ccc3#parent=http%3A%2F%2Flinuxgizmos.com%2Fmozilla-launches-project-things-iot-framework-on-raspberry-pi%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
<!--[if !IE]><!-->
<script>
					document.addEventListener( 'DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName( 'jetpack_remote_comment' );
						for ( var i = 0; i < commentForms.length; i++ ) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					} );
				</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value=""/>
</div>
<div id="footer">
 
<table width="100%" border=0 cellpadding=10 cellspacing=0><tr><td></td></tr></table>
<table align="center" width=728 height=90 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td border=1 bordercolor="#4a8ca7" bgcolor="#f4f4f4" align=center valign=middle>
 
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=23&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
 
</td></tr>
<tr><td></table>
<table width="100%" border=0 cellpadding=5 cellspacing=0><tr><td>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
</td></tr></table>
 
<div>
<font size=1><i>The content on this site is copyright &copy; 2007-2017 Rick Lehrbaum unless otherwise noted. Comments are the property of their submitters. Content originally published on LinuxDevices is Copyright &copy; 1999-2017 QuinStreet Inc. and is reproduced here under license from its owner. LinuxGizmos is part of the <a href="http://deviceguru.com/about/" target="new"><u>DeviceGuru Blog Network</u></a>. Linux is a registered trademark of Linus Torvalds.</i></font>
</div>
<br>
<div align=center>
<font size=1><a href="/contact"><font color="#4a8ca7"><u>Contact us</u></font></a> | <a href="http://www.deviceguru.com/privacy/"><font color="#4a8ca7"><u>Privacy policy</u></font></a> | <a href="/terms-of-use" target="new"><font color="#4a8ca7"><u>Terms of use</u></font></a> | <a href="/about"><font color="#4a8ca7"><u>About us</u></font></a> | <a href="/feed"><font color="#4a8ca7"><u>RSS feed</u></font></a> </font>
</div>
 
 
 
</div>
</div>
<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.2'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"M. d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201727'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.min.js?ver=4.8'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/wp-embed.min.js?ver=4.8'></script>
<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=58423&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.1&sig=4ed8d653c773237b67c9ea9bba05c55f7467ccc3#parent=http%3A%2F%2Flinuxgizmos.com%2Fmozilla-launches-project-things-iot-framework-on-raspberry-pi%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=58423&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.1&sig=4ed8d653c773237b67c9ea9bba05c55f7467ccc3#parent=http%3A%2F%2Flinuxgizmos.com%2Fmozilla-launches-project-things-iot-framework-on-raspberry-pi%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "http:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "http:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-201727.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.1',blog:'47422091',post:'58423',tz:'-7',srv:'linuxgizmos.com'} ]);
	_stq.push([ 'clickTrackerInit', '47422091', '58423' ]);
</script>
 
 
 
</body>
</html>