<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>Linux-driven module and starter kit tap Renesas RZ/G2</title> 

<meta name="generator" content="WordPress 5.5.3" /> <!-- leave this for stats -->

<link rel="stylesheet" href="http://linuxgizmos.com/wp-content/themes/lg-theme/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com RSS Feed" href="http://linuxgizmos.com/feed/" />

<link rel="pingback" href="http://linuxgizmos.com/xmlrpc.php" />

<!-- G+ author attribution -->
<link rel="author" href="https://plus.google.com/104414840801731506333" />

<style type="text/css" media="screen">
	#headerimg { margin: 0; margin-top: 0px; height: 80px; width: 1022px; }
	#headerimg { background: url('http://linuxgizmos.com/wp-content/themes/lg-theme/images/header.jpg') no-repeat top;}
</style>

<script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script>
	<!-- This site is optimized with the Yoast SEO plugin v15.3 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="TQ’s “TQMaRZG2x” module runs Linux on a dual- to octa-core, Cortex-A57 and -A53 based RZ/G2 processor with up to 8GB LPDDR4 and 64GB eMMC plus an optional dev kit and -40 to 85°C support." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Linux-driven module and starter kit tap Renesas RZ/G2" />
	<meta property="og:description" content="TQ’s “TQMaRZG2x” module runs Linux on a dual- to octa-core, Cortex-A57 and -A53 based RZ/G2 processor with up to 8GB LPDDR4 and 64GB eMMC plus an optional dev kit and -40 to 85°C support." />
	<meta property="og:url" content="http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/" />
	<meta property="og:site_name" content="LinuxGizmos.com" />
	<meta property="article:publisher" content="http://facebook.com/LinuxGizmos" />
	<meta property="article:published_time" content="2020-11-23T14:30:42+00:00" />
	<meta property="article:modified_time" content="2020-11-23T14:30:45+00:00" />
	<meta property="og:image" content="http://linuxgizmos.com/files/tq_tqmarzg2x-thm.jpg" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@LinuxGizmos" />
	<meta name="twitter:site" content="@LinuxGizmos" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Eric Brown">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="3 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://linuxgizmos.com/#website","url":"http://linuxgizmos.com/","name":"LinuxGizmos.com","description":"Embedded Linux news &amp; devices","potentialAction":[{"@type":"SearchAction","target":"http://linuxgizmos.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/#primaryimage","inLanguage":"en-US","url":"/files/tq_tqmarzg2x-thm.jpg"},{"@type":"WebPage","@id":"http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/#webpage","url":"http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/","name":"Linux-driven module and starter kit tap Renesas RZ/G2","isPartOf":{"@id":"http://linuxgizmos.com/#website"},"primaryImageOfPage":{"@id":"http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/#primaryimage"},"datePublished":"2020-11-23T14:30:42+00:00","dateModified":"2020-11-23T14:30:45+00:00","author":{"@id":"http://linuxgizmos.com/#/schema/person/6e28e3570b7dd729e9ff4170826bc3f7"},"description":"TQ\u2019s \u201cTQMaRZG2x\u201d module runs Linux on a dual- to octa-core, Cortex-A57 and -A53 based RZ/G2 processor with up to 8GB LPDDR4 and 64GB eMMC plus an optional dev kit and -40 to 85\u00b0C support.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/"]}]},{"@type":"Person","@id":"http://linuxgizmos.com/#/schema/person/6e28e3570b7dd729e9ff4170826bc3f7","name":"Eric Brown","sameAs":["http://www.ericsbrown.com/"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com &raquo; Linux-driven module and starter kit tap Renesas RZ/G2 Comments Feed" href="http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/linuxgizmos.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://linuxgizmos.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://linuxgizmos.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.1' type='text/css' media='all' />
<script id='st_insights_js' type='text/javascript' src="https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare" id='ssba-sharethis-js'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
        <style>
            .eaa-clean {
                padding: 0 !important;
                border: none !important;
            }

            .eaa-ad.alignleft {
                margin-right: 10px;
            }

            .eaa-ad.alignright {
                margin-left: 10px;
            }
            .eaa-ad.debug{
                background:peachpuff;
                border:solid 2px #FF0000;
                box-sizing: border-box;
            }

        </style>


		<link rel="https://api.w.org/" href="http://linuxgizmos.com/wp-json/" /><link rel="alternate" type="application/json" href="http://linuxgizmos.com/wp-json/wp/v2/posts/72960" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://linuxgizmos.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://linuxgizmos.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='https://wp.me/p3cYEr-iYM' />
<link rel="alternate" type="application/json+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Flinux-driven-module-and-starter-kit-tap-renesas-rz-g2%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Flinux-driven-module-and-starter-kit-tap-renesas-rz-g2%2F&#038;format=xml" />
			<style type="text/css" id="wp-custom-css">
				figcaption {
    text-align: center; margin: auto;
}			</style>
		
<!-- google adsense verification tag -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4310582701436176",
    enable_page_level_ads: true
  });
</script>
<!-- end google adsense verification tag -->
	
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5377446-2', 'linuxgizmos.com');
  ga('send', 'pageview');
</script>
	
<!-- clone of ssba css as of v7.4.10 -->
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=4.9.4' type='text/css' media='all' />

<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css'  href='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.9.4' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: 0px solid #59625c;
									
									
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								#ssba-classic-2 .ssbp-text {
									display: none!important;
								}
								
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px; }
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}
								
@font-face {
				font-family: 'ssbp';
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<!-- end clone of ssba css -->	
	
</head>
<body>
<div id="page">

<div id="header">

<!-- optional Advertserve page peel ad Display Code goes below here -->
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
_avp.push({ alias: '/', type: 'pagepeel', mid: 380, pid: 0 });
</script>
<!-- END ADVERTSERVE CODE -->

<a href="http://linuxgizmos.com/">
    <div id="headerimg">

     <!--
     <h1> <a href="http://linuxgizmos.com/">LinuxGizmos.com</a></h1> 
     <div class="description"><i>Embedded Linux news &amp; devices</i></div> 
     -->
    </div>

</a>

</div>

<hr />
<!-- section links start -->
<table align=center width="1022" height=25 border=0 cellpadding=0 cellspacing=0 bgcolor="#3b3b3b"><tr>
<td width="" align=center><a href="/"><font size="2em" color="white">All News</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/boards"><font size="2em" color="white">Boards</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/chips"><font size="2em" color="white">Chips</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/devices"><font size="2em" color="white">Devices</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/software"><font size="2em" color="white">Software</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="http://linuxdevices.org"><font size="2em" color="white"><font color="white">LinuxDevices.com Archive</b></font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/about"><font size="2em" color="white">About</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/contact"><font size="2em" color="white">Contact</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="#subscribe"><font size="2em" color="white">Subscribe</font></a></td>
</tr></table>
<!-- section links end -->

<table align=center width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

<!-- header banner wrapper starts -- NOTE: total width = 1022 px -->
<center><table width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white"><tr>

<td width=14></td>

<td align=left>
<!-- 728x90 ad goes below here -->
<table align=left width=728 height=90 border=1 bordercolor="#ebebeb" cellpadding=0 cellspacing=0 bgcolor="white"><tr><td>
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=20&pid=1&resolution='+screen.width+'x'+screen.height+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<!-- 728x90 ad goes above here -->
</td>

<td width=10></td>

<td width=250 border=0 align=center>
<!-- sharing and subscription block goes below here -->
<table align=left cellpadding=5 cellspacing=0 border=0>
<tr><td align=center valign=middle><font size=2em color="#4a8ca7"><b>Follow LinuxGizmos:</b></font></td></tr>
<tr><td align=center valign=middle>
<a href="https://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter-square-25px.png" alt="Twitter"></a> 
<a href="https://www.facebook.com/LinuxGizmos/posts/" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/facebook-square-25px.png" alt="Facebook"></a>  
<a href="https://www.pinterest.com/LinuxGizmos/" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/pinterest-square-25px.png" alt="Pinterest"></a> 
<a href="/feed/" target="new"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss-square-25px.png" target="new"></a>
</td></tr>
<tr><td align=center valign=middle><a href="/#subscribe"><font size=2em color="#4a8ca7"><b>*</b> &nbsp; get email updates &nbsp; <b>*</b></font></a></td></tr>
</table>
<!-- sharing and subscription block goes above here -->
</td>
</tr></table></center>
<!-- header banner wrapper ends -->

<table align=center width="100%" height=3 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

	<div id="sidebar">
	<div class="sidebar-right">
		<ul>
			<li id="search-3" class="widget widget_search"><h2 class="widgettitle">Search LinuxGizmos:</h2>
<form method="get" id="searchform" action="http://linuxgizmos.com/">
<div><input type="text" value="" name="s" id="s" />
<input type="submit" id="searchsubmit" value="Search" />
</div>
</form></li>
<li id="text-33" class="widget widget_text"><h2 class="widgettitle">Search LinuxGizmos.com + LinuxDevices Archive:</h2>
			<div class="textwidget"><form action="http://linuxgizmos.com/search" id="cse-search-box">
  <div>
    <input type="hidden" name="cx" value="partner-pub-3975801459690075:2161158331" />
    <input type="hidden" name="cof" value="FORID:10" />
    <input type="hidden" name="ie" value="UTF-8" />
    <input type="text" name="q" size="23" />
    <input type="submit" name="sa" value="Search" />
  </div>
</form>
<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script></div>
		</li>
<li id="text-35" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
			<div class="textwidget"><br><!-- BEGIN ZONE 2 ADVERTSERVE CODE --> <!-- set total to zone 2 (non-dg) campaigns minus 1 -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/unique/javascript/strip?zid=18&pid=1&total=13&layout=vertical&margin=0&padding=15&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent(document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
		</li>
<li id="top-posts-4" class="widget widget_top-posts"><h2 class="widgettitle">Top 10 trending posts&#8230;</h2>
<ul>				<li>
					<a href="http://linuxgizmos.com/raspberry-pi-automation-add-on-offers-adcs-dido-and-ups/" class="bump-view" data-bump-view="tp">Raspberry Pi automation add-on offers ADCs, DIDO, and UPS</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/" class="bump-view" data-bump-view="tp" aria-current="page">Linux-driven module and starter kit tap Renesas RZ/G2</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/tinker-board-2-sbc-advances-to-rk3399/" class="bump-view" data-bump-view="tp">Tinker Board 2 SBC advances to RK3399</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/sata-hats-support-up-to-four-drives-on-raspberry-pi-4-or-rock-pi-4/" class="bump-view" data-bump-view="tp">SATA HATs support up to four drives on Raspberry Pi 4 or Rock Pi 4</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/portwell-and-congatec-spin-elkhart-lake-modules-in-multiple-form-factors/" class="bump-view" data-bump-view="tp">Portwell and Congatec spin Elkhart Lake modules in multiple form factors</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/raspberry-pi-automation-add-on-supplies-five-relays-and-8-channel-adc/" class="bump-view" data-bump-view="tp">Raspberry Pi automation add-on supplies five relays and 8-channel ADC</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/cluster-platform-supports-seven-raspberry-pi-compute-modules/" class="bump-view" data-bump-view="tp">Cluster platform supports seven Raspberry Pi Compute Modules</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/allwinner-h3-maker-board-could-be-smallest-linux-powered-sbc-yet/" class="bump-view" data-bump-view="tp">Allwinner H3 maker board could be smallest Linux-powered SBC yet</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/turing-pi-2-clusters-four-raspberry-pi-cm4-modules/" class="bump-view" data-bump-view="tp">Turing Pi 2 clusters four Raspberry Pi CM4 modules</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/banana-pi-quad-gbe-router-sbc-features-m-2-and-five-mini-pcie-slots-with-sim/" class="bump-view" data-bump-view="tp">Banana Pi quad-GbE router SBC features M.2 and five mini-PCIe slots with SIM</a>					</li>
				</ul></li>
<li id="text-36" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
			<div class="textwidget"><br><!-- BEGIN ZONE 3 ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=21&pid=1&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
		</li>
<li id="text-18" class="widget widget_text">			<div class="textwidget"><a name="subscribe"></a></div>
		</li>
<li id="text-3" class="widget widget_text"><h2 class="widgettitle">Follow LinuxGizmos or subscribe to our posts:</h2>
			<div class="textwidget"></div>
		</li>
<li id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><table>
<tr><td align=center valign=middle>
&nbsp;&nbsp;
<a href="https://www.twitter.com/LinuxGizmos" target="new" rel="noopener noreferrer"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter-square-25px.png" alt="Twitter"></a>
<a href="https://www.facebook.com/LinuxGizmos/posts/" target="new" rel="noopener noreferrer"><img height=25 width=25 vspace=0 hspace=5 src="/files/facebook-square-25px.png" alt="Facebook"></a>
<a href="https://www.pinterest.com/LinuxGizmos/" target="new" rel="noopener noreferrer"><img height=25 width=25 vspace=0 hspace=5 src="/files/pinterest-square-25px.png" alt="Pinterest"></a>
<a href="/feed/" target="new" rel="noopener noreferrer"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss-square-25px.png" target="new"></a>
</td></tr></table></div></li>
<li id="blog_subscription-3" class="widget widget_blog_subscription jetpack_subscription_widget"><h2 class="widgettitle">Subscribe</h2>

            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
				                    <div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div>					<div class="jetpack-subscribe-count">
						<p>
						Join 1,296 other subscribers						</p>
					</div>
					                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-3">
							email address                        </label>
                        <input type="email" name="email" required="required"
                        			                                                value=""
                            id="subscribe-field-blog_subscription-3"
                            placeholder="email address"
                        />
                    </p>

                    <p id="subscribe-submit">
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-3"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Subscribe                        </button>
                    </p>
				            </form>
		
</li>

		</ul>
	</div>	<!--sidebar-left-->


	</div>


	<div id="content" class="narrowcolumn">
				
  		
		<div class="post" id="post-72960">
			<h2><a href="http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/" rel="bookmark" title="Permanent Link: Linux-driven module and starter kit tap Renesas RZ/G2">Linux-driven module and starter kit tap Renesas RZ/G2</a></h2>

		<small>Nov 23, 2020 &mdash; by Eric Brown </small>

	<!-- tag for gapp post pageviews plugin -->
    <small>  </small> 

	<!-- tag for WP Stats View Counter -->
 <small> &mdash; 1499 views</small>
			
			<div class="entrytext">
				<!-- Simple Share Buttons Adder (8.0.1) simplesharebuttons.com --><div class="ssba-classic-2 ssba ssbp-wrap left ssbp--theme-1"><div style="text-align:left"><span class="ssba-share-text">Please share:</span><a data-site="" class="ssba_twitter_share" href="https://twitter.com/share?url=http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/&amp;text=Linux-driven%20module%20and%20starter%20kit%20tap%20Renesas%20RZ%2FG2%20" target=&quot;_blank&quot;><img src="/files/twitter-square-25px.png" style="width: 25px;" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /><div title="Twitter" class="ssbp-text">Twitter</div></a><a data-site="" class="ssba_facebook_share" href="https://www.facebook.com/sharer.php?u=http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/" target="_blank"><img src="/files/facebook-square-25px.png" title="Facebook" style="width: 25px;" class="ssba ssba-img" alt="Share on Facebook" /><div title="Facebook" class="ssbp-text">Facebook</div></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/" target=&quot;_blank&quot;><img src="/files/linkedin-square-25px.png" alt="Share on LinkedIn" style="width: 25px;" title="LinkedIn" class="ssba ssba-img" /><div title="Linkedin" class="ssbp-text">Linkedin</div></a><a data-site="reddit" class="ssba_reddit_share" href="https://reddit.com/submit?url=http://linuxgizmos.com/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/&amp;title=Linux-driven module and starter kit tap Renesas RZ/G2" target=&quot;_blank&quot;><img src="/files/reddit-square-25px.png" style="width: 25px;" title="Reddit" class="ssba ssba-img" alt="Share on Reddit" /><div title="Reddit" class="ssbp-text">Reddit</div></a><a data-site='pinterest' class='ssba_pinterest_share' href='javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;//assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());'><img style="width: 25px;" title="Pinterest" class="ssba ssba-img" src="/files/pinterest-square-25px.png" alt="Pin on Pinterest" /><div title="Pinterest" class="ssbp-text">Pinterest</div></a><a data-site="email" class="ssba_email_share" href="/cdn-cgi/l/email-protection#8eb1fdfbece4ebedfab3c2e7e0fbf6a3eafce7f8ebe0abbcbee3e1eafbe2ebabbcbeefe0eaabbcbefdfaeffcfaebfcabbcbee5e7faabbcbefaeffeabbcbedcebe0ebfdeffdabbcbedcd4a1c9bca8adbebdb6b5ece1eaf7b3abbcbee6fafafeb4a1a1e2e7e0fbf6e9e7f4e3e1fda0ede1e3a1e2e7e0fbf6a3eafce7f8ebe0a3e3e1eafbe2eba3efe0eaa3fdfaeffcfaebfca3e5e7faa3faeffea3fcebe0ebfdeffda3fcf4a3e9bca1"><img src="/files/email-square-25px.png" style="width: 25px;" title="Email" class="ssba ssba-img" alt="Email to someone" /><div title="email" class="ssbp-text">email</div></a></div></div><div class="pf-content"><p><img align="left" vspace="5" hspace="10" src="/files/tq_tqmarzg2x-thm.jpg">TQ’s “TQMaRZG2x” module runs Linux on a dual- to octa-core, Cortex-A57 and -A53 based RZ/G2 processor with up to 8GB LPDDR4 and 64GB eMMC plus an optional dev kit and -40 to 85°C support.<br />
<span id="more-72960"></span><br />
When reporting on the <a href="http://linuxgizmos.com/smarc-modules-showcase-up-to-octa-core-renesas-rz-g2/" target="new" rel="noopener noreferrer">SMARC 2.0 SoM</a> collaboration between Renesas and RelySys last week featuring Renesas’ scalable, 64-bit  <a href="http://linuxgizmos.com/renesas-unveils-64-bit-arm-socs-with-96boards-dev-boards/" target="new" rel="noopener noreferrer">RZ/G2</a> processor, we saw that we missed a September announcement from TQ Embedded about its own RZ/G2 module. The 77 x 50mm TQMaRZG2x is listed as “new” and is available with an optional new Embedded Starterkit STKaRZG2x evaluation board. The module is the first of several Renesas based products from TQ.<br />
<center><br />
<a href="/files/tq_tqmarzg2x.jpg" target="new" rel="noopener noreferrer"><img src="/files/tq_tqmarzg2x-sm.jpg" vspace="10" hspace="5" border="0"></a> <a href="/files/tq_stkarzg2x.jpg" target="new" rel="noopener noreferrer"><img src="/files/tq_stkarzg2x-sm.jpg" vspace="10" hspace="5" border="0"></a><br />
<b>TQMaRZG2x (left) and Embedded Starterkit STKaRZG2x </b><br />
(click images to enlarge)<br />
</center><br />
The RZ/G2, or RZ/G2x, family comprises four different models ranging from dual to octa-core. Like the Renesas/RelySys SMARC module, the TQMaRZG2x supports three of the four RZ/G2 models, skipping the dual-core, Cortex-A53 RZ/G2E. The supported SoCs are:</p>
<ul>
<li>RZ/G2N &#8212; 2x -A57 @ 1.5GHz; PowerVR GE7800 GPU</li>
<li>RZ/G2M &#8212; 2x -A57 @ 1.5GHz, 4x -A53 @ 1.2GHz; PowerVR GE6250</li>
<li>RZ/G2H &#8212; 4x -A57 @ 1.5GHz, 4x -A53 @ 1.2GHz; PowerVR GE6650</li>
</ul>
<p>The only other RZ/G2 products we have seen are a pair of 96Boards dev kits that Renesas announced with the SoC in Feb. 2019. The RZ/G2 is the first SoC to support the Linux Foundation’s 64-bit Civil Infrastructure Platform (CIP) Super Long-Term Support (SLTS) Linux kernel, which offers more than 10 years of kernel support. There was no mention of CIP support in the TQ announcement, however.</p>
<p>The TQMaRZG2x runs Linux on the RZ/G2, with Android and QNX available on request. The module supports up to 8GB LPDDR4, including ECC RAM, as well as up to 256MB QSPI NOR flash and up to 64GB eMMC flash. A GbE controller is available, but there is no wireless option.</p>
<p>The module’s 440-pin B2B connectors provide an LCD interface that supports HDMI 2.0, LVDS, and digital RGB. Other media features include dual MIPI-CSI2 camera interfaces and up to 10x I2S audio links.<br />
<center><br />
<a href="/files/tq_tqmarzg2x_block.jpg" target="new" rel="noopener noreferrer"><img src="/files/tq_tqmarzg2x_block-sm.jpg" vspace="10" hspace="5" border="0"></a><br />
<b>TQMaRZG2x block diagram</b><br />
(click image to enlarge)<br />
</center><br />
The TQMaRZG2x is further equipped with 2x USB 2.0 and other interfaces listed as “up to” including USB 3.0 OTG, QSPI, 6x UART, 5x H-UART, 2x CAN-FD, and 2x PCIe 2.0. More “up to” I/Os include 4x SDIO, 7x I2C, 4x SPI, 32x GPIO, and SATA, which is available only with the dual-core RZ/G2N.</p>
<p>The 5V module has an RTC, a temperature sensor, and a CPU JTAG interface. The standard operating range is -25 to 85°C and -40 to 85°C is optional. The module runs at a typical 6 Watts.</p>
<p>&nbsp;<br />
<b>Embedded Starterkit STKaRZG2x</b></p><div id="eaa_post_between_content" class="eaa-wrapper eaa_post_between_content eaa_desktop"><div class="eaa-ad  " style=""><p style="font-size:6px; text-align: center;">— ADVERTISEMENT —</p><img src="http://linuxgizmos.com/files/Clear.png"  style="width:70px"><!-- BEGIN ADVERTSERVE CODE -->
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=40&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script><br>
<!-- END ADVERTSERVE CODE --></div></div>
<p>TQ’s new eval kit for the TQMaRZG2x appears to be a Mini-ITX board like the MB-COME6-3 carrier available with TQ’s Whiskey Lake based <a href="http://linuxgizmos.com/new-tq-modules-include-whiskey-lake-u-and-ls1028a-models/" target="new" rel="noopener noreferrer">TQMx80UC</a> COM Express Compact Type 6 module. The Embedded Starterkit STKaRZG2x is equipped with a GbE port and 2x USB 3.0 ports on the coastline.</p>
<p>The STKaRZG2x provides dual MIPI-CSI camera interfaces, 2x CAN-FD connectors, and 2x PCIe slots. Although not listed in the minimalist specs, there also appears to be an HDMI port, an SD slot, 3x audio jacks, and a power jack. Two small coastline ports could be micro-USB and Type-C ports, and there are some terminal blocks and numerous I/O pins.</p>
<p>“With TQ we have one of the leading partners with proven knowledge in the market and the right experience with our technology and components,” stated Frank Urbe, Senior Manager Systems and Solutions Team EMEA, IoT and Infrastructure Business Unit at Renesas Electronics Corporation. “Since TQ is aiming for long-term customer support this is an additional value for both of us and as a result for our customers.”</p>
<p>&nbsp;<br />
<b>Further information</b></p>
<p>No pricing or availability information was provided for the TQMaRZG2x module or Embedded Starterkit STKaRZG2x kit. More information may be found in TQ Embedded’s <a href="https://www.tq-group.com/en/company/news/tq-portfolio-renesas/" target="new" rel="noopener noreferrer">announcement</a> and the <a href="https://www.tq-group.com/en/products/tq-embedded/arm-architecture/tqmrzg2x/" target="new" rel="noopener noreferrer">TQMaRZG2x</a> and <a href="https://www.tq-group.com/en/products/tq-embedded/ARM-Architecture/stkarzg2x/" target="new" rel="noopener noreferrer">STKaRZG2x</a> product pages.<br />
&nbsp;</p>
</div><div class="crp_related  "><h4>LinuxGizmos related posts:</h4><ul><li><a href="http://linuxgizmos.com/linux-driven-modules-to-showcase-new-mediatek-aiot-socs/"     class="post-65118"><span class="crp_title">Linux-driven modules to showcase new MediaTek AIoT SoCs</span></a></li><li><a href="http://linuxgizmos.com/i-mx8m-mini-module-offers-a-choice-of-two-carrier-boards/"     class="post-64928"><span class="crp_title">i.MX8M Mini module offers a choice of two carrier boards</span></a></li><li><a href="http://linuxgizmos.com/sodimm-module-runs-linux-on-i-mx8m-mini-or-nano-with-up-to-8gb-ram/"     class="post-64587"><span class="crp_title">SODIMM module runs Linux on i.MX8M Mini or Nano with&hellip;</span></a></li><li><a href="http://linuxgizmos.com/smarc-module-runs-linux-on-i-mx8m/"     class="post-63477"><span class="crp_title">SMARC module runs Linux on i.MX8M</span></a></li><li><a href="http://linuxgizmos.com/module-and-dev-kit-unleash-tis-am65x/"     class="post-67331"><span class="crp_title">Module and dev kit unleash TI's AM65x</span></a></li><li><a href="http://linuxgizmos.com/modules-and-dev-kits-run-linux-on-2-3-tops-equipped-i-mx8m-plus/"     class="post-71388"><span class="crp_title">Modules and dev kits run Linux on 2.3-TOPS equipped&hellip;</span></a></li><li><a href="http://linuxgizmos.com/congatec-shows-off-qseven-and-smarc-modules-with-new-i-mx8x/"     class="post-63340"><span class="crp_title">Congatec shows off Qseven and SMARC modules with new i.MX8X</span></a></li><li><a href="http://linuxgizmos.com/linux-driven-i-mx8m-nano-module-is-smallest-yet/"     class="post-67069"><span class="crp_title">Linux-driven i.MX8M Nano module is smallest yet</span></a></li><li><a href="http://linuxgizmos.com/variscite-launches-its-first-i-mx8x-module/"     class="post-63317"><span class="crp_title">Variscite unveils its first i.MX8X module</span></a></li><li><a href="http://linuxgizmos.com/pico-itx-sbc-runs-linux-on-i-mx8m-with-8gb-lpddr4/"     class="post-61515"><span class="crp_title">Pico-ITX SBC runs Linux on i.MX8M with 8GB LPDDR4</span></a></li></ul><div class="crp_clear"></div></div></p>							</div>
		</div>

<table align=center border=0 bordercolor="#ebebeb" cellpadding=0 cellspacing=0>
<tr><td bgcolor="#f4f4f4" align=center valign=middle>
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=22&pid=0&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
<br><br> 
<!-- tag for printer friendly display or pdf printout -->
<div class="printfriendly pf-alignleft"><a href="#" rel="nofollow" onclick="window.print();if(typeof(_gaq) != 'undefined') { _gaq.push(['_trackEvent','PRINTFRIENDLY', 'print', 'NULL']);
          }else if(typeof(ga) != 'undefined') {  ga('send', 'event','PRINTFRIENDLY', 'print', 'NULL'); } return false;" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; -moz-box-shadow: none; box-shadow:none; padding:0; margin:0" src="https://cdn.printfriendly.com/buttons/printfriendly-button-nobg.png" alt="Print Friendly, PDF & Email" /></a></div><!-- end of tag -->
<table width="100%" bordercolor="#ebebeb" border=1 cellpadding=10 cellspacing="0" align=center>
<tr><td align=center><b><font color="#4a8ca7" size=3>PLEASE COMMENT BELOW</font></b></td></tr></table>

	
<!-- You can start editing here. -->


			<!-- If comments are open, but there are no comments. -->

	

		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Please comment here...					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/linux-driven-module-and-starter-kit-tap-renesas-rz-g2/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&#038;postid=72960&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=blank&#038;greeting=Please+comment+here...&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=2c7f055b9b0835cab992bbebeec66dc93a19c257#parent=http%3A%2F%2Flinuxgizmos.com%2Flinux-driven-module-and-starter-kit-tap-renesas-rz-g2%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
		
	</div>

<div id="footer">
<table width="100%" border=0 bgcolor="#ebebeb" cellpadding=10 cellspacing=0><tr><td></td></tr></table>
<table align="center" width=100% height=90 border=0 bgcolor="#ebebeb" cellpadding=0 cellspacing=0><tr><td align="center" valign="middle">
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=23&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<center><a href="/contact"><font size="1.2em" color="#4a8ca7">(advertise here)</font></a></center>
<table width="100%" align=center border=0 bgcolor="#ebebeb" cellpadding=10 cellspacing=0><tr><td>	
<font size="1.2em"><i>The content on this site is copyright &copy; 2007-2020 LinuxGizmos.com unless otherwise noted.  Comments are the property of their submitters. LinuxGizmos is part of the <a href="http://circuitcellar.com/about-us/" target="new"><font color="#4a8ca7">KCK Media Corp. network</font></a>. Linux is a registered trademark of Linus Torvalds.</i></font></td></tr></table>
<!-- <br /><a href="feed:http://linuxgizmos.com/feed/">Entries (RSS)</a> --> <!-- and <a href="feed:http://linuxgizmos.com/comments/feed/">Comments (RSS)</a>. --> 	<!-- 46 queries. 0.115 seconds. -->
<!-- optional advertserve page peel tag can go below here -->
<!-- optional advertserve page peel tag can go above here -->
</div>
        <script type="text/javascript">
          var pfHeaderImgUrl = 'http://linuxgizmos.com/files/linuxgizmos-logo.jpg';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '1';
          var pfImagesSize = 'medium';
          var pfImageDisplayStyle = 'block';
          var pfEncodeImages = '0';
          var pfDisableEmail = '1';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
        </script>
        <script async src='https://cdn.printfriendly.com/printfriendly.js'></script>
      <link rel='stylesheet' id='simple-share-buttons-adder-ssba-css'  href='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=5.5.3' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: -1px solid #59625c;
									
									
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}

								.ssba-classic-2 .ssbp-text {
									display: none!important;
								}

								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px; }
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}
								

			   #ssba-bar-2 .ssbp-bar-list {
					max-width: 48px!important;;
			   }
			   #ssba-bar-2 .ssbp-bar-list li a {height: 48px!important; width: 48px!important; 
				}
				#ssba-bar-2 .ssbp-bar-list li a:hover {
				}

				#ssba-bar-2 .ssbp-bar-list li a::before {line-height: 48px!important;; font-size: 18px;}
				#ssba-bar-2 .ssbp-bar-list li a:hover::before {}
				#ssba-bar-2 .ssbp-bar-list li {
				margin: 0px 0!important;
				}@media only screen and ( max-width: 750px ) {
				#ssba-bar-2 {
				display: block;
				}
			}
@font-face {
				font-family: 'ssbp';
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=5.5.3' id='simple-share-buttons-adder-ssba-js'></script>
<script type='text/javascript' id='simple-share-buttons-adder-ssba-js-after'>
Main.boot( [] );
</script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.7' id='akismet-form-js'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=72960&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=2c7f055b9b0835cab992bbebeec66dc93a19c257#parent=http%3A%2F%2Flinuxgizmos.com%2Flinux-driven-module-and-starter-kit-tap-renesas-rz-g2%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=72960&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=2c7f055b9b0835cab992bbebeec66dc93a19c257#parent=http%3A%2F%2Flinuxgizmos.com%2Flinux-driven-module-and-starter-kit-tap-renesas-rz-g2%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202048.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.1',blog:'47422091',post:'72960',tz:'-8',srv:'linuxgizmos.com'} ]);
	_stq.push([ 'clickTrackerInit', '47422091', '72960' ]);
</script>
 
</body>
</html>
<!-- Dynamic page generated in 0.116 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-11-25 00:31:07 -->

<!-- super cache -->