<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
 
<title>Gumstix adds Arduino support for Curie-based boards designed with Geppetto</title>
<meta name="generator" content="WordPress 4.7.3"/>  
<link rel="stylesheet" href="http://linuxgizmos.com/wp-content/themes/BlackTower-lgw/style.css" type="text/css" media="screen"/>
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com RSS Feed" href="http://linuxgizmos.com/feed/"/>
<link rel="pingback" href="http://linuxgizmos.com/xmlrpc.php"/>
 
<link rel="author" href="https://plus.google.com/104414840801731506333"/>
<style type="text/css" media="screen">#headerimg{margin:0;margin-top:0px;height:80px;width:1022px;}#headerimg{background:url('http://linuxgizmos.com/wp-content/themes/BlackTower-lgw/images/header.jpg') no-repeat top;}</style>
 
<meta name="description" content="Gumstix added Arduino IDE support to its Geppetto design service for boards based on the Intel Curie. It also shipped a Curie-based “Radium 96BIE” board."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://linuxgizmos.com/gumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto/"/>
<link rel="publisher" href="https://plus.google.com/b/104414840801731506333/+LinuxGizmos"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Gumstix adds Arduino support for Curie-based boards designed with Geppetto"/>
<meta property="og:description" content="Gumstix added Arduino IDE support to its Geppetto design service for boards based on the Intel Curie. It also shipped a Curie-based “Radium 96BIE” board."/>
<meta property="og:url" content="http://linuxgizmos.com/gumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto/"/>
<meta property="og:site_name" content="LinuxGizmos.com"/>
<meta property="article:publisher" content="http://facebook.com/LinuxGizmos"/>
<meta property="article:section" content="SBCs &amp; COMs"/>
<meta property="article:published_time" content="2017-04-01T00:07:56-07:00"/>
<meta property="article:modified_time" content="2017-04-01T20:39:16-07:00"/>
<meta property="og:updated_time" content="2017-04-01T20:39:16-07:00"/>
<meta property="og:image" content="http://linuxgizmos.com/files/gumstix_radium96bie_2017_front-thm.jpg"/>
<meta property="og:image" content="http://linuxgizmos.com/files/gumstix_radium96bie_2017_front-sm.jpg"/>
<meta property="og:image" content="http://linuxgizmos.com/files/gumstix_radium96bie_2017_back-sm.jpg"/>
<meta property="og:image" content="http://linuxgizmos.com/files/gumstix_curie_geppetto_screen-sm.jpg"/>
<meta property="og:image" content="http://linuxgizmos.com/files/intel_curie_hand.jpg"/>
<meta property="og:image" content="http://linuxgizmos.com/files/gumstix_radium96bie_detail-sm.jpg"/>
<meta property="og:image" content="http://linuxgizmos.com/files/gumstix_radium96bie_detail2-sm.jpg"/>
 
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//w.sharethis.com'/>
<link rel='dns-prefetch' href='//ajax.googleapis.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com &raquo; Gumstix adds Arduino support for Curie-based boards designed with Geppetto Comments Feed" href="http://linuxgizmos.com/gumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/linuxgizmos.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='xyz_cfm_short_code_style-css' href='http://linuxgizmos.com/wp-content/plugins/contact-form-manager/css/xyz_cfm_shortcode_style.css?ver=4.7.3' type='text/css' media='all'/>
<link rel='stylesheet' id='jquery-style-css' href='http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=4.7.3' type='text/css' media='all'/>
<link rel='stylesheet' id='jetpack_css-css' href='http://linuxgizmos.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.7.1' type='text/css' media='all'/>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script id='st_insights_js' type='text/javascript' src='http://w.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare'></script>
<link rel='https://api.w.org/' href='http://linuxgizmos.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://linuxgizmos.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://linuxgizmos.com/wp-includes/wlwmanifest.xml"/>
<meta name="generator" content="WordPress 4.7.3"/>
<link rel='shortlink' href='http://wp.me/p3cYEr-eMf'/>
<link rel="alternate" type="application/json+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Fgumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Fgumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto%2F&#038;format=xml"/>
<script>(function(d, s, id){
                 var js, fjs = d.getElementsByTagName(s)[0];
                 if (d.getElementById(id)) {return;}
                 js = d.createElement(s); js.id = id;
                 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
                 fjs.parentNode.insertBefore(js, fjs);
               }(document, 'script', 'facebook-jssdk'));</script><style type="text/css">.ssba{padding:0px;border:0px solid #59625c;}.ssba img{width:25px!important;padding:15px;border:0;box-shadow:none!important;display:inline!important;vertical-align:middle;}.ssba,.ssba a{text-decoration:none;border:0;background:none;font-size:12px;color:#4d4d4d!important;font-weight:normal;}</style>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<style type="text/css" id="wp-custom-css">.commentlist li{font-size:1em;}</style>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5377446-2', 'linuxgizmos.com');
  ga('send', 'pageview');
</script>
</head>
<body>
<div id="page">
<div id="header">
<a href="http://linuxgizmos.com/">
<div id="headerimg">
 
</div>
</a>
</div>
<hr/>
 
<table align=center width="1022" height=25 border=0 cellpadding=0 cellspacing=0 bgcolor="#3b3b3b"><tr>
<td width="" align=center><a href="/"><font size="2em" color="white">All News</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/boards"><font size="2em" color="white">Boards</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/chips"><font size="2em" color="white">Chips</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/devices"><font size="2em" color="white">Devices</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/software"><font size="2em" color="white">Software</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="http://linuxdevices.linuxgizmos.com"><font size="2em" color="white"><font color="white">LinuxDevices.com Archive</b></font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/about"><font size="2em" color="white">About</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/contact"><font size="2em" color="white">Contact</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="#subscribe"><font size="2em" color="white">Subscribe</font></a></td>
</tr></table>
 
<table align=center width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>
 
<center><table width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white"><tr>
<td width=14></td>
<td align=left>
 
<table align=left width=728 height=90 border=1 bordercolor="#ebebeb" cellpadding=0 cellspacing=0 bgcolor="white"><tr><td>
 
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=20&pid=1&resolution='+screen.width+'x'+screen.height+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
 
</td></tr></table>
 
</td>
<td width=10></td>
<td width=250 border=0 align=center>
 
<table align=left cellpadding=5 cellspacing=0 border=0>
<tr><td align=center valign=middle><font size=2em color="#4a8ca7"><b>Follow LinuxGizmos:</b></font></td></tr>
<tr><td align=center valign=middle>
<a href="http://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter.png" alt="Twitter"></a>
<a href="https://plus.google.com/+LinuxGizmos/posts" rel="publisher" style="text-decoration:none;" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/gplus.png" alt="Google+"></a>
<a href="https://www.facebook.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="http://linuxgizmos.com/files/facebook.png" alt="Facebook"></a>
<a href="/feed/" target="new"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss.png" target="new"></a>
</td></tr>
<tr><td align=center valign=middle>(<a href="/#subscribe"><font size=2em color="#4a8ca7">get email updates</font></a>)</td></tr>
</table>
 
</td>
</tr></table></center>
 
<table align=center width="100%" height=3 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>
<div id="sidebar">
<div class="sidebar-right">
<ul>
<li id="search-3" class="widget widget_search"><h2 class="widgettitle">Search LinuxGizmos:</h2>
<form method="get" id="searchform" action="http://linuxgizmos.com/">
<div><input type="text" value="" name="s" id="s"/>
<input type="submit" id="searchsubmit" value="Search"/>
</div>
</form></li>
<li id="text-33" class="widget widget_text"><h2 class="widgettitle">Search LinuxGizmos.com + LinuxDevices Archive:</h2>
<div class="textwidget"><form action="http://linuxgizmos.com/search" id="cse-search-box">
<div>
<input type="hidden" name="cx" value="partner-pub-3975801459690075:2161158331"/>
<input type="hidden" name="cof" value="FORID:10"/>
<input type="hidden" name="ie" value="UTF-8"/>
<input type="text" name="q" size="23"/>
<input type="submit" name="sa" value="Search"/>
</div>
</form>
<script type="text/javascript" src="http://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script></div>
</li>
<li id="text-35" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
<div class="textwidget"><br>   
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/unique/javascript/strip?zid=18&pid=0&total=10&layout=vertical&margin=0&padding=15&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent(document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
 
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
</li>
<li id="top-posts-3" class="widget widget_top-posts"><h2 class="widgettitle">Top 10 trending posts&#8230; </h2>
<ul> <li>
<a href="http://linuxgizmos.com/rugged-open-spec-industrial-sbc-runs-linux-on-i-mx6/" class="bump-view" data-bump-view="tp">
Rugged, open-spec industrial SBC runs Linux on i.MX6 </a>
</li>
<li>
<a href="http://linuxgizmos.com/opengl-accelerated-games-come-to-raspberry-pi/" class="bump-view" data-bump-view="tp">
OpenGL accelerated x86 games come to Raspberry Pi </a>
</li>
<li>
<a href="http://linuxgizmos.com/linux-meet-displayport/" class="bump-view" data-bump-view="tp">
Linux, meet DisplayPort </a>
</li>
<li>
<a href="http://linuxgizmos.com/open-source-ota-software-targets-linux-devices/" class="bump-view" data-bump-view="tp">
Open source OTA software targets Linux devices </a>
</li>
<li>
<a href="http://linuxgizmos.com/gumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto/" class="bump-view" data-bump-view="tp">
Gumstix adds Arduino support for Curie-based boards designed with Geppetto </a>
</li>
<li>
<a href="http://linuxgizmos.com/ringing-in-2017-with-90-hacker-friendly-single-board-computers/" class="bump-view" data-bump-view="tp">
Ringing in 2017 with 90 hacker-friendly single board computers </a>
</li>
<li>
<a href="http://linuxgizmos.com/open-spec-iot-hacker-sbc-has-a-gsm-radio/" class="bump-view" data-bump-view="tp">
Open spec IoT hacker SBC has a GSM radio </a>
</li>
<li>
<a href="http://linuxgizmos.com/orange-pi-sbcs-offer-a-choice-of-32-or-64-bit-socs-for-under-20/" class="bump-view" data-bump-view="tp">
Orange Pi SBCs offer a choice of 32- or 64-bit SoCs for under $20 </a>
</li>
<li>
<a href="http://linuxgizmos.com/raspberry-pi-based-computer-offers-real-time-ethernet/" class="bump-view" data-bump-view="tp">
Raspberry Pi based computer offers Real-Time Ethernet </a>
</li>
<li>
<a href="http://linuxgizmos.com/quad-core-atom-thin-client-offers-hardened-thinlinux/" class="bump-view" data-bump-view="tp">
Quad-core Atom thin client offers hardened ThinLinux </a>
</li>
</ul></li>
<li id="text-18" class="widget widget_text"> <div class="textwidget"><a name="subscribe"></a></div>
</li>
<li id="text-3" class="widget widget_text"><h2 class="widgettitle">Follow LinuxGizmos or subscribe to our posts:</h2>
<div class="textwidget"></div>
</li>
<li id="text-37" class="widget widget_text"> <div class="textwidget"><table align=center><tr><td align=center valign=middle><h2>Follow:</h2></td><td align=center valign=middle><a href="http://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/twitter.png" alt="Twitter" target="new"></a> <a href="https://plus.google.com/+LinuxGizmos/posts" rel="publisher" style="text-decoration:none;" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/gplus.png" alt="Google+"></a> <a href="https://www.facebook.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=5 hspace=5 src="http://linuxgizmos.com/files/facebook.png" alt="Facebook"></a> <a href="/feed/"><img height=25 width=25 vspace=5 hspace=5 alt="RSS feed" src="http://linuxgizmos.com/files/rss.png" target="new"></a></td></tr></table></div>
</li>
<li id="blog_subscription-2" class="widget jetpack_subscription_widget"> <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
<div id="subscribe-text"><p>Enter your email address to receive notifications of new posts:</p>
</div> <p id="subscribe-email">
<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-2">
Email Address </label>
<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-2" placeholder="Email Address"/>
</p>
<p id="subscribe-submit">
<input type="hidden" name="action" value="subscribe"/>
<input type="hidden" name="source" value="http://linuxgizmos.com/gumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto/"/>
<input type="hidden" name="sub-type" value="widget"/>
<input type="hidden" name="redirect_fragment" value="blog_subscription-2"/>
<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget"/>
</p>
</form>
<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-2]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-2'),
					input = d.getElementById('subscribe-field-blog_subscription-2'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
</li>
<li id="text-36" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
<div class="textwidget"><br> 
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=21&pid=1&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
 
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
</li>
</ul>
</div>  
</div>
<div id="content" class="narrowcolumn">
<div class="post" id="post-56807">
<h2><a href="http://linuxgizmos.com/gumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto/" rel="bookmark" title="Permanent Link: Gumstix adds Arduino support for Curie-based boards designed with Geppetto">Gumstix adds Arduino support for Curie-based boards designed with Geppetto</a></h2>
<small>Apr 1, 2017 &mdash; by Eric Brown </small>
 
<small> &mdash; 289 views </small>
<div class="entrytext">
 <div class="ssba ssba-wrap"><div style="text-align:center"><a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=http://linuxgizmos.com/gumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto/&amp;text=Gumstix+adds+Arduino+support+for+Curie-based+boards+designed+with+Geppetto+" target="_blank"><img src="http://linuxgizmos.com/files/ssarbenta-twitter-lg.png" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter"/></a><a data-site="" class="ssba_google_share" href="https://plus.google.com/share?url=http://linuxgizmos.com/gumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto/" target="_blank"><img src="http://linuxgizmos.com/files/ssarbenta-google-lg.png" title="Share on Google+" class="ssba ssba-img" alt="Google+"/></a><a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=http://linuxgizmos.com/gumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto/" target="_blank"><img src="http://linuxgizmos.com/files/ssarbenta-facebook-lg.png" title="Facebook" class="ssba ssba-img" alt="Share on Facebook"/></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http://linuxgizmos.com/gumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto/" target="_blank"><img src="http://linuxgizmos.com/files/ssarbenta-linkedin-lg.png" alt="Share on LinkedIn" title="LinkedIn" class="ssba ssba-img"/></a><a data-site="reddit" class="ssba_reddit_share" href="http://reddit.com/submit?url=http://linuxgizmos.com/gumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto/&amp;title=Gumstix adds Arduino support for Curie-based boards designed with Geppetto" target="_blank"><img src="http://linuxgizmos.com/files/ssarbenta-reddit-lg.png" title="Reddit" class="ssba ssba-img" alt="Share on Reddit"/></a></div></div><p><img align=left vspace=5 hspace=10 src="/files/gumstix_radium96bie_2017_front-thm.jpg">Gumstix added Arduino IDE support to its Geppetto design service for boards based on the Intel Curie. It also shipped a Curie-based “Radium 96BIE” SBC.<br/>
<span id="more-56807"></span><br/>
Last September, Gumstix <a href="http://linuxgizmos.com/96boards-sbcs-host-intel-joule-and-curie-iot-modules/" target="new">unveiled two single board computers</a> based on Intel Joule and Curie modules, and built to 96Boards CE and the new, MCU-oriented 96Boards IE (IoT Edition) form-factor specifications, respectively. The Curie-based 96Boards IE compliant Radium 96BIE board is now available for $75, and Gumstix has also added Arduino IDE support for designing similar Curie-based boards in its Geppetto D2O custom board design and manufacturing service.<br/>
<center><br/>
<a href="/files/gumstix_radium96bie_2017_front.jpg" target="new"><img src="/files/gumstix_radium96bie_2017_front-sm.jpg" vspace=10 hspace=5 border=0></a> <a href="/files/gumstix_radium96bie_2017_back.jpg" target="new"><img src="/files/gumstix_radium96bie_2017_back-sm.jpg" vspace=10 hspace=5 border=0></a><br/>
<b>Radium 96BIE, front and back</b><br/>
(click images to enlarge)<br/>
</center><br/>
By adding Arduino IDE support for the Curie’s Quark SE MCU, both Arduino and Intel x86-oriented designers can use Geppetto to &#8220;rapidly design and manufacture small form-factor expansion boards for their wearables, IoT and robotic devices in minutes,&#8221; says Gumstix. &#8220;We are excited to support the Arduino community with a rapid, low cost and simple hardware design-to- order platform,&#8221; stated Gordon Kruberg, Gumstix CEO.</p>
<p>Designers can start with the Radium 96BIE design to prototype or create their own Curie-based custom expansion board design. During the free design process, users can compare alternatives for features and costs, create multiple projects, and share ideas, and then go straight from a design to an order in one session, says Gumstix. Custom BSPs and documentation are available with orders, and production quality boards are shipped in 15 business days. The initial manufacturing cost is $1,999, with discounts for quantity orders and repeat board spins.<br/>
<center><br/>
<a href="/files/gumstix_curie_geppetto_screen.jpg" target="new"><img src="/files/gumstix_curie_geppetto_screen-sm.jpg" vspace=10 hspace=5 border=0></a><br/>
<b>Sample MAV controller board design within Geppetto based on Intel Curie and incorporating Arduino 101 support</b><br/>
(click image to enlarge)<br/>
</center><br/>
To demonstrate the Arduino-on-Curie functionality, Gumstix has developed and posted specs for a tiny Arduino 101 compatible micro-drone, or MAV, controller board based on the Curie (see image above). Controlled via Bluetooth Low Energy, the board includes PWMs, ADCs, on-board barometer, and an expansion header for an optional Pre-GO GPS module. It also includes an RGB light sensor for overhead obstruction detection.<br/>
<center><br/>
<img src="/files/intel_curie_hand.jpg" vspace=10 hspace=5 border=0><br/>
<b>A handful of Intel Curie modules</b><br/>
</center><br/>
The Intel Curie’s 32MHz Quark SE chip offers a full Intel x86 instruction set architecture, as well as the Pentium support found on earlier Quarks. It&#8217;s supported by the open source Zephyr, among other RTOSes. The Intel Curie is further equipped with 80KB of SRAM, 384KB of flash, BLE, and a 6-axis IMU.<br/>
<center><br/>
<a href="/files/gumstix_radium96bie_detail.jpg" target="new"><img src="/files/gumstix_radium96bie_detail-sm.jpg" vspace=10 hspace=5 border=0></a> <a href="/files/gumstix_radium96bie_detail2.jpg" target="new"><img src="/files/gumstix_radium96bie_detail2-sm.jpg" vspace=10 hspace=5 border=0></a><br/>
<b>Radium 96BIE detail views</b><br/>
(click images to enlarge)<br/>
</center><br/>
The Radium 96BIE extends the module with the 30-pin 96Boards IE expansion connector, as well as a USB Type-C port, a micro-USB port for console access, and an FTDI FT232RQ USB/UART interface. There’s also a U.FL connector for the BLE radio. The board’s DC power is supplied through the USB Type-C port.</p>
<p>&nbsp;<br/>
<b>Further information</b></p>
<p>The Geppetto D2O Arduino IDE support for Intel Curie is available now. The Radium 96BIE board is available for $75. More information may be found at the newly redesigned <a href="https://www.gumstix.com/geppetto/" target="new">Geppetto site</a>, including <a href="https://www.gumstix.com/geppetto/intel-curie-module/" target="new">this page showing pin mapping</a> between the Curie module and the Arduino IDE. Also, check out the <a href="https://store.gumstix.com/expansion/radium-96bie.html" target="new">Radium 96BIE shopping page</a>.<br/>
&nbsp;</p>
<div class="crp_related "><h4>Related posts:</h4><ul><li><a href="http://linuxgizmos.com/96boards-sbcs-host-intel-joule-and-curie-iot-modules/"><span class="crp_title">96Boards SBCs host Intel Joule and Curie IoT modules</span></a></li><li><a href="http://linuxgizmos.com/linux-friendly-drone-controller-flies-on-intel-joule-power/"><span class="crp_title">Linux-friendly drone controller flies on Intel Joule power</span></a></li><li><a href="http://linuxgizmos.com/online-dev-tool-adds-diy-baseboard-for-raspberry-pi-compute-module/"><span class="crp_title">Online dev tool adds DIY baseboard for RPi Compute Module</span></a></li><li><a href="http://linuxgizmos.com/arduino-101-gains-faster-compiler-better-curie-support/"><span class="crp_title">Arduino 101 gains faster compiler, better Curie support</span></a></li><li><a href="http://linuxgizmos.com/imx6-based-iot-module-gains-an-easily-customizable-carrier-board/"><span class="crp_title">iMX6-based IoT module gains an easily customizable carrier&hellip;</span></a></li><li><a href="http://linuxgizmos.com/intel-joule-iot-module-gains-a-family-of-diy-companion-boards/"><span class="crp_title">Intel Joule IoT module gains a family of DIY companion&hellip;</span></a></li><li><a href="http://linuxgizmos.com/quick-turn-baseboard-dev-tool-adds-third-party-coms-and-sbcs/"><span class="crp_title">Quick-turn baseboard dev tool adds third-party COMs, SBCs</span></a></li><li><a href="http://linuxgizmos.com/sodimm-style-imx6-module-gains-diy-carrier-board/"><span class="crp_title">SODIMM-style i.MX6 module gains DIY carrier board</span></a></li><li><a href="http://linuxgizmos.com/online-carrier-board-dev-tool-adds-am335x-module-support/"><span class="crp_title">Online carrier board dev tool adds AM335x module support</span></a></li><li><a href="http://linuxgizmos.com/micro-uav-controller-features-open-modifiable-design/"><span class="crp_title">Micro-UAV controller features open, modifiable design</span></a></li></ul><div class="crp_clear"></div></div> </div>
</div>
<table width=468 height=60 align=center border=1 bordercolor="#ebebeb" cellpadding=0 cellspacing=0>
<tr><td bgcolor="#f4f4f4" align=center valign=middle>
 
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=22&pid=0&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
 
</td></tr></table>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
<br><br>
<table width="100%" bordercolor="#ebebeb" border=1 cellpadding=10 cellspacing="0" align=center>
<tr><td align=center><b><font color="#4a8ca7" size=3>PLEASE COMMENT BELOW</font></b></td></tr></table>
 
 
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Please comment here... <small><a rel="nofollow" id="cancel-comment-reply-link" href="/gumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto/#respond" style="display:none;">Cancel reply</a></small></h3>
<form id="commentform" class="comment-form">
<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&#038;postid=56807&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=blank&#038;greeting=Please+comment+here...&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=4.7.1&#038;sig=2699207569dded4ebf1074fb1cbed1c8b42f4c98#parent=http%3A%2F%2Flinuxgizmos.com%2Fgumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
<!--[if !IE]><!-->
<script>
					document.addEventListener( 'DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName( 'jetpack_remote_comment' );
						for ( var i = 0; i < commentForms.length; i++ ) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					} );
				</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value=""/>
</div>
<div id="footer">
 
<table width="100%" border=0 cellpadding=10 cellspacing=0><tr><td></td></tr></table>
<table align="center" width=728 height=90 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td border=1 bordercolor="#4a8ca7" bgcolor="#f4f4f4" align=center valign=middle>
 
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=23&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
 
</td></tr>
<tr><td></table>
<table width="100%" border=0 cellpadding=5 cellspacing=0><tr><td>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
</td></tr></table>
 
<div>
<font size=1><i>The content on this site is copyright &copy; 2007-2017 Rick Lehrbaum unless otherwise noted. Comments are the property of their submitters. Content originally published on LinuxDevices is Copyright &copy; 1999-2017 QuinStreet Inc. and is reproduced here under license from its owner. LinuxGizmos is part of the <a href="http://deviceguru.com/about/" target="new"><u>DeviceGuru Blog Network</u></a>. Linux is a registered trademark of Linus Torvalds.</i></font>
</div>
<br>
<div align=center>
<font size=1><a href="/contact"><font color="#4a8ca7"><u>Contact us</u></font></a> | <a href="http://www.deviceguru.com/privacy/"><font color="#4a8ca7"><u>Privacy policy</u></font></a> | <a href="/terms-of-use" target="new"><font color="#4a8ca7"><u>Terms of use</u></font></a> | <a href="/about"><font color="#4a8ca7"><u>About us</u></font></a> | <a href="/feed"><font color="#4a8ca7"><u>RSS feed</u></font></a> </font>
</div>
 
 
 
</div>
</div>
<div style="display:none">
</div>
<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"M. d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201713'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=56807&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.7.1&sig=2699207569dded4ebf1074fb1cbed1c8b42f4c98#parent=http%3A%2F%2Flinuxgizmos.com%2Fgumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=56807&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.7.1&sig=2699207569dded4ebf1074fb1cbed1c8b42f4c98#parent=http%3A%2F%2Flinuxgizmos.com%2Fgumstix-adds-arduino-support-for-curie-based-boards-designed-with-geppetto%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-201713.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.7.1',blog:'47422091',post:'56807',tz:'-7',srv:'linuxgizmos.com'} ]);
	_stq.push([ 'clickTrackerInit', '47422091', '56807' ]);
</script>
 
 
 
</body>
</html>