<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>Firefly&#039;s RK3399-based mini-PC can boot Ubuntu, Android, and media-savvy Station OS</title> 

<meta name="generator" content="WordPress 5.4.1" /> <!-- leave this for stats -->

<link rel="stylesheet" href="http://linuxgizmos.com/wp-content/themes/lg-theme/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com RSS Feed" href="http://linuxgizmos.com/feed/" />

<link rel="pingback" href="http://linuxgizmos.com/xmlrpc.php" />

<!-- G+ author attribution -->
<link rel="author" href="https://plus.google.com/104414840801731506333" />

<style type="text/css" media="screen">
	#headerimg { margin: 0; margin-top: 0px; height: 80px; width: 1022px; }
	#headerimg { background: url('http://linuxgizmos.com/wp-content/themes/lg-theme/images/header.jpg') no-repeat top;}
</style>

<script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script>
	<!-- This site is optimized with the Yoast SEO plugin v14.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Firefly’s “Station P1 Geek Mini PC” runs Ubuntu, Android, or an Android-based Station OS on an RK3399 and supports dual 4K displays. The price is $129 with 4GB LPDDR4 and 32GB eMMC or $179 with 4GB and 128GB." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Firefly&#039;s RK3399-based mini-PC can boot Ubuntu, Android, and media-savvy Station OS" />
	<meta property="og:description" content="Firefly’s “Station P1 Geek Mini PC” runs Ubuntu, Android, or an Android-based Station OS on an RK3399 and supports dual 4K displays. The price is $129 with 4GB LPDDR4 and 32GB eMMC or $179 with 4GB and 128GB." />
	<meta property="og:url" content="http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/" />
	<meta property="og:site_name" content="LinuxGizmos.com" />
	<meta property="article:publisher" content="http://facebook.com/LinuxGizmos" />
	<meta property="article:published_time" content="2020-06-02T22:03:12+00:00" />
	<meta property="og:image" content="http://linuxgizmos.com/files/firefly_stationp1-thm.jpg" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@LinuxGizmos" />
	<meta name="twitter:site" content="@LinuxGizmos" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://linuxgizmos.com/#website","url":"http://linuxgizmos.com/","name":"LinuxGizmos.com","description":"Embedded Linux news &amp; devices","potentialAction":[{"@type":"SearchAction","target":"http://linuxgizmos.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/#primaryimage","inLanguage":"en-US","url":"/files/firefly_stationp1-thm.jpg"},{"@type":"WebPage","@id":"http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/#webpage","url":"http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/","name":"Firefly's RK3399-based mini-PC can boot Ubuntu, Android, and media-savvy Station OS","isPartOf":{"@id":"http://linuxgizmos.com/#website"},"primaryImageOfPage":{"@id":"http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/#primaryimage"},"datePublished":"2020-06-02T22:03:12+00:00","dateModified":"2020-06-02T22:03:12+00:00","author":{"@id":"http://linuxgizmos.com/#/schema/person/6e28e3570b7dd729e9ff4170826bc3f7"},"description":"Firefly\u2019s \u201cStation P1 Geek Mini PC\u201d runs Ubuntu, Android, or an Android-based Station OS on an RK3399 and supports dual 4K displays. The price is $129 with 4GB LPDDR4 and 32GB eMMC or $179 with 4GB and 128GB.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/"]}]},{"@type":["Person"],"@id":"http://linuxgizmos.com/#/schema/person/6e28e3570b7dd729e9ff4170826bc3f7","name":"Eric Brown"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com &raquo; Firefly&#8217;s RK3399-based mini-PC can boot Ubuntu, Android, and media-savvy Station OS Comments Feed" href="http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/linuxgizmos.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://linuxgizmos.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://linuxgizmos.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.5' type='text/css' media='all' />
<script id='st_insights_js' type='text/javascript' src="https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare"></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://linuxgizmos.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://linuxgizmos.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://linuxgizmos.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.1" />
<link rel='shortlink' href='https://wp.me/p3cYEr-i14' />
<link rel="alternate" type="application/json+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Ffireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2Ffireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>

<!-- google adsense verification tag -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4310582701436176",
    enable_page_level_ads: true
  });
</script>
<!-- end google adsense verification tag -->
	
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5377446-2', 'linuxgizmos.com');
  ga('send', 'pageview');
</script>
	
<!-- clone of ssba css as of v7.4.10 -->
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=4.9.4' type='text/css' media='all' />

<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css'  href='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.9.4' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: 0px solid #59625c;
									
									
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								#ssba-classic-2 .ssbp-text {
									display: none!important;
								}
								
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px; }
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}
								
@font-face {
				font-family: 'ssbp';
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<!-- end clone of ssba css -->	
	
</head>
<body>
<div id="page">

<div id="header">

<!-- optional Advertserve page peel ad Display Code goes below here -->
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
_avp.push({ alias: '/', type: 'pagepeel', mid: 380, pid: 0 });
</script>
<!-- END ADVERTSERVE CODE -->

<a href="http://linuxgizmos.com/">
    <div id="headerimg">

     <!--
     <h1> <a href="http://linuxgizmos.com/">LinuxGizmos.com</a></h1> 
     <div class="description"><i>Embedded Linux news &amp; devices</i></div> 
     -->
    </div>

</a>

</div>

<hr />
<!-- section links start -->
<table align=center width="1022" height=25 border=0 cellpadding=0 cellspacing=0 bgcolor="#3b3b3b"><tr>
<td width="" align=center><a href="/"><font size="2em" color="white">All News</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/boards"><font size="2em" color="white">Boards</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/chips"><font size="2em" color="white">Chips</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/devices"><font size="2em" color="white">Devices</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/software"><font size="2em" color="white">Software</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="http://linuxdevices.org"><font size="2em" color="white"><font color="white">LinuxDevices.com Archive</b></font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/about"><font size="2em" color="white">About</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/contact"><font size="2em" color="white">Contact</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="#subscribe"><font size="2em" color="white">Subscribe</font></a></td>
</tr></table>
<!-- section links end -->

<table align=center width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

<!-- header banner wrapper starts -- NOTE: total width = 1022 px -->
<center><table width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white"><tr>

<td width=14></td>

<td align=left>
<!-- 728x90 ad goes below here -->
<table align=left width=728 height=90 border=1 bordercolor="#ebebeb" cellpadding=0 cellspacing=0 bgcolor="white"><tr><td>
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=20&pid=1&resolution='+screen.width+'x'+screen.height+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<!-- 728x90 ad goes above here -->
</td>

<td width=10></td>

<td width=250 border=0 align=center>
<!-- sharing and subscription block goes below here -->
<table align=left cellpadding=5 cellspacing=0 border=0>
<tr><td align=center valign=middle><font size=2em color="#4a8ca7"><b>Follow LinuxGizmos:</b></font></td></tr>
<tr><td align=center valign=middle>
<a href="https://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter-square-25px.png" alt="Twitter"></a> 
<a href="https://www.facebook.com/LinuxGizmos/posts/" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/facebook-square-25px.png" alt="Facebook"></a>  
<a href="https://www.pinterest.com/LinuxGizmos/" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/pinterest-square-25px.png" alt="Pinterest"></a> 
<a href="/feed/" target="new"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss-square-25px.png" target="new"></a>
</td></tr>
<tr><td align=center valign=middle><a href="/#subscribe"><font size=2em color="#4a8ca7"><b>*</b> &nbsp; get email updates &nbsp; <b>*</b></font></a></td></tr>
</table>
<!-- sharing and subscription block goes above here -->
</td>
</tr></table></center>
<!-- header banner wrapper ends -->

<table align=center width="100%" height=3 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

	<div id="sidebar">
	<div class="sidebar-right">
		<ul>
			<li id="search-3" class="widget widget_search"><h2 class="widgettitle">Search LinuxGizmos:</h2>
<form method="get" id="searchform" action="http://linuxgizmos.com/">
<div><input type="text" value="" name="s" id="s" />
<input type="submit" id="searchsubmit" value="Search" />
</div>
</form></li>
<li id="text-33" class="widget widget_text"><h2 class="widgettitle">Search LinuxGizmos.com + LinuxDevices Archive:</h2>
			<div class="textwidget"><form action="http://linuxgizmos.com/search" id="cse-search-box">
  <div>
    <input type="hidden" name="cx" value="partner-pub-3975801459690075:2161158331" />
    <input type="hidden" name="cof" value="FORID:10" />
    <input type="hidden" name="ie" value="UTF-8" />
    <input type="text" name="q" size="23" />
    <input type="submit" name="sa" value="Search" />
  </div>
</form>
<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script></div>
		</li>
<li id="text-35" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
			<div class="textwidget"><br><!-- BEGIN ZONE 2 ADVERTSERVE CODE --> <!-- set total to zone 2 (non-dg) campaigns minus 1 -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/unique/javascript/strip?zid=18&pid=1&total=13&layout=vertical&margin=0&padding=15&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent(document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
		</li>
<li id="top-posts-4" class="widget widget_top-posts"><h2 class="widgettitle">Top 10 trending posts&#8230;</h2>
<ul>				<li>
					<a href="http://linuxgizmos.com/timesys-and-nxp-partner-on-bsp-maintenance-service-for-embedded-linux/" class="bump-view" data-bump-view="tp">Timesys and NXP partner on BSP maintenance service for embedded Linux</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/" class="bump-view" data-bump-view="tp" aria-current="page">Firefly&#039;s RK3399-based mini-PC can boot Ubuntu, Android, and media-savvy Station OS</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/sata-hats-support-up-to-four-drives-on-raspberry-pi-4-or-rock-pi-4/" class="bump-view" data-bump-view="tp">SATA HATs support up to four drives on Raspberry Pi 4 or Rock Pi 4</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/low-cost-air-quality-sensor-works-with-raspberry-pi/" class="bump-view" data-bump-view="tp">Low-cost air quality sensor works with Raspberry Pi</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/10th-gen-comet-lake-computer-has-gtx-gpu-and-10-gbe-ports/" class="bump-view" data-bump-view="tp">10th Gen Comet Lake computer has GTX GPU and 10 GbE ports</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/compact-coffee-lake-system-features-hot-swappable-sata/" class="bump-view" data-bump-view="tp">Compact Coffee Lake system features hot-swappable SATA</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/cluster-platform-supports-seven-raspberry-pi-compute-modules/" class="bump-view" data-bump-view="tp">Cluster platform supports seven Raspberry Pi Compute Modules</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/facial-recognition-reader-includes-thermometry-and-card-readers/" class="bump-view" data-bump-view="tp">Facial recognition reader includes thermometry and card readers</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/udoo-bolt-gear-mini-pc-launches-with-ryzen-v1000-udoo-bolt-sbc/" class="bump-view" data-bump-view="tp">Udoo Bolt Gear mini-PC launches with Ryzen V1000 Udoo Bolt SBC</a>					</li>
								<li>
					<a href="http://linuxgizmos.com/raspberry-pi-4-gains-75-8gb-ram-version-releases-64-bit-raspberry-pi-os/" class="bump-view" data-bump-view="tp">Raspberry Pi 4 gains 8GB RAM version and 64-bit Raspberry Pi OS</a>					</li>
				</ul></li>
<li id="text-36" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
			<div class="textwidget"><br><!-- BEGIN ZONE 3 ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=21&pid=1&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
		</li>
<li id="text-18" class="widget widget_text">			<div class="textwidget"><a name="subscribe"></a></div>
		</li>
<li id="text-3" class="widget widget_text"><h2 class="widgettitle">Follow LinuxGizmos or subscribe to our posts:</h2>
			<div class="textwidget"></div>
		</li>
<li id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><table>
<tr><td align=center valign=middle>
&nbsp;&nbsp;
<a href="https://www.twitter.com/LinuxGizmos" target="new" rel="noopener noreferrer"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter-square-25px.png" alt="Twitter"></a>
<a href="https://www.facebook.com/LinuxGizmos/posts/" target="new" rel="noopener noreferrer"><img height=25 width=25 vspace=0 hspace=5 src="/files/facebook-square-25px.png" alt="Facebook"></a>
<a href="https://www.pinterest.com/LinuxGizmos/" target="new" rel="noopener noreferrer"><img height=25 width=25 vspace=0 hspace=5 src="/files/pinterest-square-25px.png" alt="Pinterest"></a>
<a href="/feed/" target="new" rel="noopener noreferrer"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss-square-25px.png" target="new"></a>
</td></tr></table></div></li>
<li id="blog_subscription-3" class="widget widget_blog_subscription jetpack_subscription_widget"><h2 class="widgettitle">Subscribe</h2>

            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
				                    <div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div><p>Join 1,256 other subscribers</p>
                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-3">
							email address                        </label>
                        <input type="email" name="email" required="required" class="required"
                               value=""
                               id="subscribe-field-blog_subscription-3"
                               placeholder="email address"/>
                    </p>

                    <p id="subscribe-submit">
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-3"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Subscribe                        </button>
                    </p>
				            </form>
		
</li>

		</ul>
	</div>	<!--sidebar-left-->


	</div>


	<div id="content" class="narrowcolumn">
				
  		
		<div class="post" id="post-69258">
			<h2><a href="http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/" rel="bookmark" title="Permanent Link: Firefly&#8217;s RK3399-based mini-PC can boot Ubuntu, Android, and media-savvy Station OS">Firefly&#8217;s RK3399-based mini-PC can boot Ubuntu, Android, and media-savvy Station OS</a></h2>

		<small>Jun 2, 2020 &mdash; by Eric Brown </small>

	<!-- tag for gapp post pageviews plugin -->
    <small>  </small> 

	<!-- tag for WP Stats View Counter -->
 <small> &mdash; 318 views</small>
			
			<div class="entrytext">
				<!-- Simple Share Buttons Adder (7.6.21) simplesharebuttons.com --><div class="ssba-classic-2 ssba ssbp-wrap left ssbp--theme-1"><div style="text-align:center"><span class="ssba-share-text">Please share:</span><a data-site="" class="ssba_twitter_share" href="https://twitter.com/share?url=http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/&amp;text=Firefly%E2%80%99s%20RK3399-based%20mini-PC%20can%20boot%20Ubuntu%2C%20Android%2C%20and%20media-savvy%20Station%20OS%20" target=&quot;_blank&quot;><img src="/files/twitter-square-25px.png" style="width: 25px;" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /><div title="Twitter" class="ssbp-text">Twitter</div></a><a data-site="" class="ssba_facebook_share" href="https://www.facebook.com/sharer.php?u=http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/" target="_blank"><img src="/files/facebook-square-25px.png" title="Facebook" style="width: 25px;" class="ssba ssba-img" alt="Share on Facebook" /><div title="Facebook" class="ssbp-text">Facebook</div></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/" target=&quot;_blank&quot;><img src="/files/linkedin-square-25px.png" alt="Share on LinkedIn" style="width: 25px;" title="LinkedIn" class="ssba ssba-img" /><div title="Linkedin" class="ssbp-text">Linkedin</div></a><a data-site="reddit" class="ssba_reddit_share" href="https://reddit.com/submit?url=http://linuxgizmos.com/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/&amp;title=Firefly&#8217;s RK3399-based mini-PC can boot Ubuntu, Android, and media-savvy Station OS" target=&quot;_blank&quot;><img src="/files/reddit-square-25px.png" style="width: 25px;" title="Reddit" class="ssba ssba-img" alt="Share on Reddit" /><div title="Reddit" class="ssbp-text">Reddit</div></a><a data-site='pinterest' class='ssba_pinterest_share' href='javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;//assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());'><img style="width: 25px;" title="Pinterest" class="ssba ssba-img" src="/files/pinterest-square-25px.png" alt="Pin on Pinterest" /><div title="Pinterest" class="ssbp-text">Pinterest</div></a><a data-site="email" class="ssba_email_share" href="/cdn-cgi/l/email-protection#fec18d8b9c949b9d8ac3b8978c9b989287dbccc8ddc6cccfc9c58ddbccceacb5cdcdc7c7d39c9f8d9b9adbccce93979097d3aebddbccce9d9f90dbccce9c91918adbccceab9c8b908a8bd2dbcccebf909a8c91979ad2dbccce9f909adbccce939b9a979fd38d9f888887dbcccead8a9f8a979190dbccceb1add8ddcecdc6c59c919a87c3dbccce968a8a8ec4d1d19297908b8699978493918dd09d9193d198978c9b9892878dd38c95cdcdc7c7d39c9f8d9b9ad393979097d38e9dd39d9f90d39c91918ad38b9c8b908a8bd39f909a8c91979ad39f909ad3939b9a979fd38d9f888887d38d8a9f8a979190d3918dd1"><img src="/files/email-square-25px.png" style="width: 25px;" title="Email" class="ssba ssba-img" alt="Email to someone" /><div title="email" class="ssbp-text">email</div></a></div></div><div class="pf-content"><p><img align=left vspace=5 hspace=10 src="/files/firefly_stationp1-thm.jpg">Firefly’s “Station P1 Geek Mini PC” runs Ubuntu, Android, or an Android-based Station OS on an RK3399 and supports dual 4K displays. The price is $129 with 4GB LPDDR4 and 32GB eMMC or $179 with 4GB and 128GB.<br />
<span id="more-69258"></span><br />
Since we covered Firefly’s Rockchip RK1808 based <a href="http://linuxgizmos.com/firefly-launches-rk1808-based-module-and-dev-kit-with-3-tops-npu/" target="new" rel="noopener noreferrer">Core-1808-JD4 AI Core Board</a> module and AIO-1808-JD4 dev kit in April, the company has launched a $129 and up Station P1 Geek Mini PC based on the Rockchip RK3399. Firefly, the community-backed SBC and compute module brand of T-Chip Technology, helped popularize the hexa-core Arm SoC with products such as its <a href="http://linuxgizmos.com/firefly-launches-rk1808-based-module-and-dev-kit-with-3-tops-npu/" target="new" rel="noopener noreferrer">Firefly-RK3399</a>, the world’s first RK3399 SBC.<br />
<center><br />
<a href="/files/firefly_stationp1_angle.jpg" target="new" rel="noopener noreferrer"><img src="/files/firefly_stationp1_angle-sm.jpg" vspace=10 hspace=5 border=0></a> <a href="/files/firefly_stationp1_kit.jpg" target="new" rel="noopener noreferrer"><img src="/files/firefly_stationp1_kit-sm.jpg" vspace=10 hspace=5 border=0></a><br />
<b>Station P1 Geek Mini PC (left) and kit contents</b><br />
(click images to enlarge)<br />
</center><br />
The Station P1 Geek Mini PC is a multipurpose consumer desktop replacement, gaming system, and video entertainment computer. The fanless, 124.4 x 79 x 31.6mm mini-PC can run Ubuntu, Android, and <a href="http://en.t-firefly.com/index.php/news/info/index/id/527.html" target="new" rel="noopener noreferrer">Station OS</a> on the RK3399. The RK3399 SoC has 2x up to 1.8GHz Cortex-A72 cores, 4x 1.42GHz Cortex-A53 cores, and a quad-core Mali-T864 GPU.</p>
<p>Station OS was jointly developed by Firefly and the <a href="http://www.phoenixos.com/en/download_x86" target="new" rel="noopener noreferrer">Phoenix OS</a> project and is based on Phoenix OS. Also referred to as the Geek Entertainment System, this dual mode OS let’s you easily switch between work and entertainment modes. The entertainment mode provides a “a strong local video library,” says Firefly. Station OS lets you load the distro alongside Android and Ubuntu and then triple boot between all three platforms.<br />
<center><br />
<a href="/files/firefly_stationos_work.jpg" target="new" rel="noopener noreferrer"><img src="/files/firefly_stationos_work-sm.jpg" vspace=10 hspace=5 border=0></a> <a href="/files/firefly_stationos_media.jpg" target="new" rel="noopener noreferrer"><img src="/files/firefly_stationos_media-sm.jpg" vspace=10 hspace=5 border=0></a><br />
<b>Station OS in work/study (left) and entertainment modes</b><br />
(click images to enlarge)<br />
</center><br />
The Station P1 is available for $129 with 4GB LPDDR4 and 32GB eMMC or $179 with 4GB LPDDR4 and 128GB eMMC. You also get 16MB SPI flash and the microSD slot.<br />
Firefly does not specify whether the Station P1 is built on an existing board or uses a custom mainboard. It’s possibly built around Firefly’s <a href="http://linuxgizmos.com/firefly-com-dual-boots-android-and-ubuntu-on-hexa-core-rk3399/" target="new" rel="noopener noreferrer">RK3399 Coreboard</a> compute module.</p>
<p><center><br />
<a href="/files/firefly_stationp1_detail.jpg" target="new" rel="noopener noreferrer"><img src="/files/firefly_stationp1_detail-sm.jpg" vspace=10 hspace=5 border=0></a><br />
<b>Station P1 detail views</b><br />
(click image to enlarge)<br />
</center><br />
The Station P1 is equipped with a GbE port and 2.4GHz 802.11n and Bluetooth 4.2 LE radios with external antenna. Media features include dual simultaneous displays of HDMI 2.0a with HDCP 1.3/2.2 and DisplayPort 1.2, both at up to <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="57631c1761671f2d79">[email&#160;protected]</a> The DP connection is enabled via a multi-mode USB 3.0 Type-C port. There is also an audio output jack and an IR remote.<br />
<center><br />
<img src="/files/firefly_stationp1.jpg" vspace=10 hspace=5 border=0><br />
<b>Station P1</b><br />
</center><br />
The Station P1 is further equipped with USB 3.0 and USB 2.0 host ports and a recovery key. The aluminum alloy enclosed system has a 12V/2A DC input. HDMI and USB Type-A to -C cables are included. Although Firefly typically produces open source hardware products, the Station P1 is not currently listed in the <a href="http://wiki.t-firefly.com/en/" target="new" rel="noopener noreferrer">Firefly wiki</a>.</p>
<p>&nbsp;<br />
<b>Further information</b></p>
<p>The Station P1 Geek Mini PC is available starting at $129. More information may be found in the <a href="http://en.t-firefly.com/index.php/news/info/index/id/531.html" target="new" rel="noopener noreferrer">announcement</a> and <a href="http://shop.t-firefly.com/goods.php?id=114" target="new" rel="noopener noreferrer">product/shopping page</a>.<br />
&nbsp;</p>
</div><div class="crp_related  "><h4>Related posts:</h4><ul><li><a href="http://linuxgizmos.com/firefly-com-dual-boots-android-and-ubuntu-on-hexa-core-rk3399/"     class="post-59394"><span class="crp_title">Firefly COM dual-boots Android and Ubuntu on&hellip;</span></a></li><li><a href="http://linuxgizmos.com/sandwich-style-rk3399-sbc-has-optional-nvme-and-4g/"     class="post-65353"><span class="crp_title">Sandwich-style RK3399 SBC has optional NVMe and 4G</span></a></li><li><a href="http://linuxgizmos.com/pico-itx-sbc-extends-hexa-core-rockchip-rk3399/"     class="post-60975"><span class="crp_title">Pico-ITX SBC extends hexa-core Rockchip RK3399</span></a></li><li><a href="http://linuxgizmos.com/mxm3-enabled-rk3399-board-blurs-lines-between-sbc-and-com/"     class="post-62592"><span class="crp_title">MXM3-enabled RK3399 board blurs lines between SBC and COM</span></a></li><li><a href="http://linuxgizmos.com/odroid-n2-sbc-launches-at-63-with-new-cortex-a73-soc/"     class="post-64210"><span class="crp_title">Odroid-N2 SBC launches at $63 with new Cortex-A73 SoC</span></a></li><li><a href="http://linuxgizmos.com/sandwich-style-hacker-board-debuts-new-quad-a7-rockchip-soc/"     class="post-62311"><span class="crp_title">Sandwich-style hacker board debuts new quad -A7 Rockchip SoC</span></a></li><li><a href="http://linuxgizmos.com/olimex-debuts-new-computer-on-module-format/"     class="post-59661"><span class="crp_title">New SODIMM-style COM standard to debut on an&hellip;</span></a></li><li><a href="http://linuxgizmos.com/signage-sbc-showcases-hexa-core-s922x/"     class="post-68124"><span class="crp_title">Signage SBC showcases hexa-core S922X</span></a></li><li><a href="http://linuxgizmos.com/hybrid-rk3399-com-sbc-hacker-board-can-plug-into-feature-rich-carrier/"     class="post-64541"><span class="crp_title">Hybrid RK3399 COM/SBC hacker board can plug into&hellip;</span></a></li><li><a href="http://linuxgizmos.com/rk3399-based-qseven-module-has-extended-temp-support/"     class="post-64201"><span class="crp_title">RK3399 based Qseven module has extended temp support</span></a></li></ul><div class="crp_clear"></div></div>							</div>
		</div>

<table align=center border=0 bordercolor="#ebebeb" cellpadding=0 cellspacing=0>
<tr><td bgcolor="#f4f4f4" align=center valign=middle>
<!-- BEGIN ADVERTSERVE CODE -->
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=22&pid=0&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
<br><br> 
<!-- tag for printer friendly display or pdf printout -->
<div class="printfriendly pf-alignleft"><a href="#" rel="nofollow" onclick="window.print();if(typeof(_gaq) != 'undefined') { _gaq.push(['_trackEvent','PRINTFRIENDLY', 'print', 'NULL']);
          }else if(typeof(ga) != 'undefined') {  ga('send', 'event','PRINTFRIENDLY', 'print', 'NULL'); } return false;" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; -moz-box-shadow: none; box-shadow:none; padding:0; margin:0" src="https://cdn.printfriendly.com/buttons/printfriendly-button-nobg.png" alt="Print Friendly, PDF & Email" /></a></div><!-- end of tag -->
<table width="100%" bordercolor="#ebebeb" border=1 cellpadding=10 cellspacing="0" align=center>
<tr><td align=center><b><font color="#4a8ca7" size=3>PLEASE COMMENT BELOW</font></b></td></tr></table>

	
<!-- You can start editing here. -->


			<!-- If comments are open, but there are no comments. -->

	

		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Please comment here...					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/fireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&#038;postid=69258&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=blank&#038;greeting=Please+comment+here...&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.5&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=a12d78f6e90902242e68093ab0a2a2650f20b914#parent=http%3A%2F%2Flinuxgizmos.com%2Ffireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
		
	</div>

<div id="footer">
<table width="100%" border=0 bgcolor="#ebebeb" cellpadding=10 cellspacing=0><tr><td></td></tr></table>
<table align="center" width=100% height=90 border=0 bgcolor="#ebebeb" cellpadding=0 cellspacing=0><tr><td align="center" valign="middle">
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=23&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<center><a href="/contact"><font size="1.2em" color="#4a8ca7">(advertise here)</font></a></center>
<table width="100%" align=center border=0 bgcolor="#ebebeb" cellpadding=10 cellspacing=0><tr><td>	
<font size="1.2em"><i>The content on this site is copyright &copy; 2007-2020 LinuxGizmos.com unless otherwise noted.  Comments are the property of their submitters. LinuxGizmos is part of the <a href="http://circuitcellar.com/about-us/" target="new"><font color="#4a8ca7">KCK Media Corp. network</font></a>. Linux is a registered trademark of Linus Torvalds.</i></font></td></tr></table>
<!-- <br /><a href="feed:http://linuxgizmos.com/feed/">Entries (RSS)</a> --> <!-- and <a href="feed:http://linuxgizmos.com/comments/feed/">Comments (RSS)</a>. --> 	<!-- 40 queries. 0.274 seconds. -->
<!-- optional advertserve page peel tag can go below here -->
<!-- optional advertserve page peel tag can go above here -->
</div>
        <script type="text/javascript">
          var pfHeaderImgUrl = 'http://linuxgizmos.com/files/linuxgizmos-logo.jpg';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '1';
          var pfImagesSize = 'medium';
          var pfImageDisplayStyle = 'block';
          var pfEncodeImages = '0';
          var pfDisableEmail = '1';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
        </script>
        <script async src='https://cdn.printfriendly.com/printfriendly.js'></script>
      <link rel='stylesheet' id='simple-share-buttons-adder-ssba-css'  href='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=5.4.1' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: -1px solid #59625c;
									
									
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								.ssba-classic-2 .ssbp-text {
									display: none!important;
								}
								
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px; }
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}
								

			   #ssba-bar-2 .ssbp-bar-list {
					max-width: 48px!important;;
			   }
			   #ssba-bar-2 .ssbp-bar-list li a {height: 48px!important; width: 48px!important; 
				}
				#ssba-bar-2 .ssbp-bar-list li a:hover {
				}
					
				#ssba-bar-2 .ssbp-bar-list li a::before {line-height: 48px!important;; font-size: 18px;}
				#ssba-bar-2 .ssbp-bar-list li a:hover::before {}
				#ssba-bar-2 .ssbp-bar-list li {
				margin: 0px 0!important;
				}@media only screen and ( max-width: 750px ) {
				#ssba-bar-2 {
				display: block;
				}
			}
@font-face {
				font-family: 'ssbp';
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=5.4.1'></script>
<script type='text/javascript'>
Main.boot( [] );
</script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
<script async="async" type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.5'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=69258&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=a12d78f6e90902242e68093ab0a2a2650f20b914#parent=http%3A%2F%2Flinuxgizmos.com%2Ffireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=69258&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=a12d78f6e90902242e68093ab0a2a2650f20b914#parent=http%3A%2F%2Flinuxgizmos.com%2Ffireflys-rk3399-based-mini-pc-can-boot-ubuntu-android-and-media-savvy-station-os%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202023.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.5',blog:'47422091',post:'69258',tz:'-7',srv:'linuxgizmos.com'} ]);
	_stq.push([ 'clickTrackerInit', '47422091', '69258' ]);
</script>
 
</body>
</html>
<!-- Dynamic page generated in 1.517 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-06-03 16:10:22 -->

<!-- super cache -->