<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>3rd gen kit for embedded linux self-training is Raspberry Pi B-based</title> 

<meta name="generator" content="WordPress 5.2.3" /> <!-- leave this for stats -->

<link rel="stylesheet" href="http://linuxgizmos.com/wp-content/themes/BlackTower-lgw/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com RSS Feed" href="http://linuxgizmos.com/feed/" />

<link rel="pingback" href="http://linuxgizmos.com/xmlrpc.php" />

<!-- G+ author attribution -->
<link rel="author" href="https://plus.google.com/104414840801731506333" />

<style type="text/css" media="screen">
	#headerimg { margin: 0; margin-top: 0px; height: 80px; width: 1022px; }
	#headerimg { background: url('http://linuxgizmos.com/wp-content/themes/BlackTower-lgw/images/header.jpg') no-repeat top;}
</style>

<script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script>
<!-- This site is optimized with the Yoast SEO plugin v12.0 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="3rd gen kit for embedded linux self-training is Raspberry Pi B-based" />
<meta property="og:description" content="The 3rd generation Embedded Linux Learning Kit from Intellimetrix includes a Raspberry Pi 3B board, a Pi HAT with peripherals, power supply, cables and Linux software. It also features a manual tailored specifically for self-teaching yourself embedded Linux. Intellimetrix has announced the immediate availability of the third generation of its Embedded Linux Learning Kit (E.L.L.K.). &hellip;" />
<meta property="og:url" content="http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/" />
<meta property="og:site_name" content="LinuxGizmos.com" />
<meta property="article:publisher" content="http://facebook.com/LinuxGizmos" />
<meta property="article:section" content="SBCs &amp; COMs" />
<meta property="article:published_time" content="2019-09-13T20:17:47+00:00" />
<meta property="article:modified_time" content="2019-09-14T14:44:03+00:00" />
<meta property="og:updated_time" content="2019-09-14T14:44:03+00:00" />
<meta property="og:image" content="http://linuxgizmos.com/files/Intellimetrix_ellk3_kit-thm.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="The 3rd generation Embedded Linux Learning Kit from Intellimetrix includes a Raspberry Pi 3B board, a Pi HAT with peripherals, power supply, cables and Linux software. It also features a manual tailored specifically for self-teaching yourself embedded Linux. Intellimetrix has announced the immediate availability of the third generation of its Embedded Linux Learning Kit (E.L.L.K.). [&hellip;]" />
<meta name="twitter:title" content="3rd gen kit for embedded linux self-training is Raspberry Pi B-based" />
<meta name="twitter:site" content="@LinuxGizmos" />
<meta name="twitter:image" content="http://linuxgizmos.com/files/Intellimetrix_ellk3_kit-thm.jpg" />
<meta name="twitter:creator" content="@LinuxGizmos" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://linuxgizmos.com/#website","url":"http://linuxgizmos.com/","name":"LinuxGizmos.com","potentialAction":{"@type":"SearchAction","target":"http://linuxgizmos.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/#primaryimage","url":"/files/Intellimetrix_ellk3_kit-thm.jpg"},{"@type":"WebPage","@id":"http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/#webpage","url":"http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/","inLanguage":"en-US","name":"3rd gen kit for embedded linux self-training is Raspberry Pi B-based","isPartOf":{"@id":"http://linuxgizmos.com/#website"},"primaryImageOfPage":{"@id":"http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/#primaryimage"},"datePublished":"2019-09-13T20:17:47+00:00","dateModified":"2019-09-14T14:44:03+00:00","author":{"@id":"http://linuxgizmos.com/#/schema/person/216a3c6d087ca6f2be4bfabf885e6f3d"}},{"@type":["Person"],"@id":"http://linuxgizmos.com/#/schema/person/216a3c6d087ca6f2be4bfabf885e6f3d","name":"Jeff Child","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="LinuxGizmos.com &raquo; 3rd gen kit for embedded linux self-training is Raspberry Pi B-based Comments Feed" href="http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/linuxgizmos.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://linuxgizmos.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://linuxgizmos.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.7.1' type='text/css' media='all' />
<script id='st_insights_js' type='text/javascript' src="https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare"></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://linuxgizmos.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://linuxgizmos.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://linuxgizmos.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.3" />
<link rel='shortlink' href='https://wp.me/p3cYEr-gZp' />
<link rel="alternate" type="application/json+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2F3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://linuxgizmos.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxgizmos.com%2F3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based%2F&#038;format=xml" />
    <style type="text/css" media="screen">
      div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited, div.printfriendly a:focus {
        text-decoration: none;
        border: none;
        -webkit-box-shadow:none!important;
        box-shadow:none!important;
      }
    </style>
           <style type="text/css" media="screen">
          div.printfriendly {
            margin: 12px 12px 12px 30px;
          }
          div.printfriendly a, div.printfriendly a:link, div.printfriendly a:visited {
            font-size: 14px;
            color: #6D9F00;
          }
        </style>
		<link rel="stylesheet" href="http://linuxgizmos.com/wp-content/plugins/printfriendly/printfriendly.css" media="screen"></style>
        <style type="text/css" media="print">
          .printfriendly {
            display: none;
          }
        </style>

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>

<!-- google adsense verification tag -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4310582701436176",
    enable_page_level_ads: true
  });
</script>
<!-- end google adsense verification tag -->
	
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5377446-2', 'linuxgizmos.com');
  ga('send', 'pageview');
</script>
	
<!-- clone of ssba css as of v7.4.10 -->
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=4.9.4' type='text/css' media='all' />

<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css'  href='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.9.4' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: 0px solid #59625c;
									
									
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								#ssba-classic-2 .ssbp-text {
									display: none!important;
								}
								
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px; }
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}
								
@font-face {
				font-family: 'ssbp';
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<!-- end clone of ssba css -->	
	
</head>
<body>
<div id="page">

<div id="header">

<!-- optional Advertserve page peel ad Display Code goes below here -->
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
_avp.push({ alias: '/', type: 'pagepeel', mid: 380, pid: 0 });
</script>
<!-- END ADVERTSERVE CODE -->

<a href="http://linuxgizmos.com/">
    <div id="headerimg">

     <!--
     <h1> <a href="http://linuxgizmos.com/">LinuxGizmos.com</a></h1> 
     <div class="description"><i>Embedded Linux news &amp; devices</i></div> 
     -->
    </div>

</a>

</div>

<hr />
<!-- section links start -->
<table align=center width="1022" height=25 border=0 cellpadding=0 cellspacing=0 bgcolor="#3b3b3b"><tr>
<td width="" align=center><a href="/"><font size="2em" color="white">All News</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/boards"><font size="2em" color="white">Boards</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/chips"><font size="2em" color="white">Chips</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/devices"><font size="2em" color="white">Devices</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/category/software"><font size="2em" color="white">Software</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="http://linuxdevices.org"><font size="2em" color="white"><font color="white">LinuxDevices.com Archive</b></font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/about"><font size="2em" color="white">About</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="/contact"><font size="2em" color="white">Contact</font></a></td>
<td width="1%" align=center valign=middle><font size="2em" color="#b0b0b0">&#124;</font></td>
<td width="" align=center><a href="#subscribe"><font size="2em" color="white">Subscribe</font></a></td>
</tr></table>
<!-- section links end -->

<table align=center width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

<!-- header banner wrapper starts -- NOTE: total width = 1022 px -->
<center><table width="100%" height=10 border=0 cellpadding=0 cellspacing=0 bgcolor="white"><tr>

<td width=14></td>

<td align=left>
<!-- 728x90 ad goes below here -->
<table align=left width=728 height=90 border=1 bordercolor="#ebebeb" cellpadding=0 cellspacing=0 bgcolor="white"><tr><td>
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=20&pid=1&resolution='+screen.width+'x'+screen.height+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<!-- 728x90 ad goes above here -->
</td>

<td width=10></td>

<td width=250 border=0 align=center>
<!-- sharing and subscription block goes below here -->
<table align=left cellpadding=5 cellspacing=0 border=0>
<tr><td align=center valign=middle><font size=2em color="#4a8ca7"><b>Follow LinuxGizmos:</b></font></td></tr>
<tr><td align=center valign=middle>
<a href="https://www.twitter.com/LinuxGizmos" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter-square-25px.png" alt="Twitter"></a> 
<a href="https://www.facebook.com/LinuxGizmos/posts/" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/facebook-square-25px.png" alt="Facebook"></a>  
<a href="https://www.pinterest.com/LinuxGizmos/" target="new"><img height=25 width=25 vspace=0 hspace=5 src="/files/pinterest-square-25px.png" alt="Pinterest"></a> 
<a href="/feed/" target="new"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss-square-25px.png" target="new"></a>
</td></tr>
<tr><td align=center valign=middle><a href="/#subscribe"><font size=2em color="#4a8ca7"><b>*</b> &nbsp; get email updates &nbsp; <b>*</b></font></a></td></tr>
</table>
<!-- sharing and subscription block goes above here -->
</td>
</tr></table></center>
<!-- header banner wrapper ends -->

<table align=center width="100%" height=3 border=0 cellpadding=0 cellspacing=0 bgcolor="white">
<tr><td align=center></td></tr></table>

	<div id="sidebar">
	<div class="sidebar-right">
		<ul>
			<li id="search-3" class="widget widget_search"><h2 class="widgettitle">Search LinuxGizmos:</h2>
<form method="get" id="searchform" action="http://linuxgizmos.com/">
<div><input type="text" value="" name="s" id="s" />
<input type="submit" id="searchsubmit" value="Search" />
</div>
</form></li>
<li id="text-33" class="widget widget_text"><h2 class="widgettitle">Search LinuxGizmos.com + LinuxDevices Archive:</h2>
			<div class="textwidget"><form action="http://linuxgizmos.com/search" id="cse-search-box">
  <div>
    <input type="hidden" name="cx" value="partner-pub-3975801459690075:2161158331" />
    <input type="hidden" name="cof" value="FORID:10" />
    <input type="hidden" name="ie" value="UTF-8" />
    <input type="text" name="q" size="23" />
    <input type="submit" name="sa" value="Search" />
  </div>
</form>
<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script></div>
		</li>
<li id="text-35" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
			<div class="textwidget"><br><!-- BEGIN ZONE 2 ADVERTSERVE CODE --> <!-- set total to zone 2 (non-dg) campaigns minus 1 -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/unique/javascript/strip?zid=18&pid=1&total=13&layout=vertical&margin=0&padding=15&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent(document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
		</li>
<li id="top-posts-3" class="widget widget_top-posts"><h2 class="widgettitle">Top 10 trending posts&#8230; </h2>
<ul>				<li>
										<a href="http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/" class="bump-view" data-bump-view="tp">
						3rd gen kit for embedded linux self-training is Raspberry Pi B-based					</a>
										</li>
								<li>
										<a href="http://linuxgizmos.com/qualcomm-ipq4019-based-som-and-dev-board-run-openwrt-linux/" class="bump-view" data-bump-view="tp">
						Qualcomm IPQ4019-based SOM and dev board run OpenWrt Linux					</a>
										</li>
								<li>
										<a href="http://linuxgizmos.com/raspberry-pi-clone-sports-1-84ghz-intel-cherry-trail-processor/" class="bump-view" data-bump-view="tp">
						Raspberry Pi clone sports 1.84GHz Intel Cherry Trail processor					</a>
										</li>
								<li>
										<a href="http://linuxgizmos.com/shipping-schedule-released-for-linux-driven-librem-5-phone/" class="bump-view" data-bump-view="tp">
						Shipping schedule released for Linux-driven Librem 5 phone					</a>
										</li>
								<li>
										<a href="http://linuxgizmos.com/arduino-mkrzero-shrinks-zero-to-mkr1000-dimensions/" class="bump-view" data-bump-view="tp">
						Arduino MKRZero shrinks Zero to MKR1000 dimensions					</a>
										</li>
								<li>
										<a href="http://linuxgizmos.com/worlds-first-amd-based-nuc-mini-pc-showcases-ryzen-r1000/" class="bump-view" data-bump-view="tp">
						World’s first AMD-based NUC mini-PC showcases Ryzen R1000					</a>
										</li>
								<li>
										<a href="http://linuxgizmos.com/rk3399-hacker-board-upgrade-adds-4gb-lpddr4-ram/" class="bump-view" data-bump-view="tp">
						RK3399 hacker board upgrade adds 4GB LPDDR4 RAM					</a>
										</li>
								<li>
										<a href="http://linuxgizmos.com/worlds-smallest-quad-core-sbc-starts-at-8-dollars/" class="bump-view" data-bump-view="tp">
						World’s smallest quad-core Linux SBC starts at $8					</a>
										</li>
								<li>
										<a href="http://linuxgizmos.com/3-5-inch-sbc-and-embedded-pc-feature-whiskey-lake-ue/" class="bump-view" data-bump-view="tp">
						3.5-inch SBC and embedded PC feature Whiskey Lake-UE					</a>
										</li>
								<li>
										<a href="http://linuxgizmos.com/arduino-yun-bounces-back-to-life-with-a-rev-2/" class="bump-view" data-bump-view="tp">
						Arduino Yun bounces back to life with a Rev 2					</a>
										</li>
				</ul></li>
<li id="text-36" class="widget widget_text"><h2 class="widgettitle">LinuxGizmos Sponsor ads:</h2>
			<div class="textwidget"><br><!-- BEGIN ZONE 3 ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=21&pid=1&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
<table width=300 border=0 cellpadding=5 cellspacing=0><tr><td align=center>
<a href="http://linuxgizmos.com/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></td></tr></table></div>
		</li>
<li id="text-18" class="widget widget_text">			<div class="textwidget"><a name="subscribe"></a></div>
		</li>
<li id="text-3" class="widget widget_text"><h2 class="widgettitle">Follow LinuxGizmos or subscribe to our posts:</h2>
			<div class="textwidget"></div>
		</li>
<li id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><table>
<tr><td align=center valign=middle>
&nbsp;&nbsp;
<a href="https://www.twitter.com/LinuxGizmos" target="new" rel="noopener noreferrer"><img height=25 width=25 vspace=0 hspace=5 src="/files/twitter-square-25px.png" alt="Twitter"></a>
<a href="https://www.facebook.com/LinuxGizmos/posts/" target="new" rel="noopener noreferrer"><img height=25 width=25 vspace=0 hspace=5 src="/files/facebook-square-25px.png" alt="Facebook"></a>
<a href="https://www.pinterest.com/LinuxGizmos/" target="new" rel="noopener noreferrer"><img height=25 width=25 vspace=0 hspace=5 src="/files/pinterest-square-25px.png" alt="Pinterest"></a>
<a href="/feed/" target="new" rel="noopener noreferrer"><img height=25 width=25 vspace=0 hspace=5 alt="RSS feed" src="/files/rss-square-25px.png" target="new"></a>
</td></tr></table></div></li>
<li id="blog_subscription-2" class="widget widget_blog_subscription jetpack_subscription_widget"><h2 class="widgettitle">Subscribe:</h2>

            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
				                    <div id="subscribe-text"><p>Enter your email address to receive notifications of new posts:</p>
</div>                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-2">
							Email Address                        </label>
                        <input type="email" name="email" required="required" class="required"
                               value=""
                               id="subscribe-field-blog_subscription-2"
                               placeholder="Email Address"/>
                    </p>

                    <p id="subscribe-submit">
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-2"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Subscribe                        </button>
                    </p>
				            </form>
		
</li>

		</ul>
	</div>	<!--sidebar-left-->


	</div>


	<div id="content" class="narrowcolumn">
				
  		
		<div class="post" id="post-65311">
			<h2><a href="http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/" rel="bookmark" title="Permanent Link: 3rd gen kit for embedded linux self-training is Raspberry Pi B-based">3rd gen kit for embedded linux self-training is Raspberry Pi B-based</a></h2>

		<small>Sep 13, 2019 &mdash; by Jeff Child </small>

	<!-- tag for gapp post pageviews plugin -->
    <small>  </small> 

	<!-- tag for WP Stats View Counter -->
 <small> &mdash; 1719 views</small>
			
			<div class="entrytext">
				<!-- Simple Share Buttons Adder (7.6.20) simplesharebuttons.com --><div class="ssba-classic-2 ssba ssbp-wrap left ssbp--theme-1"><div style="text-align:center"><span class="ssba-share-text">Please share:     </span><a data-site="" class="ssba_twitter_share" href="https://twitter.com/share?url=http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/&amp;text=3rd%20gen%20kit%20for%20embedded%20linux%20self-training%20is%20Raspberry%20Pi%20B-based%20" target=&quot;_blank&quot;><img src="http://linuxgizmos.com/files/twitter-square-25px.png" style="width: 25px;" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /><div title="Twitter" class="ssbp-text">Twitter</div></a><a data-site="" class="ssba_facebook_share" href="https://www.facebook.com/sharer.php?u=http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/" target="_blank"><img src="http://linuxgizmos.com/files/facebook-square-25px.png" title="Facebook" style="width: 25px;" class="ssba ssba-img" alt="Share on Facebook" /><div title="Facebook" class="ssbp-text">Facebook</div></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/" target=&quot;_blank&quot;><img src="http://linuxgizmos.com/files/linkedin-square-25px.png" alt="Share on LinkedIn" style="width: 25px;" title="LinkedIn" class="ssba ssba-img" /><div title="Linkedin" class="ssbp-text">Linkedin</div></a><a data-site="reddit" class="ssba_reddit_share" href="https://reddit.com/submit?url=http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/&amp;title=3rd gen kit for embedded linux self-training is Raspberry Pi B-based" target=&quot;_blank&quot;><img src="http://linuxgizmos.com/files/reddit-square-25px.png" style="width: 25px;" title="Reddit" class="ssba ssba-img" alt="Share on Reddit" /><div title="Reddit" class="ssbp-text">Reddit</div></a><a data-site='pinterest' class='ssba_pinterest_share' href='javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;//assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());'><img style="width: 25px;" title="Pinterest" class="ssba ssba-img" src="http://linuxgizmos.com/files/pinterest-square-25px.png" alt="Pin on Pinterest" /><div title="Pinterest" class="ssbp-text">Pinterest</div></a><a data-site="email" class="ssba_email_share" href="/cdn-cgi/l/email-protection#5b64282e39313e382f6668293f7e696b3c3e357e696b30322f7e696b3d34297e696b3e36393e3f3f3e3f7e696b3732352e237e696b283e373d762f293a323532353c7e696b32287e696b093a282b393e2929227e696b0b327e696b1976393a283e3f7d786b68636039343f22667e696b332f2f2b6174743732352e233c3221363428753834367468293f763c3e357630322f763d3429763e36393e3f3f3e3f763732352e2376283e373d762f293a323532353c76322876293a282b393e292922762b32763976393a283e3f74"><img src="http://linuxgizmos.com/files/email-square-25px.png" style="width: 25px;" title="Email" class="ssba ssba-img" alt="Email to someone" /><div title="email" class="ssbp-text">email</div></a></div></div><div class="pf-content"><p><img align=left vspace=5 hspace=10 src="/files/Intellimetrix_ellk3_kit-thm.jpg">The 3rd generation Embedded Linux Learning Kit from Intellimetrix includes a Raspberry Pi 3B board, a Pi HAT with peripherals, power supply, cables and Linux software. It also features a manual tailored specifically for self-teaching yourself embedded Linux.<br />
<span id="more-65311"></span><br />
Intellimetrix has announced the immediate availability of the third generation of its Embedded Linux Learning Kit (E.L.L.K.). The firm touts it as a complete, hands-on way to get started using embedded Linux. Intellimetrix is a consulting firm specializing in real-time and embedded training and software development.<br />
<center><br />
<a href="/files/Intellimetrix_ellk3_kit.jpg" target="new" rel="noopener noreferrer"><img src="/files/Intellimetrix_ellk3_kit-sm.jpg" vspace=10 hspace=5 border=0></a><br />
<b>3rd generation Embedded Linux Learning Kit</b><br />
(click image to enlarge)<br />
</center><br />
We covered an <a href="http://linuxdevices.org/hardware-software-kit-teaches-embedded-linux/" rel="noopener noreferrer" target="_blank">earlier version of Intellimetrix’s E.L.L.K 13 years ago</a> back when we were under the LinuxDevices banner. That earlier version included an Atmel Arm9 processor-based SBC as part the kit, while this new 3rd generation in based on the popular <a href="http://linuxgizmos.com/quad-core-64-bit-pi-3-is-official-with-wifi-bt-and-35-price/" rel="noopener noreferrer" target="_blank">Raspberry Pi 3B</a>. Besides the Raspberry Pi 3B, the E.L.L.K. comes with a Pi HAT that provides a range of common peripherals. Also included are a power supply, cables and a CD with a random collection of Linux software.</p>
<p>At the heart of the E.L.L.K. is a 100-plus page manual. The manual guides you through a number of topics, including (1) workstation and target setup and configuration; (2) basic application development and debugging; (3) building a kernel image and a root filesystem in flash; (4) accessing hardware with and without device drivers; and (5) networking and more.<br />
<center><br />
<a href="/files/Intellimetrix_ellk3_rpi3b.jpg" target="new" rel="noopener noreferrer"><img src="/files/Intellimetrix_ellk3_rpi3b-sm.jpg" vspace=10 hspace=5 border=0></a><br />
<b>Raspberry Pi B board with peripheral HAT included with kit</b><br />
(click image to enlarge)<br />
</center><br />
Doug Abbott, creator of the E.L.L.K. and principal consultant at Intellimetrix, contrasts the kit with the typical development kits, emphasizing that the E.L.L.K. is specifically designed to teach embedded Linux. “This is the kind of tool I wish I had had when I was climbing that steep Linux learning curve a few years back,” said Abbott. “The sample code has been written with clarity and readability in mind and the exercises move in a logical progression where each step builds on the ones before.”</p>
<p>“Each successive generation of the E.L.L.K has been smaller, faster, more capable, and cheaper than the predecessor”, says Abbot. Validating that statement, the 2006 Arm9 version mentioned earlier, cost at $349, while the new 3rd gen version costs only $139.</p>
<p>The Raspberry Pi 3B SBC included in the E.L.L.K. features: </p>
<ul>
<li>Quad-core 64-bit Arm Cortex-53 at 1.2GHz
<li>1 GB RAM
<li>Micro SD slot
<li>BCM43438 wireless LAN and Bluetooth Low Energy (BLE) on board
<li>10/100 Ethernet port
<li>4x USB 2.0 host ports, Type A
<li>Serial debug port, 3.3V signal levels
<li>Micro USB, primarily for power
</ul>
<p>More details on the <a href="http://linuxgizmos.com/quad-core-64-bit-pi-3-is-official-with-wifi-bt-and-35-price/">Raspberry Pi B can be found on our report here</a>.</p>
<p>In addition to the SBC, the kit contains: </p>
<ul>
<li>8 GB micro SD card with boot loader, Linux kernel, and root file system image
<li>Micro USB power supply
<li>Matrix Compact HAT that plugs into the 40-pin GPIO connector and provides a range of &#8220;n&#8221; peripheral devices
<li>DVD ROM with:
<ul>
<li>Yocto Project build system based on Poky 2.6, “thud”
<li>Eclipse integrated development environment (IDE)
<li>Sample source code
<li>Other miscellaneous “goodies”</ul>
</ul>
<p>&nbsp;<br />
<b>Further information</b></p>
<p>More information on the 3rd gen E.L.L.K. can be found on its <a href="http://www.intellimetrix.us/EmbeddedLinuxKit.html" rel="noopener noreferrer" target="_blank">product page</a>.  The regular pricing for the kit is $139, but Intellimetrix is selling the new E.L.L.K. at a introductory price of $109 including free USPS Priority shipping within the continental U.S. for the first 50 orders. Different individual parts of the E.L.L.K. may also be purchased separately. See the <a href="http://www.intellimetrix.us/store.html" rel="noopener noreferrer" target="_blank">Intellimetrix shopping pag</a>e for details.</p>
</div><div class="crp_related "><h4>Related posts:</h4><ul><li><a href="http://linuxgizmos.com/raspberry-pi-hat-does-hydroponic-root-zone-monitoring/"    ><span class="crp_title">Raspberry Pi HAT does hydroponic root zone monitoring</span></a></li><li><a href="http://linuxgizmos.com/raspberry-pi-zero-wh-adds-40-pin-gpio-header-to-zero-w/"    ><span class="crp_title">Raspberry Pi Zero WH adds 40-pin GPIO header to Zero W</span></a></li><li><a href="http://linuxgizmos.com/raspberry-pi-zero-w-adds-wifi-and-bluetooth-for-only-5-more/"    ><span class="crp_title">Raspberry Pi Zero W adds WiFi and Bluetooth for only $5 more</span></a></li><li><a href="http://linuxgizmos.com/raspberry-pi-based-garden-monitoring-system-supplies-five-sensors/"    ><span class="crp_title">Raspberry Pi based garden monitoring system supplies&hellip;</span></a></li><li><a href="http://linuxgizmos.com/tiny-iot-gateway-built-on-raspberry-pi-compute-module-wears-hats/"    ><span class="crp_title">Tiny IoT gateway built on Raspberry Pi Compute&hellip;</span></a></li><li><a href="http://linuxgizmos.com/cluster-platform-supports-seven-raspberry-pi-compute-modules/"    ><span class="crp_title">Cluster platform supports seven Raspberry Pi Compute Modules</span></a></li><li><a href="http://linuxgizmos.com/survey-shows-linux-and-freertos-out-front-in-embedded-tech/"    ><span class="crp_title">Survey shows Linux and FreeRTOS out front in embedded tech</span></a></li><li><a href="http://linuxgizmos.com/rpi-zero-w-based-robot-kits-offer-pan-tilt-cam-gps-and-tof-sensing/"    ><span class="crp_title">RPi Zero W based robot kits offer pan-tilt cam, GPS,&hellip;</span></a></li><li><a href="http://linuxgizmos.com/raspberry-pi-hat-handles-rfid-and-nfc/"    ><span class="crp_title">Raspberry Pi HAT spins up RFID and NFC</span></a></li><li><a href="http://linuxgizmos.com/jetson-nano-based-robotics-kit-connects-to-sparkfun-sensors/"    ><span class="crp_title">Jetson Nano based robotics kit connects to SparkFun sensors</span></a></li></ul><div class="crp_clear"></div></div>							</div>
		</div>

<table align=center border=0 bordercolor="#ebebeb" cellpadding=0 cellspacing=0>
<tr><td bgcolor="#f4f4f4" align=center valign=middle>
<!-- BEGIN ADVERTSERVE CODE -->
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=22&pid=0&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<center><a href="/contact"><font size=1 color="#4a8ca7">(advertise here)</font></a></center>
<br><br> 
<!-- tag for printer friendly display or pdf printout -->
<div class="printfriendly pf-alignleft"><a href="#" rel="nofollow" onclick="window.print();if(typeof(_gaq) != 'undefined') { _gaq.push(['_trackEvent','PRINTFRIENDLY', 'print', 'NULL']);
          }else if(typeof(ga) != 'undefined') {  ga('send', 'event','PRINTFRIENDLY', 'print', 'NULL'); } return false;" class="noslimstat" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="https://cdn.printfriendly.com/buttons/printfriendly-button-nobg.png" alt="Print Friendly, PDF & Email" /></a></div><!-- end of tag -->
<table width="100%" bordercolor="#ebebeb" border=1 cellpadding=10 cellspacing="0" align=center>
<tr><td align=center><b><font color="#4a8ca7" size=3>PLEASE COMMENT BELOW</font></b></td></tr></table>

	
<!-- You can start editing here. -->

	<h3 id="comments">
		2 responses to &#8220;3rd gen kit for embedded linux self-training is Raspberry Pi B-based&#8221;	</h3>

	<div class="navigation">
		<div class="alignleft"></div>
		<div class="alignright"></div>
	</div>

	<ol class="commentlist">
			<li class="comment even thread-even depth-1" id="comment-210974">
				<div id="div-comment-210974" class="comment-body">
				<div class="comment-author vcard">
						<cite class="fn">Nitin Bhaskar</cite> <span class="says">says:</span>		</div>
		
		<div class="comment-meta commentmetadata"><a href="http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/#comment-210974">
			Sep. 13, 2019 at 10:07 pm				</a>
						</div>

		<p>64-bit ARM cortex-A8?</p>

		<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-210974' data-commentid="210974" data-postid="65311" data-belowelement="div-comment-210974" data-respondelement="respond" aria-label='Reply to Nitin Bhaskar'>Reply</a></div>
				</div>
				</li><!-- #comment-## -->
		<li class="comment byuser comment-author-jeffchild bypostauthor odd alt thread-odd thread-alt depth-1" id="comment-210976">
				<div id="div-comment-210976" class="comment-body">
				<div class="comment-author vcard">
						<cite class="fn">Jeff Child</cite> <span class="says">says:</span>		</div>
		
		<div class="comment-meta commentmetadata"><a href="http://linuxgizmos.com/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/#comment-210976">
			Sep. 14, 2019 at 7:39 am				</a>
						</div>

		<p>Thanks for catching that.<br />
Looks like the wrong processor was listed for the Raspberry Pi 3B.<br />
Should be Quad-core 64-bit Arm Cortex-53 at 1.2GHz, not the Cortex-A8,<br />
We have made the correction.</p>

		<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-210976' data-commentid="210976" data-postid="65311" data-belowelement="div-comment-210976" data-respondelement="respond" aria-label='Reply to Jeff Child'>Reply</a></div>
				</div>
				</li><!-- #comment-## -->
	</ol>

	<div class="navigation">
		<div class="alignleft"></div>
		<div class="alignright"></div>
	</div>


		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Please comment here...					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&#038;postid=65311&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=blank&#038;greeting=Please+comment+here...&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=7.7.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=d0dae6e1ecb424e4426b6b66fc3e9a149ec07047#parent=http%3A%2F%2Flinuxgizmos.com%2F3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
		
	</div>

<div id="footer">
<table width="100%" border=0 bgcolor="#ebebeb" cellpadding=10 cellspacing=0><tr><td></td></tr></table>
<table align="center" width=100% height=90 border=0 bgcolor="#ebebeb" cellpadding=0 cellspacing=0><tr><td align="center" valign="middle">
<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
document.write('<scr'+'ipt src="http://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=23&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');
</script>
<!-- END ADVERTSERVE CODE -->
</td></tr></table>
<center><a href="/contact"><font size="1.2em" color="#4a8ca7">(advertise here)</font></a></center>
<table width="100%" align=center border=0 bgcolor="#ebebeb" cellpadding=10 cellspacing=0><tr><td>	
<font size="1.2em"><i>The content on this site is copyright &copy; 2007-2019 LinuxGizmos.com unless otherwise noted.  Comments are the property of their submitters. LinuxGizmos is part of the <a href="http://circuitcellar.com/about-us/" target="new"><font color="#4a8ca7">KCK Media Corp. network</font></a>. Linux is a registered trademark of Linus Torvalds.</i></font></td></tr></table>
<!-- <br /><a href="feed:http://linuxgizmos.com/feed/">Entries (RSS)</a> --> <!-- and <a href="feed:http://linuxgizmos.com/comments/feed/">Comments (RSS)</a>. --> 	<!-- 41 queries. 0.105 seconds. -->
<!-- optional advertserve page peel tag can go below here -->
<!-- optional advertserve page peel tag can go above here -->
</div>
      <script type="text/javascript">

          var pfHeaderImgUrl = 'http://linuxgizmos.com/files/linuxgizmos-logo.jpg';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '1';
          var pfImagesSize = 'medium';
          var pfImageDisplayStyle = 'block';
          var pfEncodeImages = '0';
          var pfDisableEmail = '1';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
      </script>
      <script async src='https://cdn.printfriendly.com/printfriendly.js'></script>
<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css'  href='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=5.2.3' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									padding: 0px;
									border: 0px solid #59625c;
									
									
								}
								.ssba img
								{
									width: 25px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								.ssba-classic-2 .ssbp-text {
									display: none!important;
								}
								
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 20px; }
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 12px;
									color: #4d4d4d!important;
									font-weight: normal;
								}
								

			   #ssba-bar-2 .ssbp-bar-list {
					max-width: 48px!important;;
			   }
			   #ssba-bar-2 .ssbp-bar-list li a {height: 48px!important; width: 48px!important; 
				}
				#ssba-bar-2 .ssbp-bar-list li a:hover {
				}
					
				#ssba-bar-2 .ssbp-bar-list li a::before {line-height: 48px!important;; font-size: 18px;}
				#ssba-bar-2 .ssbp-bar-list li a:hover::before {}
				#ssba-bar-2 .ssbp-bar-list li {
				margin: 0px 0!important;
				}@media only screen and ( max-width: 750px ) {
				#ssba-bar-2 {
				display: block;
				}
			}
@font-face {
				font-family: 'ssbp';
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201937'></script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=5.2.3'></script>
<script type='text/javascript'>
Main.boot( [] );
</script>
<script type='text/javascript' src='http://linuxgizmos.com/wp-includes/js/wp-embed.min.js?ver=5.2.3'></script>
<script async="async" type='text/javascript' src='http://linuxgizmos.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=65311&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=7.7.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=d0dae6e1ecb424e4426b6b66fc3e9a149ec07047#parent=http%3A%2F%2Flinuxgizmos.com%2F3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47422091&postid=65311&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=blank&greeting=Please+comment+here...&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=7.7.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=d0dae6e1ecb424e4426b6b66fc3e9a149ec07047#parent=http%3A%2F%2Flinuxgizmos.com%2F3rd-gen-kit-for-embedded-linux-self-training-is-raspberry-pi-b-based%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-201937.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.7.1',blog:'47422091',post:'65311',tz:'-7',srv:'linuxgizmos.com'} ]);
	_stq.push([ 'clickTrackerInit', '47422091', '65311' ]);
</script>
 
</body>
</html>